Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th January 2009, 09:46
kkonline kkonline is offline
Junior Member
 
Join Date: Aug 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default BIND9 errors

Hi,
Below are my zone files and i receive the errors as specified.
mysite.org.db
Code:
 BIND data file for mysite.org
;
$TTL    604800
@       IN      SOA     mysite.org. (
                            2007011501         ; Serial
                                  7200         ; Refresh
                                   120         ; Retry
                               2419200         ; Expire
                                604800)        ; Default TTL
;
@       IN      NS      ns1.ns.com.
@       IN      NS      ns2.ns.com.
mysite.org.    IN      MX      10      mail.mysite.org.
mysite.org.    IN      A       200.19.227.135
www                     IN      CNAME   mysite.org.
mail                    IN      A       200.19.227.135
ftp                     IN      CNAME   mysite.org.
mysite.org.         IN      TXT     "v=spf1 ip4:200.19.227.135 a mx ~all"
mail                    IN      TXT     "v=spf1 a -all"
mysite:/etc/bind/zones/master#
Code:
;
;dns_rdata_fromtext: mysite.org.db:10: near eol: unexpected end of input
zone mysite.org/IN: loading master file mysite.org.db: unexpected end of input
200.19.227.rev

Code:
mysite:/etc/bind/zones/master# more 200.19.227.rev
$TTL 1d ;
$ORIGIN 227.19.200.IN-ADDR.ARPA.
@       IN      SOA     ns1.ns.com.    (
                                       2007011501
                                       7200
                                       120
                                       2419200
                                       604800
)
        IN      NS      ns1.ns.com.
        IN      NS      ns2.ns.com.
1       IN      PTR     ns1.ns.com.
2       IN      PTR     ns2.ns.com.
mysite:/etc/bind/zones/master#
Code:
mysite:/etc/bind/zones/master# named-checkzone mysite.org 200.19.227.rev
200.19.227.rev:3: ignoring out-of-zone data (227.19.200.IN-ADDR.ARPA)
dns_rdata_fromtext: 200.19.227.rev:8: near eol: unexpected end of input
200.19.227.rev:12: ignoring out-of-zone data (1.227.19.200.IN-ADDR.ARPA)
200.19.227.rev:13: ignoring out-of-zone data (2.227.19.200.IN-ADDR.ARPA)
zone mysite.org/IN: loading master file 200.19.227.rev: unexpected end of input
How to correct these errors?
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2009, 15:08
lqman lqman is offline
Junior Member
 
Join Date: Jan 2009
Location: Indonesia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to lqman
Default

Your db file, contain wrong configuration, i will try to FIX it
mysite.org.db
Code:
;BIND data file for mysite.org : 
;
$TTL   604800
@       IN      SOA     ns1.mysite.org. yourmailaddress.mysite.org. (
                             2007011501         ; Serial
                                   7200         ; Refresh
                                    120         ; Retry
                                2419200         ; Expire
                                 604800)        ; Default TTL
;
@                IN      NS           ns1.ns.com.
@                IN      NS           ns2.ns.com.
@                IN      MX 10        mail.mysite.org.
@                IN      A            200.19.227.135

mail             IN      A           200.19.227.135
www              IN     CNAME        mysite.org.
ftp              IN     CNAME        mysite.org.
mysite.org.      IN     TXT          "v=spf1 ip4:200.19.227.135 a mx ~all"
pay attention to the log file :
Code:
;dns_rdata_fromtext: mysite.org.db:10: near eol: unexpected end of input
10 (numeric) means your error on line 10

Regards, LQman.
http://lqman.wordpress.com
Reply With Quote
  #3  
Old 12th January 2009, 14:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Remove the ; sign in line 10.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 13th January 2009, 07:31
lqman lqman is offline
Junior Member
 
Join Date: Jan 2009
Location: Indonesia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to lqman
Default

@ Falko
In my opinion.
The ; sign isn't counted, ; sign is only for comment.
I found the error, and i have fixed it and rewrite configuration with bold font.

@kkonline
ns1.mysite.org. -> information about authoritative nameserver in your domain / zone.
yourmailaddress.mysite.org. -> mail address domain administrator with special syntax (replace @ sign with . sign).
eg :
yourmailaddress@mysite.org = yourmailaddress.mysite.org
lqman@ee.its.ac.id = lqman.ee.its.ac.id
__________________
Be Polite, Don't Be r00t
http://lqman.wordpress.com
Reply With Quote
  #5  
Old 23rd November 2010, 23:20
miki86 miki86 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question

Hello
Can anyone help me with this im stuck and i don't know where my error is.
My reverse dns is not setup like it shuold be, i know this step is optional but i want to learn.

/etc/named.conf
Code:
zone "Z.Y.X.in-addr.arpa" {
	type master;
	file "/var/named/Z.Y.X.in-addr.arpa.rev";
	//allow-update { key “rndckey”; };
};
Z.Y.X.in-addr.arpa.rev
Code:
Z.Y.X.in-addr.arpa.	IN	SOA	ns1.example.com. webmaster.example.com (
        100	; serial
        30M	; refresh
        3600	; retry
        3W	; expiry
        38400 )		; minimum

@       IN      NS      ns1.example.com.
@       IN      NS      ns2.example.com.

1.0.0.127.in-addr.arpa.	IN	PTR	binggo.example.com.
This is the error im geting when trying to restart bind
Code:
Error in named configuration:
zone example.com/IN: loaded serial 100
dns_rdata_fromtext: /var/named/Z.Y.X.in-addr.arpa.rev:1: unexpected end of input
zone Z.Y.X.in-addr.arpa/IN: loading master file /var/named/Z.Y.X.in-addr.arpa.rev: unexpected end of input
_default/Z.Y.X.in-addr.arpa/IN: unexpected end of input
Of course Z.Y.X is my reversed ip address.
Reply With Quote
  #6  
Old 24th November 2010, 05:50
lqman lqman is offline
Junior Member
 
Join Date: Jan 2009
Location: Indonesia
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to lqman
Default

maybe you can try this one.

Quote:
$TTL 604800
$ORIGIN Z.Y.X.in-addr.arpa.
@ IN SOA ns1.example.com. webmaster.example.com. (

100 ; serial
30M ; refresh
3600 ; retry
3W ; expiry
38400 ) ; minimum

@ IN NS ns1.example.com.
@ IN NS ns2.example.com.

1 IN PTR binggo.example.com.
2 IN PTR bingoagain.example.com.
take a look at the bold characters.

I assume that Z.Y.X.in-addr.arpa = 0.0.127.in-addr.arpa
then, querying your dns server :
Quote:
nslookup 127.0.0.1 ns1.example.com
nslookup 127.0.0.2 ns1.example.com
or
nslookup 127.0.0.1 ns2.example.com
nslookup 127.0.0.2 ns2.example.com
for easier troubleshoot procces, you must pay attention to /var/log/syslog especially when restarting the named daemon / service
Quote:
tail -f /var/log/syslog
if you have ccze installed, you get colorize output with
Quote:
tail -f /var/log/syslog | ccze
I hope this can solve your error.
__________________
Be Polite, Don't Be r00t
http://lqman.wordpress.com

Last edited by lqman; 24th November 2010 at 06:02.
Reply With Quote
  #7  
Old 24th November 2010, 12:01
miki86 miki86 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you for replaying.

I tried changing my reverse zone file as you sugested and im still geting same error.

sysolg, same error as i posted above:
Code:
...in-addr.arpa.zone:1: unexpected end of input...
1 is for line one right?
I can't determine which line one is wrong, my named.conf or zone file
When i comment out zone calling in my named.conf file everything goes smoothly.

By the way i noticed some errors in log file, i dont know if they are related to bind:
Code:
Nov 24 11:54:14 server avahi-daemon[7428]: avahi-daemon 0.6.16 starting up.
Nov 24 11:54:14 server avahi-daemon[7428]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Nov 24 11:54:14 server avahi-daemon[7428]: dbus_bus_get(): Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
Nov 24 11:54:14 server avahi-daemon[7428]: WARNING: Failed to contact D-Bus daemon.
Reply With Quote
  #8  
Old 24th November 2010, 17:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by miki86 View Post
1 is for line one right?
Yes.

Quote:
Originally Posted by miki86 View Post
I can't determine which line one is wrong, my named.conf or zone file
It's line 1 of the zone file.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 24th November 2010, 18:50
miki86 miki86 is offline
Junior Member
 
Join Date: Nov 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes but what's wrong with it?
Code:
Z.Y.X.in-addr.arpa.	IN	SOA	ns1.example.com. webmaster.example.com (
Looks like the link permissions are not right, since i installed bind-chroot i cant change permission on that link, chown passed but again link owner group is root

Any ideas?
Reply With Quote
  #10  
Old 25th November 2010, 14:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Make your zonefile look as suggested in post #6.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fresh onstall of Debian - getting errors in log for bind9 mspIggy Installation/Configuration 1 16th July 2008 12:12
bind9 and mySQL errors FuzzMaster HOWTO-Related Questions 5 12th March 2008 20:22
ispconfig installation errors kcmohan Installation/Configuration 1 9th April 2007 21:14
Install Errors DarkLord00 Installation/Configuration 12 25th February 2007 18:49
PHP Errors in the "WEB-FTP" module crudolphy General 9 27th December 2005 21:17


All times are GMT +2. The time now is 22:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.