Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 3rd November 2011, 11:03
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
The biggest note: Don't place an "upgrade" link inside of any software design when you don't know or intend for it to function perfectly. If your original intent is for any upgrade to perform at its best through SSH, remove the option to update by CPanel.
The upgrade link works fine on my systems. Just tested the upgrade again from 3.0.3.3 to 3.0.4. That I recommend to use the shell script is just a general consideration as you have more control over the update process and see error messages. It does not mean that the update function in the interface dont work. You mentioned above that the update link in the dashboard opened the auto update page as you clicked on it, on my servers it opened the ispconfig.org download page where you find the download link and release notes with instructions for this specific update.

I'am not able to help you with the issues on your server if you dont answer the questions that I ask you.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #22  
Old 3rd November 2011, 11:23
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

The upgrade link you're referring to is located at the top, as an alert, not the link that is there at all times, located on the bottom left under "System". This link in always available in ISPConfig. The "notice" (top center) takes you to the download link, yes. This is not what I used. I elected to use the "System" "Update ISPConfig" (lower left)

The amavisd.conf was wiped-out...empty. I "robbed" a copy of the file from server two, which is still ISPC 3.0.3.3 and that did the trick. At the moment, I am attempting to treat Dovecot the same way, only it is tricker. Fedora 14 64 bit in ISPConfig only works w/ dovecot 1.2.x, ot the latest 2.0.x (this should have been implemented with the update of ISPConfig....the ATRM for fed. 14 65 bit in 1.2.x is no longer even listed as a link rpm. Deprecated) So, the mail is still stuck in the clientmqueue. Amavisd is running fine. Postfix is fine

This file (and path) does exist. config.inc.php The file is empty.
Reply With Quote
  #23  
Old 3rd November 2011, 11:35
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Ok, Till

Progress. I robbed this file too from the other server. However, it won't let me log in because it is stating "Incorrect Password" The MySql DB is running, this file was "robbed" from a server with ISPConfig 3.0.3.3. Do any changes need to be made? Where can I reset the password? The mail system no longer works, so that is not an option. At least the 500 IS error is gone and the CPanel interface launches (or tries to)

Thanks.
Reply With Quote
  #24  
Old 3rd November 2011, 12:01
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

You still havent answered a lot of questions from the above posts, so I dont know what you did from the suggested steps and you did not post the messages that you got after running the update manually. So I can mainly guess what you did till now due to lack of posted infos.

Quote:
Do any changes need to be made?
Yes. Please download ispconfig 3.0.4, you can find the master template for the file in install/tpl/config.inc.php.master. Use that file and just replace the login details in the lines:

$conf['db_host'] = '{mysql_server_host}';
$conf['db_database'] = '{mysql_server_database}';
$conf['db_user'] = '{mysql_server_ispconfig_user}';
$conf['db_password'] = '{mysql_server_ispconfig_password}';

with the correct details for your setup. The details for your setup can be found e.g. in the mysql* files in the /etc/postfix/ directory. Dont reset the password of the ispconfig user in mysql, instaed check if the password in the postfix files work and then use that password in the ispconfig config.inc.php file.

Quote:
he mail system no longer works, so that is not an option.
Again, if you dont post details, nobody will be able to help you!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #25  
Old 3rd November 2011, 12:08
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Till,

I reviewed each of your requests and can't seem to find one that I did not give you the direct outcome, output, etc. Just looked through the threads and didn't see one unanswered????
Reply With Quote
  #26  
Old 3rd November 2011, 12:20
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Also,

I have posted this at least twice. I can't download 3.0.4 because I get this error:

PHP notice: Undefined variable: conf in /tmp/ispconfig3_install/install/update.php on line 76
Reply With Quote
  #27  
Old 3rd November 2011, 12:27
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

- #6 No file content posted (not nescessary to post it anymore as you seem to reach the interface again, just listed here as example for what I mean).
- Have you done #17? Is DNS working again after you fixed that so that you could redo #12? Have ou redone #12 then?
- Whats with #19 2)?
- Whats with #24, mailsystem errors?

Please dont get me wrong, this is not meant as rant. But if I dont get detailed information about the problem and which steps you did already, I simply cant help much.

Just a guess for the reasons of your problems, have you edited the php.ini on your server and changed any values since you installed ispconfig? Especially have you disabled any php functions by adding them to "disable_functions" in php.ini?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #28  
Old 3rd November 2011, 12:28
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
Originally Posted by midcarolina View Post
Also,

I have posted this at least twice. I can't download 3.0.4 because I get this error:

PHP notice: Undefined variable: conf in /tmp/ispconfig3_install/install/update.php on line 76
And I posted what you should check in post #17 to solve that.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #29  
Old 3rd November 2011, 12:44
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Till,

OK, Here we go:

#17 Check
#12 Check - does not work - errors sent
#19 - 2 Check
#24 Maillogs - This excerpt is fairly repetitive, it pretty much repeats on this block of info:

Nov 3 03:26:56 webserverone postfix/smtpd[2242]: connect from ham-cannon.twitter.com[199.59.148.231]
Nov 3 03:26:56 webserverone postfix/smtpd[2242]: warning: SASL: Connect to private/auth failed: No such file or directory
Nov 3 03:26:56 webserverone postfix/smtpd[2242]: fatal: no SASL authentication mechanisms
Nov 3 03:26:57 webserverone postfix/master[13821]: warning: process /usr/libexec/postfix/smtpd pid 2242 exit status 1
Nov 3 03:26:57 webserverone postfix/master[13821]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling
Nov 3 03:28:37 webserverone postfix/anvil[2244]: statistics: max connection rate 1/60s for (smtp:199.59.148.231) at Nov 3 03:26:56
Nov 3 03:28:37 webserverone postfix/anvil[2244]: statistics: max connection count 1 for (smtp:199.59.148.231) at Nov 3 03:26:56
Nov 3 03:28:37 webserverone postfix/anvil[2244]: statistics: max cache size 1 at Nov 3 03:26:56
Nov 3 03:32:19 webserverone clamd.amavisd[2002]: SelfCheck: Database status OK.

I have made very little changes to php.ini. I think maybe file upload size is it.

Also, for the file that needs revision (for CPanel login), does the "host" need to change to "localhost" and db to "ispconfigdb" or leave at defaults and change only username and password?

Thanks Till
Reply With Quote
  #30  
Old 3rd November 2011, 13:41
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
 
Default

Till,

I have done everything in the book to change the password in the config.php file and nothing works. (Control Panel Interface)

/etc/resolv.conf brings an error nameserver not found. Open the file and there they are...plain as day. All of my sites are live...servers running, so the nameservers are working?
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3.0.4

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02


All times are GMT +2. The time now is 18:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.