Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th October 2011, 04:41
GoremanX GoremanX is offline
Member
 
Join Date: Apr 2010
Posts: 49
Thanks: 2
Thanked 0 Times in 0 Posts
Default HTTPS For ISPConfig3

How do I change the ispconfig vhost to be accessible only via https? Running ISPConfig 3.0.3.3 on Ubuntu 10.04. I can't find any option for it in the control panel, or any place to put in my SSL certificate.
Reply With Quote
Sponsored Links
  #2  
Old 28th October 2011, 09:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Download ispconfig tar.gz, run update.php script. The updater will then ask you if it shall create a ssl cert for ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th October 2011, 06:24
GoremanX GoremanX is offline
Member
 
Join Date: Apr 2010
Posts: 49
Thanks: 2
Thanked 0 Times in 0 Posts
Default

That part worked, but I still get Secure Connection Failed when I try to access ispconfig3 using https

The ISPConfig vhost file does have the following in it:
Quote:
# SSL Configuration
SSLEngine On
SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key

Last edited by GoremanX; 29th October 2011 at 06:31.
Reply With Quote
  #4  
Old 29th October 2011, 06:33
GoremanX GoremanX is offline
Member
 
Join Date: Apr 2010
Posts: 49
Thanks: 2
Thanked 0 Times in 0 Posts
Default

nevermind, I had to do a /etc/init.d/apache2 reload before it took effect. I guess I assumed the update.php script did that for me.
Reply With Quote
  #5  
Old 29th October 2011, 06:50
GoremanX GoremanX is offline
Member
 
Join Date: Apr 2010
Posts: 49
Thanks: 2
Thanked 0 Times in 0 Posts
Default

If the ISPConfig vhost has SSL enabled, does that mean no other vhost on that server can have SSL enabled?
Reply With Quote
  #6  
Old 30th October 2011, 10:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Prior to ISPConfig 3.0.4 (which will be released soon) you can have just one SSL vhost per IP address. In ISPConfig 3.0.4, you can enable SNI (Server Name Indication) so that you can have multiple SSL vhosts per IP (please note that not all browsers support this).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 11th November 2011, 13:31
stevegjacobs stevegjacobs is offline
Junior Member
 
Join Date: Sep 2008
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default ssl cert for single site

Hi
I chose having ispconfig only available at https when i installed it. I want to only have one ip address on this server and also have a signed certificate installed that will only work for www.mydomainname.com (the only web site on the server that needs a cert)

My question is, is there some way can I use the same certificate for the www.mydomain.com site as for www.mydomain.com:8080? If so, how can I set this up?

As I said, I won't need ssl on any other site for this server - and if I do i will add more ip addrresses

Thanks
Reply With Quote
  #8  
Old 11th November 2011, 13:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Make a copy of the signed ssl certificate and copy it to the ispconfig ssl folder so that it replaces the existing cert and key file in /usr/local/ispconfig/interface/ssl/. Then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 11th November 2011, 14:37
stevegjacobs stevegjacobs is offline
Junior Member
 
Join Date: Sep 2008
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default

Something has gone wrong. The web site has disappeared - when I go to www.domainname.com, I am seeing only the default web page of the server, not the web site that wsa working a little while ago.
I had a look at the site vhost file in /etc/apache2/sites-enabled, and it looks ok to me.

and running /etc/init.d/apache2 restart gives NameVirtualHost xxx.xxx.xxx.xxx has no Virtualhosts
and
NameVirtualhost xxx.xxx.xxx.xxx:442 has no VirtualHosts

Last edited by stevegjacobs; 11th November 2011 at 14:41.
Reply With Quote
  #10  
Old 11th November 2011, 17:19
stevegjacobs stevegjacobs is offline
Junior Member
 
Join Date: Sep 2008
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
 
Default Till - here is what is happening..

Something is going wrong with the implementation of ssl on this server (ispconfig 3.04 - ubuntu 11.10 on a virtual machine)
  1. I've set up a site domainname.com in client1/web1 - and enabled ssl
  2. I tick it for ssl
  3. Assign the one ip address to client1 and then to web 1
  4. As soon as I save when I do that, www.domainname.com shows root of web (It Works! page from /var/www/)
  5. I then delete the ip address from the client, and website shows home page in client1/web1/web/

I also tried setting up this site without an ip address and when I create the certificate, apache dies and won't restart till I delete all references to ssl in sites-available/mydomain.vhost. And I know it says that you can't do that anyway.

Any ideas? I need this done today!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig: from http to https & from https to http Hans Tips/Tricks/Mods 13 12th March 2013 23:22
400 Bad Request when https is used Overcrook Installation/Configuration 7 5th October 2011 02:02
3 Question SSL cert, https redirect, WebFtp, serkejal Installation/Configuration 8 19th April 2011 19:10
squid and https passthrough Xitron Installation/Configuration 0 5th November 2009 18:40
Can ISPConfig listen on http & https? spidie Installation/Configuration 2 31st July 2007 02:53


All times are GMT +2. The time now is 08:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.