Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Suggest HOWTO

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th October 2011, 03:08
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
Default ModSecurity on Debian Squeeze

I found an article on http://www.debian-administration.org/articles/65, but it's older article and needs this to Debian Squeeze. Could anybody make a tutorial to me? Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 25th October 2011, 09:20
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Err .. search howtofoge.com better :P

http://www.howtoforge.com/apache_mod_security

it works on squeeze as well..
__________________
Real men don't backup... Real men cry!

http://www.e-rave.nl/
Reply With Quote
  #3  
Old 25th October 2011, 18:46
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Mark_NL View Post
Err .. search howtofoge.com better :P

http://www.howtoforge.com/apache_mod_security

it works on squeeze as well..
You does not read comments there. Read last comment:

"Tried this on Squeeze for apache2:
# apt-get install libapache2-mod-security
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libapache2-mod-security


So tried your one:
apt-get install libapache-mod-security
Which was installed into the mods-enabled dir.
Sadly, your Sec* entries above fail:
# /etc/init.d/apache2 restart
Syntax error on line 219 of /etc/apache2/apache2.conf:
Invalid command 'SecFilterEngine', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed."

That could be problem if i do this. Because I need a tutorial for this.
Reply With Quote
  #4  
Old 26th October 2011, 11:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Did you enable the module after installation? It's probably something like
Code:
a2enmod mod-security
or
Code:
a2enmod security
Restart Apache afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 26th October 2011, 12:29
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
Default

Okay. I tried to install modsecurity, it does works. i understand why it is problem what it say in comment on debian-administratation.com. Do I need any more to configure it to more security?
Reply With Quote
  #6  
Old 20th May 2012, 21:22
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 263
Thanks: 32
Thanked 6 Times in 5 Posts
 
Default

Hi, Falko's Tutorial for installing mod security was good in 2007 but is now completely obsolete.
Mod security has undergone many changes since then, and needs a totally different installation.

Rather use this how-to:
http://www.faqforge.com/linux/apache...n-6-0-squeeze/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation just stops, and dies. cosmicsafari Installation/Configuration 3 19th July 2011 10:24
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
Booting On PXE And On A Customized Debian System sebastienp HOWTO-Related Questions 7 30th July 2009 21:13
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 10:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.