Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 23rd April 2012, 19:51
ghall ghall is offline
Member
 
Join Date: Nov 2006
Posts: 43
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
According to this (old) thread...
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=224319
... you should set
Code:
DEFAULT_SERVER_LANGUAGE = 'en'
in your mailman configuration.
That fixed that, thanks.

I finally got it to send me an e-mail "Your new mailing list: mailman". However in the basic information about my mailing list under "The web page for users of your mailing list is:" https://lists.physics.fsu.edu/cgi-bi...stinfo/mailman I'm getting the SSL error: Secure Connection Failed ... SSL received a record that exceeded the maximum possible length. (Error code ssl_error_rx_record_too_long)

It works as http:

Since mailman made this how do I correct it's SSL certificate or how do i get the e-mail response to only show http: instead of https:? I'd rather just fix the SSL certificate but will settle for the latter.

Thanks!
Reply With Quote
Sponsored Links
  #22  
Old 24th April 2012, 15:15
ghall ghall is offline
Member
 
Join Date: Nov 2006
Posts: 43
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ghall View Post
Since mailman made this how do I correct it's SSL certificate or how do i get the e-mail response to only show http: instead of https:? I'd rather just fix the SSL certificate but will settle for the latter.

Thanks!
Ok I finally managed to crash Apache2 messing with the SSL. Now I can't access ISPconfig or anything. Is there anyone that has recovered from this position that could help?

Thanks in advance
Reply With Quote
  #23  
Old 14th June 2014, 03:40
Tastiger Tastiger is offline
Junior Member
 
Join Date: Feb 2011
Posts: 28
Thanks: 3
Thanked 1 Time in 1 Post
Default

Time to revisit this subject - after an rebuild of my server and following the setup described here for Ubuntu 14.0.4, I am having issues connecting to mailing list archives created via ispconfig3 at:-
http://polyoz.net.au/pipermail/committee/ - keep getting 404 error

any other links such as:-
http://polyoz.net.au/cgi-bin/mailman/listinfo/committee



I have checked /etc/apache2/conf-available/mailman.conf and it is shown below:-

Quote:
# Sample configuration for Debian mailman with Apache

# We can find mailman here:
ScriptAlias /cgi-bin/mailman/ /usr/lib/cgi-bin/mailman/
# And the public archives:
Alias /pipermail/ /var/lib/mailman/archives/public/
# Logos:
Alias /images/mailman/ /usr/share/images/mailman/

# Use this if you don't want the "cgi-bin" component in your URL:
# In case you want to access mailman through a shorter URL you should enable
# this:
#ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
# In this case you need to set the DEFAULT_URL_PATTERN in
# /etc/mailman/mm_cfg.py to http://%s/mailman/ for the cookie
# authentication code to work. Note that you need to change the base
# URL for all the already-created lists as well.

<Directory /usr/lib/cgi-bin/mailman/>
AllowOverride None
Options ExecCGI
AddHandler cgi-script .cgi
Order allow,deny
Allow from all
</Directory>
<Directory /var/lib/mailman/archives/public/>
Options FollowSymlinks
AllowOverride None
Order allow,deny
Allow from all
</Directory>
<Directory /usr/share/images/mailman/>
AllowOverride None
Order allow,deny
Allow from all
</Directory>


## The following describes how to configure mailman on
## a dedicated virtual host, courtesy Marco d'Itri.

# Add these lines in /etc/mailman/mm_cfg.py:
#DEFAULT_EMAIL_HOST = 'lists.example.net'
#DEFAULT_URL_HOST = 'lists.example.net'
#DEFAULT_URL_PATTERN = 'http://%s/'

#<VirtualHost *>
#ServerName lists.example.net
#DocumentRoot /var/www/lists
#ErrorLog /var/log/apache2/lists-error.log
#CustomLog /var/log/apache2/lists-access.log combined
#
#<Directory /var/lib/mailman/archives/>
# Options FollowSymLinks
# AllowOverride None
#</Directory>
#
#Alias /pipermail/ /var/lib/mailman/archives/public/
#Alias /images/mailman/ /usr/share/images/mailman/
#ScriptAlias /admin /usr/lib/cgi-bin/mailman/admin
#ScriptAlias /admindb /usr/lib/cgi-bin/mailman/admindb
#ScriptAlias /confirm /usr/lib/cgi-bin/mailman/confirm
#ScriptAlias /create /usr/lib/cgi-bin/mailman/create
#ScriptAlias /edithtml /usr/lib/cgi-bin/mailman/edithtml
#ScriptAlias /listinfo /usr/lib/cgi-bin/mailman/listinfo
#ScriptAlias /options /usr/lib/cgi-bin/mailman/options
#ScriptAlias /private /usr/lib/cgi-bin/mailman/private
#ScriptAlias /rmlist /usr/lib/cgi-bin/mailman/rmlist
#ScriptAlias /roster /usr/lib/cgi-bin/mailman/roster
#ScriptAlias /subscribe /usr/lib/cgi-bin/mailman/subscribe
#ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
#</VirtualHost>
Any clues??

Last edited by Tastiger; 16th June 2014 at 03:23.
Reply With Quote
  #24  
Old 16th June 2014, 05:58
Tastiger Tastiger is offline
Junior Member
 
Join Date: Feb 2011
Posts: 28
Thanks: 3
Thanked 1 Time in 1 Post
 
Default

Ah - never mind after much searching I finally added

Quote:
Alias /pipermail/ /var/lib/mailman/archives/public/

Alias /images/mailman/ /usr/share/images/mailman/
to my 900-polyoz.net.au.vhost file and now I can access archives.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Howtoforge the perfect Server(links) rini90 Installation/Configuration 0 14th December 2008 10:58
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30


All times are GMT +2. The time now is 20:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.