Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th June 2014, 13:30
floown floown is offline
Junior Member
 
Join Date: Jun 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Arrow End of script output before headers: index.php

Hello,

I have completely reinstall my Ubuntu server by reading and apply the howto for The Perfect Server - Ubuntu 14.04 (Apache2, PHP, MySQL, PureFTPD, BIND, Dovecot, ISPConfig 3.

I have create the domain name in ISPconfig and I have copy the local site in the server, by SFTP. I have change the right permission in domainename/web for web1:client1

But I have an error in site's log :
Quote:
[Fri Jun 13 13:13:45.913855 2014] [fcgid:warn] [pid 28126] (104)Connection reset by peer: [client 79.82.67.245:65469] mod_fcgid: error reading data from FastCGI server
[Fri Jun 13 13:13:45.913951 2014] [core:error] [pid 28126] [client 79.82.67.245:65469] End of script output before headers: index.php
[Fri Jun 13 13:13:50.113698 2014] [fcgid:warn] [pid 28127] (104)Connection reset by peer: [client 79.82.67.245:65470] mod_fcgid: error reading data from FastCGI server
[Fri Jun 13 13:13:50.113790 2014] [core:error] [pid 28127] [client 79.82.67.245:65470] End of script output before headers: index.php
[Fri Jun 13 13:13:52.266710 2014] [fcgid:warn] [pid 28128] (104)Connection reset by peer: [client 79.82.67.245:65471] mod_fcgid: error reading data from FastCGI server
[Fri Jun 13 13:13:52.266813 2014] [core:error] [pid 28128] [client 79.82.67.245:65471] End of script output before headers: index.php
My /var/log/apache2/error.log
Quote:
[Fri Jun 13 13:13:37.708681 2014] [mpm_prefork:notice] [pid 19871] AH00171: Graceful restart requested, doing restart
[Fri Jun 13 13:13:37.873086 2014] [auth_digest:notice] [pid 19871] AH01757: generating secret for digest authentication ...
[Fri Jun 13 13:13:37.875028 2014] [:notice] [pid 28123] FastCGI: process manager initialized (pid 28123)
[Fri Jun 13 13:13:37.951663 2014] [:notice] [pid 19871] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
[Fri Jun 13 13:13:37.951705 2014] [:notice] [pid 19871] mod_python: using mutex_directory /tmp
[Fri Jun 13 13:13:37.974495 2014] [ssl:warn] [pid 19871] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Jun 13 13:13:37.974533 2014] [ssl:warn] [pid 19871] AH01909: RSA certificate configured for sd-63122.dedibox.fr:8080 does NOT include an ID which matches the server name
[Fri Jun 13 13:13:37.974988 2014] [mpm_prefork:notice] [pid 19871] AH00163: Apache/2.4.7 (Ubuntu) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4 mod_python/3.3.1 Python/2.7.6 OpenSSL/1.0.1f configured -- resuming normal operations
[Fri Jun 13 13:13:37.975019 2014] [core:notice] [pid 19871] AH00094: Command line: '/usr/sbin/apache2'
[Fri Jun 13 13:13:37.975095 2014] [mpm_prefork:warn] [pid 19871] AH00167: long lost child came home! (pid 19874)
[Fri Jun 13 13:13:48.874494 2014] [fcgid:error] [pid 28124] mod_fcgid: process /var/www/php-fcgi-scripts/web1/.php-fcgi-starter(28131) exit(communication error), get unexpected signal 11
[Fri Jun 13 13:13:54.032037 2014] [fcgid:error] [pid 28124] mod_fcgid: process /var/www/php-fcgi-scripts/web1/.php-fcgi-starter(28136) exit(communication error), get unexpected signal 11
[Fri Jun 13 13:13:54.032176 2014] [fcgid:error] [pid 28124] mod_fcgid: process /var/www/php-fcgi-scripts/web1/.php-fcgi-starter(28134) exit(communication error), get unexpected signal 11
What I have done wrong in server installation? What's the bug, and how to repear it?

Thx!

Last edited by floown; 13th June 2014 at 15:41.
Reply With Quote
Sponsored Links
  #2  
Old 15th June 2014, 22:39
LeChuck LeChuck is offline
Junior Member
 
Join Date: Jun 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello!

I'm new here but have the same problem :-)

Just installed an Ubuntu 12.04 vServer and upgraded directly to 14.04 without problems.
After installing ISP with the Guide for 14.04 I get the messages "mod_fcgid: error reading data from FastCGI server" and "End of script output before headers: index.php" in the errors.log when I want to access the adminpanel.
Reply With Quote
  #3  
Old 15th June 2014, 22:54
floown floown is offline
Junior Member
 
Join Date: Jun 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello LeChuck

Cause I didn't have support on this forum, I have reinstall the server with iRedmail this time. No problem. Nice for email configuration.

I can't help you better.
Reply With Quote
  #4  
Old 16th June 2014, 07:29
srijan srijan is offline
HowtoForge Supporter
 
Join Date: Feb 2014
Location: New Delhi, India
Posts: 708
Thanks: 4
Thanked 91 Times in 88 Posts
Send a message via Skype™ to srijan
Default

Quote:
After installing ISP with the Guide for 14.04 I get the messages "mod_fcgid: error reading data from FastCGI server" and "End of script output before headers: index.php" in the errors.log when I want to access the adminpanel.
This means that php dies for some reason, this can be php settings or a incompatibility of any app with a specific php version or something similar. If you changed any folder permissions in that site, then this can cause such a error as well. You can try to enable in php.ini to show errors on the screen and then restart apache.
__________________
Br//
Srijan
Reply With Quote
  #5  
Old 16th June 2014, 09:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

Quote:
Originally Posted by floown View Post
Hello LeChuck

Cause I didn't have support on this forum, I have reinstall the server with iRedmail this time. No problem. Nice for email configuration.

I can't help you better.
I'am sorry that we did not recognize your post earlier. The ISPConfig support team is working in the ispconfig forums only and you posted in the forum that is labeled "This forum is for general Linux installation/configuration issues, not for ISPConfig!".

If you still need help with your website, the post the ls -la output from within the web directory.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 16th June 2014, 09:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
 
Default

Quote:
Originally Posted by LeChuck View Post
Hello!

I'm new here but have the same problem :-)

Just installed an Ubuntu 12.04 vServer and upgraded directly to 14.04 without problems.
After installing ISP with the Guide for 14.04 I get the messages "mod_fcgid: error reading data from FastCGI server" and "End of script output before headers: index.php" in the errors.log when I want to access the adminpanel.
Please post in the ispconfig forum to get help with your ispconfig install:

http://www.howtoforge.com/forums/forumdisplay.php?f=27

And your error is not related to the one from flown as the vhost that runs the ispconfig interface is different from the one that runs a website. Please note that ispconfig has to be updated after you did a dist upgrade as the dist upgrade might have changed config files. Please check with the ubuntu 14.04 guide that you installed all nescessary packages, then download the ispconfig tar.gz file again, unpack it and run the update.php file. Choose to reconfigure services during update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work pehden Installation/Configuration 20 9th December 2013 14:05
Virtual Users+Postfix+Courier+CentOS problem telnet localhost 25 stinson HOWTO-Related Questions 11 5th February 2011 13:57
Debian 5 Ajax error + network interface always shutting down ev0css Installation/Configuration 3 5th June 2010 12:58
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02
What can be wrong martin_rudowicz Installation/Configuration 9 11th May 2008 19:42


All times are GMT +2. The time now is 06:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.