#1  
Old 23rd October 2011, 07:55
DaleHutch DaleHutch is offline
Member
 
Join Date: Apr 2010
Location: 39.943066 , -104.902954
Posts: 43
Thanks: 3
Thanked 4 Times in 4 Posts
Unhappy Help with new install

Greetings,

I recently followed Falko's excellent tutorial "The Perfect Desktop - Ubuntu 11.10 (Oneiric Ocelot)"

I followed everything to the letter. Everythig seems to work but the SMTP authentication.

Thunderbird keeps asking for my password. and my mail.log is showing this...

Oct 22 22:13:59 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL PLAIN authentication failed: no mechanism available
Oct 22 22:13:59 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL LOGIN authentication failed: no mechanism available
Oct 22 22:14:05 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL PLAIN authentication failed: no mechanism available
Oct 22 22:14:06 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL LOGIN authentication failed: no mechanism available
Oct 22 22:14:09 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL PLAIN authentication failed: no mechanism available
Oct 22 22:14:09 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL LOGIN authentication failed: no mechanism available
Oct 22 22:14:10 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL PLAIN authentication failed: no mechanism available
Oct 22 22:14:10 tesla postfix/smtpd[1736]: warning: Galactica[10.10.5.103]: SASL LOGIN authentication failed: no mechanism available

I've looked everywhere for an answer to this problem and have founds many dead ends. Can someone please assist me in correcting this?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 24th October 2011, 10:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you install Postfix on your desktop? Or is it installed on a remote server? Which tutorial (URL) did you use to configure Postfix?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th October 2011, 03:04
DaleHutch DaleHutch is offline
Member
 
Join Date: Apr 2010
Location: 39.943066 , -104.902954
Posts: 43
Thanks: 3
Thanked 4 Times in 4 Posts
Default

Hey Falko, Thanks for the help...

I followed yours....

The Perfect Server - Ubuntu 11.10 [ISPConfig 3]

I've gone over as much as I can with my limited experience. Everything looks okay..

Squirrelmail works fine. It can send and receive.
Reply With Quote
  #4  
Old 25th October 2011, 13:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

http://www.howtoforge.com/forums/sho...1&postcount=25
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 26th October 2011, 04:40
DaleHutch DaleHutch is offline
Member
 
Join Date: Apr 2010
Location: 39.943066 , -104.902954
Posts: 43
Thanks: 3
Thanked 4 Times in 4 Posts
Default

I followed the steps. I didn't see any errors.

I'm still not able to send (authenticate)

But my logs have changed..

postfix/smtpd[2062]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
postfix/smtpd[2062]: warning: SASL authentication failure: Password verification failed
postfix/smtpd[2062]: warning: Galactica[10.10.5.103]: SASL PLAIN authentication failed: generic failure
postfix/smtpd[2062]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
postfix/smtpd[2062]: warning: Galactica[10.10.5.103]: SASL LOGIN authentication failed: generic failure

I read through the post you found and ran this command

saslauthd -v

I get this error:
saslauthd: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory

Any suggestions?

Thanks
Reply With Quote
  #6  
Old 26th October 2011, 05:41
DaleHutch DaleHutch is offline
Member
 
Join Date: Apr 2010
Location: 39.943066 , -104.902954
Posts: 43
Thanks: 3
Thanked 4 Times in 4 Posts
Default

I think I made some headway....

I'm getting this now..

Oct 25 20:36:04 tesla postfix/smtpd[2001]: warning: SASL authentication failure: Password verification failed
Oct 25 20:36:04 tesla postfix/smtpd[2001]: warning: Galactica[10.10.5.103]: SASL PLAIN authentication failed: authentication failure
Oct 25 20:36:04 tesla postfix/smtpd[2001]: warning: Galactica[10.10.5.103]: SASL LOGIN authentication failed: authentication failure


Any suggestions?
Reply With Quote
  #7  
Old 26th October 2011, 05:56
DaleHutch DaleHutch is offline
Member
 
Join Date: Apr 2010
Location: 39.943066 , -104.902954
Posts: 43
Thanks: 3
Thanked 4 Times in 4 Posts
 
Thumbs up

FIXED!!!!!!!!!!!!




I had this in my /etc/default/saslauthd

OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd"

But it should be this!!

OPTIONS="-m /var/spool/postfix/var/run/saslauthd -r"

Also.... I also had to do the steps you suggested...

Thank you Falko for your website and help!!!!!!!!!

Your tutorials are of great value! They have taught me so much about Linux!

Thank you!

Reply With Quote
The Following User Says Thank You to DaleHutch For This Useful Post:
falko (26th October 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 11:37
Centos 5 Perfect Install with SSH tal56 Installation/Configuration 3 31st October 2007 06:23
problem install perl modules Cirox Installation/Configuration 10 16th May 2007 17:04
quota question on perfect install fedora core 5.0 bmayock HOWTO-Related Questions 7 6th July 2006 14:20
/usr/bin/make install install HTML::Parser -- NOT OK oddo Installation/Configuration 4 14th March 2006 19:32


All times are GMT +2. The time now is 20:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.