Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 24th October 2011, 15:00
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Yes I have tried that and with the DNS set to 192.168.1.1 it responds correctly... Now I just have to get it to redirect to that.
Reply With Quote
Sponsored Links
  #12  
Old 24th October 2011, 19:37
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
 
Default

Ok so I have figured it out thanks to Till (sent me in the right direction)

This is how to do it if you meet the criteria of having Debian and ISPConfig installed on your nominated recipient of the port 80 request. Other flavors no doubt will work as well just might need some editing. Also make sure you have a A record set up for the secondary apache web server.

Port 80 for me was sent to server1.example.com which had a ip of 192.168.1.1/24

So I edited example.com.vhost in /etc/apache2/sites-available/example.com.vhost

Scroll down to after it talks about the directory locations and settings (probably doesn't need to be here but that is where i put it) and place this (obviously editing it to suit your needs)

================================================== ======

ProxyRequests Off
ProxyPreserveHost On

<Proxy 10.1.5.15:80>
Order deny,allow
Allow from all
</Proxy>

ProxyPass /example http://server2.example.com/example
ProxyPassReverse /example http://server2.example.com/example

================================================== =======

What I forgot to add was the example after the forward slash. After restarting apache with a /etc/init.d/apache2 restart everything went where I wanted it.

Hopefully this helps someone else. Thanks to all and if it doesn't work out I will come back here...

Regards,
Steve

Last edited by sjswarts; 24th October 2011 at 19:38. Reason: Incorrect syntax
Reply With Quote
The Following User Says Thank You to sjswarts For This Useful Post:
falko (25th October 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix: can send emails outside, none received daseagle Server Operation 9 11th October 2011 13:03
Postfix not forwarding for some domains flappy Installation/Configuration 3 21st November 2010 18:57
RoundCube Sends but will not receive. happz Installation/Configuration 33 17th April 2010 22:55
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 21:43
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 10:40


All times are GMT +2. The time now is 19:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.