Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th October 2011, 12:13
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 419
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default Debian, ISPConfig 3.0.3.3, mod_fcgi+suExec, PHP not showing errors

Hello,

maybe somebody can give me some advice.

i have started migrate pages from ISPC2 to ISPC3, all new pages are created under mod_fcgi + SuEXEC

Now i have a problem, webpages are not showing any php errors
it doesnt matter what i set in
/etc/php5/cgi/php.ini or /etc/php5/apache2/php.in section error_reporting
any of choices
Default Value: E_ALL & ~E_NOTICE
Development Value: E_ALL | E_STRICT
Production Value: E_ALL & ~E_DEPRECATED

is not showing any error for pages in browser
?
Reply With Quote
Sponsored Links
  #2  
Old 20th October 2011, 12:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,771
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Do the pages work or do you see just a white page? If you get just a white page, then take a look at the error.log of the website.

If you migrated the pages, please check that all files and folders are owned by the web user and client group of the website, if the files are owned by root, then php-fcgi will fail with a security error in the error.log and show just a white page.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th October 2011, 12:42
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 419
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default

i have migrated pages by FTP so owner is good..

1.
when there is error, like bad mysql connection config, page is just white, instead of showing error defined in PHP code, as for example "wrong SQL connection"
i'd like the web pages showing this error...

2.
error.log seems to work correctly
only weird thing is that it is full of messages which werent shown under mod_php, as
[warn] Undefined index:
[warn] Undefined variable:

can i show just
[error] messages in error log ?

again setting of erorr reporting in php doesn't seems to do any change


does it all something to do with fcgi + suExec ?
Reply With Quote
  #4  
Old 20th October 2011, 13:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,771
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Quote:
does it all something to do with fcgi + suExec ?
No, I dont think so.

The error_reporting setting in php ini defines just which errors are reported and not where they are reported. Since Debian 6, error reporting on screen is off by default to protect the web applications. To turn it on, edit the php.ini and change:

display_errors = Off

to:

display_errors = On

and restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th October 2011, 14:00
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 419
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default

thank you for info!
Reply With Quote
  #6  
Old 20th October 2011, 14:38
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 419
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default

just for info

Here is something about
http://php.net/manual/en/errorfunc.configuration.php

i was right about it
When using PHP with Apache mod_fcgid and "log_errors = On", PHP errors get logged into Apache ErrorLog file with severity "warn". No matter what severity the PHP error itself has, the severity in the Apache log is "warn".

some solutions on the page had no time for testing...
Reply With Quote
The Following User Says Thank You to radim_h For This Useful Post:
falko (21st October 2011)
  #7  
Old 3rd June 2014, 12:04
jan-paul jan-paul is offline
Junior Member
 
Join Date: Aug 2012
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Smile How to turn on error reporting in PHP, the right (ISPConfig 3) way

Sorry for bumping this after 3 years or so, I searched howtoforge for the terms 'php error reporting' but got no useful hits. This is the thread I found via google, so that says something about it's relevance IMO.

The correct way to turn on error reporting in PHP ISPConfig is easy:
  1. Choose the website for which to turn on PHP error reporting.
  2. Go to the tab 'Options'
  3. In the field for 'Custom php.ini settings' fill in: display_errors = On

And now error reporting is active for this website; how cool is that?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 6.0 support Acid_Scorpion Developers' Forum 47 16th September 2011 10:36
ISPConfig on Debian 6 with optional PHP 5.2 for single webs Croydon Installation/Configuration 3 6th September 2011 16:35
Fedora 10 - Virtual Users And Domains With Postfix, Courier etc j.smith1981 Server Operation 6 17th February 2010 01:01
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
fastcgi and php with ispconfig tosser Tips/Tricks/Mods 3 25th June 2006 21:01


All times are GMT +2. The time now is 03:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.