Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th October 2011, 21:34
c-gundo c-gundo is offline
Junior Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default why multiple domains are directed towards same the host

I have a strange problem with my (new) server (OVH.net automatic installation)
i have 2 domains http://www.cgundoffice.com and http://www.modulance.net
each are configured on a separed DNS server with the A Zone linked to the IP of the ISPconfig3 server
On the ISPconfig3 server, i have created 2 sites, one for each domains

But now, when i try to connect to those URL, each of them are directed to the same domain (http://www.cgundoffice.com) ... why ?

any suggestion ?

thx :-)
Reply With Quote
Sponsored Links
  #2  
Old 13th October 2011, 22:15
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default

check and make sure the two site directories are not the same



kwick
__________________
Operating system Ubuntu Linux 10.04.4
ISPConfig Version: 3.0.4.3
Webmin version 1.580
Kernel and CPU Linux 2.6.32-40-server on x86_64
Processor information AMD Phenom(tm) II X4 945 Processor, 4 cores
Real memory 4.0 GB total
Reply With Quote
  #3  
Old 14th October 2011, 07:12
c-gundo c-gundo is offline
Junior Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default

i have checked the folder
and also the vhost files
/etc/apache2/sites-available/cgundoffice.com.vhost

Code:
<VirtualHost 91.121.92.131:80>
      DocumentRoot /var/www/cgundoffice.com/web
  
    ServerName cgundoffice.com
    ServerAlias www.cgundoffice.com
    ServerAdmin webmaster@cgundoffice.com

    ErrorLog /var/log/ispconfig/httpd/cgundoffice.com/error.log
/etc/apache2/sites-available/modulance.net.vhost
Code:
<VirtualHost 91.121.92.131:80>
      DocumentRoot /var/www/modulance.net/web
  
    ServerName modulance.net
    ServerAlias www.modulance.net
    ServerAdmin webmaster@modulance.net

    ErrorLog /var/log/ispconfig/httpd/modulance.net/error.log
but what i see is that all the request to my server go to the same host
http://91.121.92.131 ... same host

i have reloaded Apache, restart the server ... not better
Reply With Quote
  #4  
Old 14th October 2011, 08:39
c-gundo c-gundo is offline
Junior Member
 
Join Date: Feb 2011
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
 
Thumbs up resolved

i have found the solution
in the web domain config page, i must set IP on * and not on the real IP of the server
apache restart and all work fine
Reply With Quote
The Following User Says Thank You to c-gundo For This Useful Post:
falko (14th October 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Server Is Sending Spam. How Do I Block This? LordJ Server Operation 1 7th July 2011 19:34
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
smtp is error!!! fhawk Installation/Configuration 2 7th April 2009 13:17
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17


All times are GMT +2. The time now is 05:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.