Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th October 2011, 18:33
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Question

Quote:
Originally Posted by falko View Post
I'm running out of ideas...
Hi falko,

i have disabled amavis in master & main.cf in postfix config, restarted postfix
and did a postqueue -f and postqueue -p , still the same issue exists though.

Seems then that its an issue with postfix config ??? :s

maybe there is a wrong SQL setup somewhere ? would that give such errors, or would that give clear SQL errors ???
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
Sponsored Links
  #12  
Old 17th October 2011, 18:45
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default

falko,

i got rid of the messages !!!!

Yeeeey !!!

However, if i send a mail now to my new virtual user system thingie on my new dedicated box.

Everytime i send an email to one of the users i get following error or status :

status=bounced (mail for mail.mydomein.eu ) loops back to myself

Any idea how to fix this or what is the cause ???
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu

Last edited by MiniMe; 17th October 2011 at 20:26. Reason: UPDATE !!!
Reply With Quote
  #13  
Old 18th October 2011, 11:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Add mail.mydomein.eu to the mydestination line in /etc/postfix/main.cf and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 18th October 2011, 12:55
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by falko View Post
Add mail.mydomein.eu to the mydestination line in /etc/postfix/main.cf and restart Postfix.
hi falko, i already have that, check config i already posted previously :

mydestination = mail.evil-hannie.eu, localhost, localhost.localdomain

any other idea ?

Could this be it ? :

Line 2: the virtual_alias_domains setting tells Postfix that example.com is a so-called virtual alias domain. If you omit this setting then Postfix will reject mail (relay access denied) or will not be able to deliver it (mail for example.com loops back to myself).

NEVER list a virtual alias domain name as a mydestination domain!

Although i am not sure if i have this setup like that ...
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
  #15  
Old 18th October 2011, 21:46
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Exclamation

So falko, i hope you still wanna help me but this is where i stand at the moment :

all the other warnings or errors are gone, i have tried several adjustments to some postfix directives, but nothing seems to work :

1. My /home/vmail folder is still empty
2. in the /var/log/mail.info mail.warn and mail.log are following messages :

Code:
mail.info:
Oct 18 21:34:56 Aphrodite-Artemis amavis[9732]: (09732-19) Passed CLEAN, [195.130.137.66] [213.118.212.210] <han.flamez@telenet.be> -> <han@evil-hannie.eu>, Message-ID: <64151EB4364B4D34B9$
Oct 18 21:34:56 Aphrodite-Artemis postfix/smtp[17523]: warning: numeric domain name in resource data of MX record for mail.evil-hannie.eu: xx.xx.xx.xx
Oct 18 21:34:56 Aphrodite-Artemis postfix/smtp[17517]: E10D686A0EC3: to=<han@evil-hannie.eu>, relay=127.0.0.1[127.0.0.1]:10024, delay=3.4, delays=1.5/0/0/1.9, dsn=2.0.0, status=sent (250 2$
Oct 18 21:34:56 Aphrodite-Artemis postfix/qmgr[17509]: E10D686A0EC3: removed
Oct 18 21:34:56 Aphrodite-Artemis postfix/smtp[17523]: 26E0586A0ECA: to=<han@evil-hannie.eu>, relay=none, delay=0.14, delays=0.13/0.01/0/0, dsn=5.4.6, status=bounced (mail for mail.evil-hannie.eu loops back to myself)
Oct 18 21:34:56 Aphrodite-Artemis postfix/cleanup[17516]: 5AEB986A0ECB: message-id=<20111018193456.5AEB986A0ECB@mail.evil-hannie.eu>
Oct 18 21:34:56 Aphrodite-Artemis postfix/bounce[17524]: 26E0586A0ECA: sender non-delivery notification: 5AEB986A0ECB
Code:
mail.log
same as above
Code:
mail.warn
Oct 18 21:34:56 Aphrodite-Artemis postfix/smtp[17523]: warning: numeric domain name in resource data of MX record for mail.evil-hannie.eu: xx.xx.xx.xx
Following is in main.cf :
Code:
mydestination = mail.evil-hannie.eu, localhost
mydomain = evil-hannie.eu
myhostname = mail.evil-hannie.eu
In my SQL db mail in table domains is only evil-hannie.eu

With this info, do you have any idea what i should change ?
Ive been trying several different settings to the mydestination , myhostname and mydomain but i cant quiet get it to work

Please help, i would appreciate it so much.
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
  #16  
Old 19th October 2011, 18:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Do you use mail.evil-hannie.eu also in your database, or only in the mydestination line?

What's in /etc/hosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 19th October 2011, 19:06
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Exclamation

Quote:
Originally Posted by falko View Post
Do you use mail.evil-hannie.eu also in your database, or only in the mydestination line?

What's in /etc/hosts?
Hi falko,

no i do not use mail.evil-hannie.eu ;
mail.evil-hannie.eu is JUST my MX record on my domain evil-hannie.eu !
In my database domain table is only evil-hannie.eu

in /etc/hosts is the following :

Code:
### Hetzner Online AG installimage
# nameserver config
# IPv4
127.0.0.1 localhost
176.9.42.71  Aphrodite-Artemis
#
# IPv6
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
  #18  
Old 20th October 2011, 18:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Can you add mail.evil-hannie.eu to the 176.9.42.71 Aphrodite-Artemis line and see if that changes anything?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 21st October 2011, 19:37
MiniMe MiniMe is offline
Senior Member
 
Join Date: Oct 2008
Posts: 104
Thanks: 4
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by falko View Post
Can you add mail.evil-hannie.eu to the 176.9.42.71 Aphrodite-Artemis line and see if that changes anything?
hi falko,

same result : mail for mail.evil-hannie.eu loops back to myself :/
__________________
Debian Squeeze 6.0.3 - 16GB RAM - Intel i7-2600 Quad Core HT @ 3.4Ghz - RAID 1 2800 GB
Evil-Hannie's Dedicated Server - Aphrodite-Artemis
http://www.evil-hannie.eu
Reply With Quote
  #20  
Old 22nd October 2011, 11:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
 
Default

I'm running out of ideas...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail-Problema jz_ HOWTO-Related Questions 9 14th September 2011 13:31
postfix problem jagsler Server Operation 41 7th July 2011 14:19
421 Unexpected failure Lizard King Installation/Configuration 20 7th July 2009 20:43


All times are GMT +2. The time now is 16:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.