Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th April 2009, 17:59
smakynet smakynet is offline
Junior Member
 
Join Date: Apr 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Enable Directory Listing

I need to figure out how to enable directory listing.

Right now I get the error "Browsing this directory is forbidden"

Does anyone know how to enable Directory browsing globally?

Any help is appreciated!
Reply With Quote
Sponsored Links
  #2  
Old 5th April 2009, 11:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,592
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Add the following code in the apache2.conf file:

<Directory /var/www>
Options +Indexes
</Directory>
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th June 2009, 15:00
Bikkies Bikkies is offline
Junior Member
 
Join Date: Apr 2009
Posts: 17
Thanks: 3
Thanked 0 Times in 0 Posts
Default

If you want to configure for just a particular site/sub-directory, it can also go in the Apache Directives for required web in ISPConfig2.
Unsure about ISPConfig3

e.g.-
Code:
<Directory /var/www/web3/web/mysql-backup-reports>
Options +Indexes
</Directory>
Reply With Quote
  #4  
Old 8th June 2009, 15:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,592
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Same for ispconfig 3.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 4th August 2009, 15:06
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 260
Thanked 145 Times in 127 Posts
Default

For some reason I can not get this to work in ISPconfig3
When looking at the .vhost file it does show the added data.

I have tested this with client ID and domain.
Code:
<Directory "/var/clients/client17/web59/web/download">
Options +Indexes
</Directory>
and
Code:
<Directory /var/www/the-domain.nl/web/download>
Options +Indexes
</Directory>
Both ways give an ERROR 403 - Forbidden!
Is it only me who is having this problem? if so.. What could it be?

Last edited by edge; 4th August 2009 at 15:09.
Reply With Quote
  #6  
Old 5th August 2009, 09:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,592
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Looks correct so far. Have you took a look at the error log in the website?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 5th August 2009, 09:54
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 260
Thanked 145 Times in 127 Posts
Default

The error in the log file reads:
Quote:
client denied by server configuration: /var/www/the-domain.nl/web/download/index.php
It's correct that it can not find the index.php as it does not have one!
I want it to show the directory listing!
Reply With Quote
  #8  
Old 5th August 2009, 10:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,592
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Does the site contain a .htaccess file that might apply some rewriting?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 7th August 2009, 14:26
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 260
Thanked 145 Times in 127 Posts
Default

I mist your reply, so sorry for the delay on your question.
And.. No... No .htaccess at all on that site!

I've only added
Quote:
<Directory /var/www/the-domain.nl/web/download>
Options +Indexes
</Directory>
to the Apache Directives of the website in question.
Reply With Quote
  #10  
Old 8th August 2009, 02:13
Doug G Doug G is offline
Member
 
Join Date: Apr 2008
Posts: 63
Thanks: 0
Thanked 6 Times in 4 Posts
 
Default

fwiw I just went through this on a test server, it seems to me I had to manually restart or reload apache to get the new directory directive to be recognized and the forbidden message to go away. I put the directive in the additional apache directives in ispconfig3. This was done on centos 5.3
__________________
=====
Doug G
=====
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42


All times are GMT +2. The time now is 15:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.