Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd October 2007, 15:33
ditCh ditCh is offline
Junior Member
 
Join Date: Oct 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Smokeping installation

Did any of you guys get Smokeping running on an Ispconfig install ?

http://www.howtoforge.com/monitoring...ng_debian_etch

I used the above tutorial and ispconfig is running, but i cant get the cgi scripts to work so i dont get any graphs.

Cheers,
K.
Reply With Quote
Sponsored Links
  #2  
Old 3rd October 2007, 18:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Where did you put the smokeping.cgi script? Did you copy it to the cgi-bin directory of your web site?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th October 2007, 10:56
ditCh ditCh is offline
Junior Member
 
Join Date: Oct 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes I did, but it seems the paths where the config points to are not correct.

I'm running ubuntu and I just apt-get installed smokeping.
Reply With Quote
  #4  
Old 9th October 2007, 14:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What's the contents of smokeping.cgi?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th June 2008, 19:09
guardian guardian is offline
Member
 
Join Date: Aug 2006
Location: Bulgaria
Posts: 36
Thanks: 4
Thanked 2 Times in 2 Posts
Default

I also have a problem with smokeping on a Debian 4 system with ISPConfig
I have create a new site and copied smokeping.cgi to cgi-bin directory of a new site.
When I open http://smokeping.site/cgi-bin/smokeping.cgi all I see is a blank page or a 500 - Internal Server Error
__________________
http://www.webvision.bg
Reply With Quote
  #6  
Old 18th June 2008, 18:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Any errors in Apache's error log? Did you make the CGI executable? Do you use suExec?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 18th June 2008, 19:10
guardian guardian is offline
Member
 
Join Date: Aug 2006
Location: Bulgaria
Posts: 36
Thanks: 4
Thanked 2 Times in 2 Posts
Default

1. Yes
Code:
[Wed Jun 18 19:56:06 2008] [error] [client 10.0.0.1] suexec policy violation: see suexec log for more details
[Wed Jun 18 19:56:06 2008] [error] [client 10.0.0.1] Premature end of script headers: smokeping.cgi
2. Yes
3. Yes

suexec log

Code:
[2008-06-18 19:56:06]: uid: (65534/nobody) gid: (10063/10063) cmd: smokeping.cgi
[2008-06-18 19:56:06]: target uid/gid (65534/10063) mismatch with directory (33/10063) or program (0/0)
Thanks, I didn't think to check log file.
__________________
http://www.webvision.bg
Reply With Quote
  #8  
Old 19th June 2008, 16:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you go to the cgi-bin directory and post the output of
Code:
ls -la
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 19th June 2008, 16:44
guardian guardian is offline
Member
 
Join Date: Aug 2006
Location: Bulgaria
Posts: 36
Thanks: 4
Thanked 2 Times in 2 Posts
Default

I fix it, thanks again.
The owner of smokeping.cgi was root.
__________________
http://www.webvision.bg
Reply With Quote
  #10  
Old 15th December 2009, 15:06
thecuk thecuk is offline
Junior Member
 
Join Date: Nov 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

which owner should it be?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ispconfig Installation Problems 2XTREME4U Installation/Configuration 6 21st June 2007 11:43
ISPConfig installation question: German text in English Installation. AdamR Installation/Configuration 5 1st June 2007 09:47
ispconfig installation errors kcmohan Installation/Configuration 1 9th April 2007 20:14
newbie ububtu 6.0.6 error PHP binary line 816 davidsky73 Installation/Configuration 8 17th September 2006 11:51
ISPC install stops str2etboy Installation/Configuration 19 28th January 2006 07:18


All times are GMT +2. The time now is 03:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.