Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th September 2011, 10:24
arastirici arastirici is offline
Member
 
Join Date: Sep 2008
Posts: 82
Thanks: 0
Thanked 1 Time in 1 Post
Default How can I disable directory browsing in apache

Hello

I use ispconfig2 on opensuse11.1, apache,php5 work on it.
it works well But. directory indexes is enable. I can't disable it ?

cat /etc/apache2/httpd.conf;

<Directory /wwwroot1/*/web>
Options -Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
Order allow,deny
Allow from all
<Files ~ "^\.ht">
Allow from all
</Files>
</Directory>

How can I disable directory browsing in apache ?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 29th September 2011, 17:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you set
Code:
Options -Indexes
in the correct vhost? Did you check if there's maybe an .htaccess file where directory indexes are enabled?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th September 2011, 19:32
arastirici arastirici is offline
Member
 
Join Date: Sep 2008
Posts: 82
Thanks: 0
Thanked 1 Time in 1 Post
Default

for example, a vhost is located in /wwwroot1/web106

I added .htaccess file to web106/web/
and if I put down it " IndexIgnore */* " , it works
But if I put down Options -Indexes I get internal server error.

and it gets an error message;
.htaccess: Options not allowed here

I can't see any configure that it is enable +indexes
Also Allowoverride is All

What could be the problem ?
Reply With Quote
  #4  
Old 30th September 2011, 11:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

I guess you set
Code:
Options -Indexes
and
Code:
AllowOverride All
in the wrong locations. I'd set these in <Directory> containers inside your vhost.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th September 2011, 11:54
arastirici arastirici is offline
Member
 
Join Date: Sep 2008
Posts: 82
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello

the apache server doesn't allow me to configure "Allowoverride All" into vhost ( onto ispconfig control panel )
Therefore I configured "Allowoverride All" into /etc/apache2/httpd.conf

Note: I use opensuse11.1 and ispconfig2
Reply With Quote
  #6  
Old 1st October 2011, 09:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by arastirici View Post
Hello

the apache server doesn't allow me to configure "Allowoverride All" into vhost ( onto ispconfig control panel )
You can use the Apache Directives field on the Options tab in ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 1st October 2011, 10:04
arastirici arastirici is offline
Member
 
Join Date: Sep 2008
Posts: 82
Thanks: 0
Thanked 1 Time in 1 Post
Default

These apache directives in options tab of ispconfig works but Options -indexes does not work.

That's very interesting. i think it is a bug.
Reply With Quote
  #8  
Old 2nd October 2011, 09:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What exactly did you put in the Apache Directives field?
Did you wrap <Directory ...></Directory> around the Options line?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 2nd October 2011, 19:37
arastirici arastirici is offline
Member
 
Join Date: Sep 2008
Posts: 82
Thanks: 0
Thanked 1 Time in 1 Post
Default

I put down as following in ispconfig's apache directives;

<Directory /wwwroot1/web167/web>
Options -Indexes
</Directory>

I get an internal server error.

if I put down "IndexIgnore */*" in .htaccess
it works.
Reply With Quote
  #10  
Old 3rd October 2011, 19:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

And there's nothing in Apache's error logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Installation Error, Debian 3.1 yogi183 Installation/Configuration 6 23rd February 2007 16:11
Problems with Apache and Updating Jubalint Installation/Configuration 2 21st May 2006 19:50


All times are GMT +2. The time now is 21:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.