#1  
Old 26th September 2011, 18:52
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default Server Mail Won't Work

Hi,

It seems that my mail server only gets worse by the day. Squirrelmail used to work (sometimes). Now nothing works at all. The most important part is that contact forms, subscribe forms, email sign-ups that all work through the server won't send the information from the website (about 20 of them). Will be glad to submit maillog. Here is an error just trying to send from squirrelmail:

78 Can't execute command '/usr/sbin/sendmail -i -t -fadmin@example.com

and here is a snippet of recent maillogs:

(connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 26 08:30:03 webserverone dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Sep 26 08:30:03 webserverone dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Sep 26 08:30:04 webserverone postfix/smtpd[25370]: connect from webserverone.hostwithsupport.com[::1]
Sep 26 08:30:04 webserverone postfix/smtpd[25370]: lost connection after CONNECT from webserverone.hostwithsupport.com[::1]
Sep 26 08:30:04 webserverone postfix/smtpd[25370]: disconnect from webserverone.hostwithsupport.com[::1]
Sep 26 08:35:02 webserverone dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Sep 26 08:35:02 webserverone dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Sep 26 08:35:02 webserverone postfix/smtpd[25925]: connect from webserverone.hostwithsupport.com[::1]
Sep 26 08:35:02 webserverone postfix/smtpd[25925]: lost connection after CONNECT from webserverone.hostwithsupport.com[::1]
Sep 26 08:35:02 webserverone postfix/smtpd[25925]: disconnect from webserverone.hostwithsupport.com[::1]
Sep 26 08:36:08 webserverone postfix/qmgr[3033]: A842C2423DE: from=, size=3431, nrcpt=1 (queue active)
Sep 26 08:36:08 webserverone postfix/smtp[26004]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 26 08:36:08 webserverone postfix/smtp[26004]: A842C2423DE: to=, relay=none, delay=958, delays=958/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 26 08:40:02 webserverone dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
Sep 26 08:40:02 webserverone dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 27th September 2011, 11:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Sep 26 08:36:08 webserverone postfix/smtp[26004]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 26 08:36:08 webserverone postfix/smtp[26004]: A842C2423DE: to=, relay=none, delay=958, delays=958/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
What's the output of
Code:
netstat -tap
? It seems as if amavisd isn't running.

Code:
78 Can't execute command '/usr/sbin/sendmail -i -t -fadmin@example.com
Are there any open_basedir restrictions for SquirrelMail, or did you disable some PHP functions such as exec in your php.ini?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th September 2011, 13:51
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Default

Falko,

Here is the output of netstat -tap

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *op3 *:* LISTEN 1711/dovecot
tcp 0 0 *:imap *:* LISTEN 1711/dovecot
tcp 0 0 *:sunrpc *:* LISTEN 1518/rpcbind
tcp 0 0 webserverone.hostwiths:http 180.241.122.225:45438 SYN_RECV -
tcp 0 0 webserverone.hostwiths:http 180.241.122.225:45324 SYN_RECV -
tcp 0 0 webserverone.hostwiths:http 180.241.122.225:45245 SYN_RECV -
tcp 0 0 webserverone.hostwiths:http 180.241.122.225:45416 SYN_RECV -
tcp 0 0 webserverone.hostwiths:http 180.241.122.225:45282 SYN_RECV -
tcp 0 0 localhost:domain *:* LISTEN 9401/named
tcp 0 0 *:ftp *:* LISTEN 1859/pure-ftpd (SER
tcp 0 0 *:ssh *:* LISTEN 1699/sshd
tcp 0 0 *:smtp *:* LISTEN 15105/master
tcp 0 0 localhost:rndc *:* LISTEN 9401/named
tcp 0 0 *:35775 *:* LISTEN 1538/rpc.statd
tcp 0 0 *:imaps *:* LISTEN 1711/dovecot
tcp 0 0 *op3s *:* LISTEN 1711/dovecot
tcp 0 0 localhost:10025 *:* LISTEN 15105/master
tcp 0 0 *:mysql *:* LISTEN 15573/mysqld
tcp 0 0 localhost:mysql localhost:60684 ESTABLISHED -
tcp 0 0 localhost:60684 localhost:mysql ESTABLISHED -
tcp 0 0 webserverone.hostwithsu:ssh cpe-173-093-151-171.s:52628 ESTABLISHED 28458/0
tcp 0 0 *op3 *:* LISTEN 1711/dovecot
tcp 0 0 *:imap *:* LISTEN 1711/dovecot
tcp 0 0 *:sunrpc *:* LISTEN 1518/rpcbind
tcp 0 0 *:webcache *:* LISTEN 9058/httpd
tcp 0 0 *:http *:* LISTEN 9058/httpd
tcp 0 0 *:tproxy *:* LISTEN 9058/httpd
tcp 0 0 webserverone.hostwit:domain *:* LISTEN 9401/named
tcp 0 0 *:ftp *:* LISTEN 1859/pure-ftpd (SER
tcp 0 0 *:ssh *:* LISTEN 1699/sshd
tcp 0 0 *:smtp *:* LISTEN 15105/master
tcp 0 0 webserverone.hostwiths:rndc *:* LISTEN 9401/named
tcp 0 0 *:https *:* LISTEN 9058/httpd
tcp 0 0 *:imaps *:* LISTEN 1711/dovecot
tcp 0 0 *op3s *:* LISTEN 1711/dovecot
tcp 0 0 *:34506 *:* LISTEN 1538/rpc.statd
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:39898 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38250 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:37935 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 5addab28.bb.sky.com:50922 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 5addab28.bb.sky.com:50929 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:40382 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:40854 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38501 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38302 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:37338 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ec2-175-41-249-4.ap-n:60954 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http crawl-66-249-71-244.g:43209 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:72.21.217.96:18675 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38014 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 216-110-23-20.static.:50234 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:74.112.131.133:34806 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 75.126.3.162-static.r:47449 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:72.21.217.96:40040 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:72.21.217.96:35205 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:39827 TIME_WAIT -
tcp 0 7171 webserverone.hostwiths:http ec2-204-236-249-240.c:34860 FIN_WAIT1 -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:39814 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38005 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:39901 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:72.21.217.96:49839 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 216-110-23-20.static.:49751 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38040 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 216-110-23-20.static.:49983 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38411 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:40984 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:40933 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 5addab28.bb.sky.com:50923 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38560 TIME_WAIT -
tcp 0 8582 webserverone.hostwiths:http 115.108.232.84.static-:vpvc FIN_WAIT1 -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:40352 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:72.21.217.96:61566 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38293 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http CPE-58-164-83-252.lns:49785 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:39580 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http CPE-58-164-83-252.lns:49804 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 115.108.232.84.stat:mvel-lm TIME_WAIT -
tcp 0 8181 webserverone.hostwiths:http ec2-50-17-121-168.com:50651 FIN_WAIT1 -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38518 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:72.21.217.96:10033 ESTABLISHED -
tcp 0 0 webserverone.hostwiths:http ::ffff:180.76.5.97:54264 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:40026 TIME_WAIT -
tcp 0 11040 webserverone.hostwiths:http 115.108.232.84.stat:chip-lm ESTABLISHED -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:39816 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http 216-110-23-20.static.:50300 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:40913 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38519 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http crawl-66-249-71-244.g:52297 TIME_WAIT -
tcp 0 0 webserverone.hostwiths:http ::ffff:124.115.6.20:42354 TIME_WAIT -
tcp 0 7171 webserverone.hostwiths:http ec2-50-17-121-168.com:42645 FIN_WAIT1 -
tcp 0 0 webserverone.hostwiths:http sd-29937.dedibox.fr:38500 TIME_WAIT -

With respect to php.ini exec, no changes have been made. Regarding Squirrelmail, I really don't know the answer to this. I really don't ever use it. It was only a test to see why no message was exchanged from website contact forms, registration forms, etc.

Last, regarding Amavisd, I stopped and started it. Also ran postfix reload. Still stumped.
Reply With Quote
  #4  
Old 28th September 2011, 16:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

amavisd isn't running. If it's still not running after a restart, you should check your logs for errors.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 28th September 2011, 17:13
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
Smile

Hi Falko,

Amavisd is running and has been for some time. If you run the command:

# service amavisd start You will receive an error that it is already running.

If you run # service amavisd restart You will get a successful shutdown and restart every time. There are no amavisd errors in the log files. Only this every time mail attempts to run:


WARNING: RunAsUser for MSP ignored, check group ids (egid=51, want=25)
can not chdir(/var/spool/clientmqueue/): Permission denied
Program mode requires special privileges, e.g., root or TrustedUser.

My assumption is that this a referring to ports?? Don't know what to change and don't want to "butcher" the server files finding out.
Reply With Quote
  #6  
Old 28th September 2011, 18:57
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Look in system/services/service settings and check that amivis amavisd box is checked.

shajazzi
Reply With Quote
  #7  
Old 29th September 2011, 17:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by midcarolina View Post
Hi Falko,

Amavisd is running and has been for some time. If you run the command:

# service amavisd start You will receive an error that it is already running.

If you run # service amavisd restart You will get a successful shutdown and restart every time. There are no amavisd errors in the log files. Only this every time mail attempts to run:
But amavisd isn't shown in the output of netstat -tap, so I guess it dies instantly after a restart. Did you restart it as root?

What's the output of
Code:
ls -la /var/spool/clientmqueue/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 29th September 2011, 19:17
midcarolina midcarolina is offline
Senior Member
 
Join Date: Jul 2011
Posts: 254
Thanks: 1
Thanked 5 Times in 5 Posts
 
Default

Hi Falko,

I got everything fixed completely. I sent you a message about being able to help someone else in this position if they are using a single server IP set-up and Fedora 14 64 bit. I fixed many other problems that may be of help to them. It is not your tutorial for this server set-up. In fact, I started the steps over at page 4 using an up-to-date repo outside of Fedora that I have used in the past for VPS and everything is silky smooth.

Thanks for responding.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Timeout after DATA from some emails treeman Server Operation 13 25th September 2013 12:51
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
Webmail Relay Error palkat General 17 23rd April 2006 18:12


All times are GMT +2. The time now is 01:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.