Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th June 2011, 18:05
BrainyForge BrainyForge is offline
Junior Member
 
Join Date: Jun 2011
Location: Italia
Posts: 27
Thanks: 1
Thanked 4 Times in 4 Posts
Default Forbidden don't have permission ISPConfig 3

Hi, I installed 3 ISPonfig after years of glorious ISP2, is
experiencing the following problem and would like a tip where to start
for debugging.
After a certain time and in a repetitive way, all the sites and the panel is not
reached indicating the following error:

Forbidden
You don't have permission to access /index.php on this server.


After a few minutes, everything returns to work, to reappear after 10 minutes.
Excuse my English.

thanks
Reply With Quote
Sponsored Links
  #2  
Old 19th June 2011, 21:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

This might be a load problem on your server. Do you have munin installed to monitor your server load?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th June 2011, 07:52
BrainyForge BrainyForge is offline
Junior Member
 
Join Date: Jun 2011
Location: Italia
Posts: 27
Thanks: 1
Thanked 4 Times in 4 Posts
Default

I have not installed Munin, I proceed to do so now.
Other problems since I installed ISP 3:
In one month, three times I had to regenerate the SSL certificates, mysteriously
stop working.
For Munin, there is a track ISPConfig3 particular, I asked
safely use http://www.howtoforge.com/server-mon...n-debian-lenny.

My configurations is Debian6 ISPConfig 3

Thank you for your attention
Reply With Quote
  #4  
Old 21st June 2011, 08:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by BrainyForge View Post
For Munin, there is a track ISPConfig3 particular, I asked
safely use http://www.howtoforge.com/server-mon...n-debian-lenny.

My configurations is Debian6 ISPConfig 3
Yes, you can use that tutorial.

Is this a physical server or a virtual machine?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 22nd June 2011, 08:35
BrainyForge BrainyForge is offline
Junior Member
 
Join Date: Jun 2011
Location: Italia
Posts: 27
Thanks: 1
Thanked 4 Times in 4 Posts
Default

It is a virtual server. It runs on Xen.
Meanwhile, thanks for your attention
Reply With Quote
  #6  
Old 27th June 2011, 15:02
BrainyForge BrainyForge is offline
Junior Member
 
Join Date: Jun 2011
Location: Italia
Posts: 27
Thanks: 1
Thanked 4 Times in 4 Posts
Default

The problem is increasingly worse making it impossible to use the webmail, and much less able to click more than two pages on sites.

I could not get a munin in operation, permission problems, I'm still working, but the problem has become intolerable, which logs should be analyzed?

I hope in your help, otherwise I can not help but return to ISPconfig2, given my obvious ignorance of this new software.

Thank you for your attention, greetings from an apprentice ISPCONFIG3
Reply With Quote
  #7  
Old 28th June 2011, 09:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by BrainyForge View Post
I could not get a munin in operation, permission problems,
What's the error message?

Quote:
Originally Posted by BrainyForge View Post
I hope in your help, otherwise I can not help but return to ISPconfig2
Did your ISPConfing 2 setup run on the same configuration (Xen, etc.)?

Is your VM image-based or LVM-based (see http://www.howtoforge.com/using-xen-...ms-debian-etch )?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 28th June 2011, 11:56
BrainyForge BrainyForge is offline
Junior Member
 
Join Date: Jun 2011
Location: Italia
Posts: 27
Thanks: 1
Thanked 4 Times in 4 Posts
Default

Munin works, I had problems to write to say the web, but I easily fixed.

I have not had time to check the result, and here's the link to view the charts, just figured out the problem will proceed to the insertion of a pws.

http://www.brainyforge.net/monitoring/
Reply With Quote
  #9  
Old 29th June 2011, 09:06
BrainyForge BrainyForge is offline
Junior Member
 
Join Date: Jun 2011
Location: Italia
Posts: 27
Thanks: 1
Thanked 4 Times in 4 Posts
Default

Hello everyone,
doing a bit of control, I observed the following daemon.log, which corresponds to my IP, when I denied access.
Code:
Jun 29 08:38:24 ns1 mod_evasive[22104]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:38:28 ns1 mod_evasive[22104]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:38:32 ns1 mod_evasive[22104]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:04 ns1 mod_evasive[22152]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:18 ns1 mod_evasive[22152]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:20 ns1 mod_evasive[22152]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:23 ns1 mod_evasive[22152]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:24 ns1 mod_evasive[22152]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:26 ns1 mod_evasive[22152]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:29 ns1 mod_evasive[22152]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:51 ns1 mod_evasive[20141]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:52 ns1 mod_evasive[22118]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:52 ns1 mod_evasive[21485]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:52 ns1 mod_evasive[20141]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:52 ns1 mod_evasive[20141]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:52 ns1 mod_evasive[20141]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:40:53 ns1 mod_evasive[20141]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:43:01 ns1 dbus-daemon: [system] Reloaded configuration
Jun 29 08:48:06 ns1 mod_evasive[23196]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:48:06 ns1 mod_evasive[23196]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:04 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:06 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:08 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:10 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:11 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:11 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:13 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:14 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:17 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:19 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:21 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied
Jun 29 08:49:27 ns1 mod_evasive[26433]: Couldn't open logfile /var/log/apache2/evasive/dos-2.226.20.134: Permission denied

I would like help on how to proceed in the search, which other logs should I check.

Thanks
Reply With Quote
  #10  
Old 29th June 2011, 09:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
 
Default

The problem is that you installed mod_evasive or a similar apache anti ddos module on the server and you have used too low settings for it, so this module blocked ispconfig. Please change the settings of the anti ddos module that you use to be less strict so that it does not block ispconfig anymore.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
BrainyForge (29th June 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
ISPConfig 3.0.0.9 RC2 released till General 51 17th April 2009 17:12
ISPConfig installation into multiple OpenVZ containers letezo Installation/Configuration 11 3rd March 2009 22:47
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 14:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.