Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th September 2011, 18:08
laptop_user laptop_user is offline
Member
 
Join Date: Aug 2011
Posts: 78
Thanks: 34
Thanked 7 Times in 7 Posts
Default Can't access phpmyadmin

Hi everyone,

After following the debian squeeze tutorial and searching this forum, I still can't get phpmyadmin to work?

I already create the symlink for phpmyadmin
Code:
lrwxrwxrwx 1 root root   27 Sep  9 19:48 phpmyadmin.conf -> /etc/phpmyadmin/apache.conf
However apache restart threw out some error:
Code:
root@server1:/etc/phpmyadmin# /etc/init.d/apache2 restart                                       
Syntax error on line 88 of /etc/apache2/sites-enabled/mywebsite.com.vhost:
Invalid command 'FCGIWrapper', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
 failed!

Is it actually related Any help is appreciated. Thank you all

UPDATE
OK now I remove my domain from Sites module. I already add domain by DNS before so I access the same domain I add in Sites. Now the error I'm getting when apache restart is:
Code:
root@server1:/etc/phpmyadmin# /etc/init.d/apache2 restart
Restarting web server: apache2[Fri Sep 09 20:15:20 2011] [warn] NameVirtualHost 88.76.80.210:80 has no VirtualHosts
[Fri Sep 09 20:15:20 2011] [warn] NameVirtualHost 88.76.80.210:443 has no VirtualHosts
 ... waiting [Fri Sep 09 20:15:21 2011] [warn] NameVirtualHost 88.76.80.210:80 has no VirtualHosts
[Fri Sep 09 20:15:21 2011] [warn] NameVirtualHost 88.76.80.210:443 has no VirtualHosts
Either accessing phpmyadmin via IP or domain both condition failed. Any idea

Thanks in advance

Last edited by laptop_user; 9th September 2011 at 18:20.
Reply With Quote
Sponsored Links
  #2  
Old 10th September 2011, 12:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by laptop_user View Post
However apache restart threw out some error:
Code:
root@server1:/etc/phpmyadmin# /etc/init.d/apache2 restart                                       
Syntax error on line 88 of /etc/apache2/sites-enabled/mywebsite.com.vhost:
Invalid command 'FCGIWrapper', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
 failed!

Is it actually related Any help is appreciated. Thank you all
You probably missed to install the libapache2-mod-fcgid package. Please run
Code:
apt-get install libapache2-mod-fcgid
and restart Apache.
Quote:
Originally Posted by laptop_user View Post
UPDATE
OK now I remove my domain from Sites module. I already add domain by DNS before so I access the same domain I add in Sites. Now the error I'm getting when apache restart is:
Code:
root@server1:/etc/phpmyadmin# /etc/init.d/apache2 restart
Restarting web server: apache2[Fri Sep 09 20:15:20 2011] [warn] NameVirtualHost 88.76.80.210:80 has no VirtualHosts
[Fri Sep 09 20:15:20 2011] [warn] NameVirtualHost 88.76.80.210:443 has no VirtualHosts
 ... waiting [Fri Sep 09 20:15:21 2011] [warn] NameVirtualHost 88.76.80.210:80 has no VirtualHosts
[Fri Sep 09 20:15:21 2011] [warn] NameVirtualHost 88.76.80.210:443 has no VirtualHosts
This is just a warning and means you have no virtual hosts configured on that IP.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th September 2011, 17:54
laptop_user laptop_user is offline
Member
 
Join Date: Aug 2011
Posts: 78
Thanks: 34
Thanked 7 Times in 7 Posts
Default

Hello,

I run the command and restart apache but I still can't login
Code:
root@server1:/# /etc/init.d/apache2 restart
Restarting web server: apache2[Sat Sep 10 19:46:33 2011] [warn] NameVirtualHost 88.76.80.210:80 has no VirtualHosts
[Sat Sep 10 19:46:33 2011] [warn] NameVirtualHost 88.76.80.210:443 has no VirtualHosts
 ... waiting [Sat Sep 10 19:46:34 2011] [warn] NameVirtualHost 88.76.80.210:80 has no VirtualHosts
[Sat Sep 10 19:46:34 2011] [warn] NameVirtualHost 88.76.80.210:443 has no VirtualHosts
.
Code:
Not Found

The requested URL /phpmyadmin was not found on this server.
Apache/2.2.16 (Debian) Server at www.mywesite.me Port 80
Any suggestion Thanks in advance

This is my phpmyadmin cofiguration directory:
Code:
root@server1:/etc/phpmyadmin# ls
apache.conf            config.header.inc.php  lighttpd.conf
config-db.php          config.inc.php         phpmyadmin.service
config.footer.inc.php  htpasswd.setup
I just wondering where all the login page & the .gif image is stored

Last edited by laptop_user; 10th September 2011 at 18:31.
Reply With Quote
  #4  
Old 11th September 2011, 10:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

I suggest you re-enable your sites now. Did you check Apache's error log?

What's in /etc/apache2/conf.d/phpmyadmin.conf?

phpMyAdmin is located in the /usr/share/phpmyadmin directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th September 2011, 19:53
laptop_user laptop_user is offline
Member
 
Join Date: Aug 2011
Posts: 78
Thanks: 34
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by falko View Post
I suggest you re-enable your sites now. Did you check Apache's error log?
OK I enable my site. I didn't assign any client to domain btw, go to mydomain.com/phpmyadmin and was greet with the fancy ISPconfig 404 error page. My apache error log is 2,60 MB in size. What specific thing should I looking for? I upload it to mediafire.

http://www.mediafire.com/?7yw78kzsm97dii8

Quote:
Originally Posted by falko View Post
What's in /etc/apache2/conf.d/phpmyadmin.conf?

phpMyAdmin is located in the /usr/share/phpmyadmin directory.
Code:
root@server1:/etc/apache2/conf.d# cat phpmyadmin.conf
root@server1:/etc/apache2/conf.d# cat phpmyadmin.conf
root@server1:/etc/apache2/conf.d#
It's empty Any idea?
Thank you


UPDATE
I create a symlink
Code:
ln -s /usr/share/phpmyadmin /var/www/mywebsitedomain.com/web
and I got 500 Internal Server error

Help please. Thank you

Last edited by laptop_user; 11th September 2011 at 20:59.
Reply With Quote
  #6  
Old 12th September 2011, 13:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by laptop_user View Post
Code:
root@server1:/etc/apache2/conf.d# cat phpmyadmin.conf
root@server1:/etc/apache2/conf.d# cat phpmyadmin.conf
root@server1:/etc/apache2/conf.d#
It's empty Any idea?
Thank you
Create the file with the following contents:

Code:
# phpMyAdmin default Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
        Options Indexes FollowSymLinks
        DirectoryIndex index.php

        # Authorize for setup
        <Files setup.php>
            # For Apache 1.3 and 2.0
            <IfModule mod_auth.c>
                AuthType Basic
                AuthName "phpMyAdmin Setup"
                AuthUserFile /etc/phpmyadmin/htpasswd.setup
            </IfModule>
            # For Apache 2.2
            <IfModule mod_authn_file.c>
                AuthType Basic
                AuthName "phpMyAdmin Setup"
                AuthUserFile /etc/phpmyadmin/htpasswd.setup
            </IfModule>
            Require valid-user
        </Files>
        <IfModule mod_php4.c>
                AddType application/x-httpd-php .php

                php_flag magic_quotes_gpc Off
                php_flag track_vars On
                php_flag register_globals Off
                php_value include_path .
        </IfModule>
        <IfModule mod_php5.c>
                AddType application/x-httpd-php .php

                php_flag magic_quotes_gpc Off
                php_flag track_vars On
                php_flag register_globals Off
                php_value include_path .
        </IfModule>
AuthType Basic
AuthName "Members Only"
AuthUserFile /usr/share/phpmyadmin/.htpasswd
<limit GET PUT POST>
require valid-user
</limit>
</Directory>
Then restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 12th September 2011, 19:31
laptop_user laptop_user is offline
Member
 
Join Date: Aug 2011
Posts: 78
Thanks: 34
Thanked 7 Times in 7 Posts
Default

Hey thanks for your reply. After restart apache I go to the phpmyadmin login page and the page was asking me my username and password. After I enter my credentials boom I got 500 error page.

The weird thing is I could login if I use terminal
Code:
root@server1:/var/log/apache2# mysql -u root -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 11668
Server version: 5.1.49-3 (Debian)

Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL v2 license

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> bye
    -> ;
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'bye' at line 1
mysql> \q
Bye

What should I do next? I really appreciate your help falko. Thank you
Reply With Quote
  #8  
Old 13th September 2011, 15:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Please check your Apache error log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 13th September 2011, 17:20
laptop_user laptop_user is offline
Member
 
Join Date: Aug 2011
Posts: 78
Thanks: 34
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by falko View Post
Please check your Apache error log.
Code:
[Mon Sep 12 20:35:19 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: login in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: https://www.mywebdomain.com:8080/
[Mon Sep 12 20:38:15 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: client_group_id in /usr/local/ispconfig/interface/web/dns/dns_soa_edit.php on line 221
[Mon Sep 12 20:38:15 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: sys_userid in /usr/local/ispconfig/interface/web/dns/dns_soa_edit.php on line 221
[Mon Sep 12 20:38:15 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140
[Mon Sep 12 20:38:15 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: dns:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140
[Mon Sep 12 20:38:15 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: dns:dns_soa:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140
[Mon Sep 12 20:40:55 2011] [notice] caught SIGTERM, shutting down
[Mon Sep 12 20:40:56 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Sep 12 20:40:56 2011] [warn] RSA server certificate CommonName (CN) `Hadi Akmal' does NOT match server name!?
[Mon Sep 12 20:40:56 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Mon Sep 12 20:40:56 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Sep 12 20:40:56 2011] [warn] RSA server certificate CommonName (CN) `Hadi Akmal' does NOT match server name!?
[Mon Sep 12 20:40:56 2011] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze1 with Suhosin-Patch mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
[Mon Sep 12 21:06:22 2011] [notice] caught SIGTERM, shutting down
[Mon Sep 12 21:06:23 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Sep 12 21:06:23 2011] [warn] RSA server certificate CommonName (CN) `Hadi Akmal' does NOT match server name!?
[Mon Sep 12 21:06:23 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Mon Sep 12 21:06:23 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Sep 12 21:06:23 2011] [warn] RSA server certificate CommonName (CN) `Hadi Akmal' does NOT match server name!?
[Mon Sep 12 21:06:23 2011] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze1 with Suhosin-Patch mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
[Mon Sep 12 21:14:20 2011] [error] [client 115.135.253.115] client denied by server configuration: /etc/apache2/htdocs
[Mon Sep 12 21:14:23 2011] [error] [client 115.135.253.115] client denied by server configuration: /etc/apache2/htdocs
[Tue Sep 13 09:02:27 2011] [error] [client 89.235.6.106] client denied by server configuration: /etc/apache2/htdocs
[Tue Sep 13 14:24:44 2011] [error] [client 202.129.0.23] client denied by server configuration: /etc/apache2/htdocs
[Tue Sep 13 17:40:08 2011] [error] [client 86.120.116.82] client denied by server configuration: /etc/apache2/htdocs
[Tue Sep 13 19:05:15 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: login in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: https://www.mywebdomain.com:8080/index.php
[Tue Sep 13 19:05:25 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: client_group_id in /usr/local/ispconfig/interface/web/dns/dns_soa_edit.php on line 221, referer: https://www.mywebdomain.com:8080/index.php
[Tue Sep 13 19:05:25 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: sys_userid in /usr/local/ispconfig/interface/web/dns/dns_soa_edit.php on line 221, referer: https://www.mywebdomain.com:8080/index.php
[Tue Sep 13 19:05:25 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: https://www.mywebdomain.com:8080/index.php
[Tue Sep 13 19:05:25 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: dns:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: https://www.mywebdomain.com:8080/index.php
[Tue Sep 13 19:05:25 2011] [error] [client 115.135.253.115] PHP Notice:  Undefined index: dns:dns_soa:on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 140, referer: https://www.mywebdomain.com:8080/index.php
Not much to help
Reply With Quote
  #10  
Old 14th September 2011, 10:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Is this from your failed login?
Quote:
[Tue Sep 13 14:24:44 2011] [error] [client 202.129.0.23] client denied by server configuration: /etc/apache2/htdocs
What's in /etc/apache2/htdocs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL Error Nolan Installation/Configuration 12 16th February 2011 02:15
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
ISPConfig breaks access to phpmyadmin vondie Installation/Configuration 4 19th October 2009 16:22
PhpMyadmin access with Ipsconfig Brian_A Installation/Configuration 1 16th December 2008 21:41
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26


All times are GMT +2. The time now is 15:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.