#1  
Old 11th September 2011, 14:07
(O)fer_cz (O)fer_cz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS problem

Hello,

i have multiserver instalation of ISPConfig 3 on Debian 6 Squeeze.
I have problem accessing my websites.

heres intodns.com problem report
Quote:
Mismatched NS records WARNING: One or more of your nameservers did not return any of your NS records.

Error DNS servers responded ERROR: One or more of your nameservers did not respond:
The ones that did not respond are:
On my servers, should etc/resolv.conf be set on my NS or my hosting's NS?

output of dig localhost xxxx.xxx
Quote:
; <<>> DiG 9.7.3 <<>> localhost XXXX.XXX
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34628
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;localhost. IN A

;; ANSWER SECTION:
localhost. 604800 IN A 127.0.0.1

;; AUTHORITY SECTION:
localhost. 604800 IN NS localhost.

;; ADDITIONAL SECTION:
localhost. 604800 IN AAAA ::1

;; Query time: 1 msec
;; SERVER: XXX#53(XXX)
;; WHEN: Sun Sep 11 14:00:37 2011
;; MSG SIZE rcvd: 85

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 59213
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;xxx.xx. IN A

;; Query time: 0 msec
;; SERVER: XXXX#53(XXXX)
;; WHEN: Sun Sep 11 14:00:37 2011
;; MSG SIZE rcvd: 33
output of dig xxxxx.xx

Quote:
; <<>> DiG 9.7.3 <<>> xxxx.xx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 45559
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;xxx.xxx. IN A

;; Query time: 1 msec
;; SERVER: XXXXX#53(XXXXX)
;; WHEN: Sun Sep 11 14:03:14 2011
;; MSG SIZE rcvd: 33
Reply With Quote
Sponsored Links
  #2  
Old 11th September 2011, 14:23
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

You need create A record.

A ns1 111.222.333.444

It isn't the same as

A ns1.yourdomain.com 111.222.333.444
Reply With Quote
  #3  
Old 11th September 2011, 15:21
(O)fer_cz (O)fer_cz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for reply. do you think something else than this?

Reply With Quote
  #4  
Old 11th September 2011, 15:36
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

You need add new records.

A ns1 111.222.333.444
A ns2 111.222.333.444

I'm not sure if you use * instead ip this will works.
Reply With Quote
  #5  
Old 11th September 2011, 15:59
(O)fer_cz (O)fer_cz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default



is that correct now?
Reply With Quote
  #6  
Old 11th September 2011, 16:11
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

Seems ok. What says intodns.com ?

Why your hostname is ns1.domain.tld ?

You can remove these:

A ns1.domain.tld
A ns2.domain.tld
Reply With Quote
  #7  
Old 11th September 2011, 16:34
(O)fer_cz (O)fer_cz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default



unfortunately, problem is still same.

if you think last NS record, its name: my-product-domain.tld data: ns1.my-main-hosting-domain-running-ispc.tld

Quote:
root@ns1:/etc/bind# cat named.conf
// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
root@ns1:/etc/bind# cat named.conf.local
zone "xxxxx.cz" {
type master;
allow-transfer {none;};
file "/etc/bind/pri.xxxxx.cz";
};
zone "yyyyy.com" {
type master;
allow-transfer {none;};
file "/etc/bind/pri.ccccc.com";
};
zone "ns1.xxxxx.cz" {
type master;
allow-transfer {none;};
file "/etc/bind/pri.ns1.xxxxxxxx.cz";
};
Quote:
root@ns1:/etc/bind# ls
bind.keys db.local named.conf.options rndc.key
db.0 db.root pri.xxxxx.cz slave
db.127 named.conf pri.yyyyy.com zones.rfc1918
db.255 named.conf.default-zones pri.ns1.xxxx.cz
db.empty named.conf.local pri.xxxxx.cz
Quote:
root@ns1:/etc/bind# cat pri.xxxxx.cz
$TTL 86400
@ IN SOA ns1.xxxxxx.cz. info.xxxxxxx.cz. (
2011091113 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;

ns1 86400 A 111.222.333.444
ns2 86400 A 111.222.333.555

root@ns1:/etc/bind#

Last edited by (O)fer_cz; 11th September 2011 at 16:42.
Reply With Quote
  #8  
Old 11th September 2011, 16:41
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

Exchange all * per ip
Reply With Quote
  #9  
Old 11th September 2011, 17:58
(O)fer_cz (O)fer_cz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Default

its still same.
if i ssh to my ns1 server, where i got resolv.conf set to my NS, i can ping google, but i cannt ping mywebsite.tld, ping: unknown host. ill try reinstall my NS server... thanks for help
Reply With Quote
  #10  
Old 11th September 2011, 21:52
(O)fer_cz (O)fer_cz is offline
Junior Member
 
Join Date: Sep 2011
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

i have reinstalled ns and its working, thanks for help
edit: maybye you dont have to reinstall server, just check, if you have permissions to access master db
i was switching IPs and didnt query modified commands

Quote:
CREATE USER 'root'@'192.168.0.106' IDENTIFIED BY 'myrootpassword';
GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.0.106' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
etc

Last edited by (O)fer_cz; 11th September 2011 at 23:50.
Reply With Quote
Reply

Bookmarks

Tags
bind9, dns, ispconfig 3, multiserver

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Major recovery Toucan Installation/Configuration 18 9th August 2011 11:45
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Problem in DNS createch Installation/Configuration 1 2nd April 2010 13:18
Slave dns problem blackmask Installation/Configuration 1 3rd October 2007 13:51
DNS issue and user's alias problem rosa hsiao General 3 2nd November 2005 10:03


All times are GMT +2. The time now is 05:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.