Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th July 2006, 19:33
jacobhenry jacobhenry is offline
Member
 
Join Date: Feb 2006
Posts: 45
Thanks: 0
Thanked 2 Times in 2 Posts
Default Domains lead to Apache Directory

I am having a problem with my domains. Every domain I have created leads directly to the /var/www directory instead of to the sites directory. Any help would be appreciated.

Heres my Vhosts_ispconfig.conf
Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 192.168.2.151:80
<VirtualHost 192.168.2.151:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.scratchco.com:80
######################################
#
#
<VirtualHost 192.168.2.151:80>
SuexecUserGroup web1_jacobhenry web1
ServerName www.scratchco.com:80
ServerAdmin webmaster@scratchco.com
DocumentRoot /var/www/web1/web
ServerAlias scratchco.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias  /cgi-bin/ /var/www/web1/cgi-bin/
<Location /cgi-bin>
	SetHandler cgi-script
</Location>
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
</VirtualHost>
#
#
#

Here is part of my apache2.conf file. 'Include /etc/apache2/vhosts/Vhosts_ispconfig.conf' is at the bottom.

Code:
###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

<Directory /var/www/*/web>
    Options +Includes -Indexes -ExecCGI
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /var/www/*/user/*/web>
    Options +Includes -Indexes -ExecCGI
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

<Directory /var/www/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
And finally this is what i get when i run ls -la /root/ispconfig
Code:
root@server1:/etc/apache2/vhosts# ls -la /root/ispconfig
total 100
drwxr-xr-x  9 root root  4096 2006-07-07 15:58 .
drwxr-xr-x  4 root root  4096 2006-07-07 16:15 ..
-rwxr-xr-x  1 root root 33482 2006-07-07 15:36 cronolog
-rwxr-xr-x  1 root root  9673 2006-07-07 15:36 cronosplit
drwxr-xr-x 12 root root  4096 2006-07-07 14:05 httpd
drwxr-xr-x 12 root root  4096 2006-07-07 15:36 isp
-rw-r--r--  1 root root     8 2006-07-07 15:58 .old_path_httpd_root
drwxr-xr-x  6 root root  4096 2006-07-07 14:03 openssl
drwxr-xr-x  6 root root  4096 2006-07-07 14:19 php
drwxr-xr-x  4 root root  4096 2006-07-07 15:36 scripts
drwxr-xr-x  4 root root  4096 2006-07-07 15:36 standard_cgis
drwxr-xr-x  2 root root  4096 2006-07-07 15:36 sv
-rwx------  1 root root  9504 2006-07-07 15:36 uninstall
Reply With Quote
Sponsored Links
  #2  
Old 10th July 2006, 04:51
jacobhenry jacobhenry is offline
Member
 
Join Date: Feb 2006
Posts: 45
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default

Just had to give it some time. Everything is working great now.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with Apache and Updating Jubalint Installation/Configuration 2 21st May 2006 19:50
Mysterious Install Problem tgansert Installation/Configuration 5 9th May 2006 15:35
setup fails on debian 3.1 dtrumbower Installation/Configuration 7 7th March 2006 13:42
Update to 2.2.0 question brianetilley Installation/Configuration 10 4th March 2006 17:02
ISP install problems Debian sarge 3.1 lerra Installation/Configuration 1 5th January 2006 16:37


All times are GMT +2. The time now is 21:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.