Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 31st August 2011, 13:40
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,321 Times in 4,174 Posts
Default

Make sure that you selecetd a IP address and not * in the website settings and that the dns a-record of the domain points to that ip address. Additionally, the ssl checkbox in the site settings has to be enabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 2nd September 2011, 09:43
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

All settings are correct.
Statistic doesn't work too.
Reply With Quote
  #13  
Old 5th September 2011, 19:43
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

I made fresh installation of 'Perfect server Ubuntu 11.04 with Ispconfig 3' and I have the same problem. SSL and statistic doesn't work. I configure certificate and save it (with IP). Again Secure Connection Failed.
When I try to get statistic of the site, I got: The requested URL /stats was not found on this server.

Last edited by hitri; 5th September 2011 at 19:48.
Reply With Quote
  #14  
Old 6th September 2011, 10:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Is the SSL module enabled?
Code:
a2enmod ssl
What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 6th September 2011, 13:30
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

a2enmod ssl:

Module ssl already enabled

netstat -tap

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:http-alt *:* LISTEN 2006/apache2
tcp 0 0 *:www *:* LISTEN 2006/apache2
tcp 0 0 *:tproxy *:* LISTEN 2006/apache2
tcp 0 0 server.mydomain:domain *:* LISTEN 29208/named
tcp 0 0 localhost.locald:domain *:* LISTEN 29208/named
tcp 0 0 *:ftp *:* LISTEN 29189/pure-ftpd (SE
tcp 0 0 *:ssh *:* LISTEN 654/sshd
tcp 0 0 localhost.localdoma:953 *:* LISTEN 29208/named
tcp 0 0 *:smtp *:* LISTEN 28269/master
tcp 0 0 *:https *:* LISTEN 2006/apache2
tcp 0 0 localhost.localdo:10024 *:* LISTEN 28328/amavisd (mast
tcp 0 0 localhost.localdo:10025 *:* LISTEN 28269/master
tcp 0 0 *:mysql *:* LISTEN 28061/mysqld
tcp 0 52 server.mydomain:ssh APN-122-59-103-gp:51130 ESTABLISHED 11291/sshd: iztokm
tcp 65 0 localhost.localdo:37598 localhost.localdo:10025 CLOSE_WAIT 29062/amavisd (ch1-
tcp6 0 0 [::]:imap2 [::]:* LISTEN 29090/couriertcpd
tcp6 0 0 [::]:domain [::]:* LISTEN 29208/named
tcp6 0 0 [::]:ftp [::]:* LISTEN 29189/pure-ftpd (SE
tcp6 0 0 [::]:ssh [::]:* LISTEN 654/sshd
tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 29208/named
tcp6 0 0 [::]:imaps [::]:* LISTEN 29107/couriertcpd
tcp6 0 0 [::]op3s [::]:* LISTEN 29135/couriertcpd
tcp6 0 0 [::]op3 [::]:* LISTEN 29118/couriertcpd


I did everything by the manual, but it doesn't work.

Last edited by hitri; 16th September 2011 at 01:37.
Reply With Quote
  #16  
Old 8th September 2011, 12:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Did you check Apache's error log? Are there any errors in ISPConfig's Monitor module?

Can you post an SSL vhost configuration here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
hitri (8th September 2011)
  #17  
Old 8th September 2011, 12:56
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

Thank you Falko for your replay.

System Messages - Log: Unable to read /var/log/messages

root@server2:/home/iztokm# tail -f /var/log/apache2/error.log
[Thu Sep 08 12:35:02 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc/apache2/htdocs
[Thu Sep 08 12:35:02 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc/apache2/htdocs
[Thu Sep 08 12:35:06 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc/apache2/htdocs
[Thu Sep 08 12:35:06 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc/apache2/htdocs
[Thu Sep 08 12:35:09 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc/apache2/htdocs
[Thu Sep 08 12:35:09 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc/apache2/htdocs
[Thu Sep 08 12:35:10 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc/apache2/htdocs

vi /usr/local/ispconfig/server/conf/vhost.conf.master

------
<tmpl_if name='ssl_enabled'>
<IfModule mod_ssl.c>
################################################## #########
# SSL Vhost
################################################## #########

<VirtualHost <tmpl_var name='ip_address'>:443>
<tmpl_if name='php' op='==' value='suphp'>
DocumentRoot <tmpl_var name='web_document_root'>
</tmpl_else>
<tmpl_if name='php' op='==' value='cgi'>
DocumentRoot <tmpl_var name='web_document_root'>
</tmpl_else>
DocumentRoot <tmpl_var name='web_document_root_www'>
</tmpl_if>
</tmpl_if>

ServerName <tmpl_var name='ssl_domain'>
<tmpl_if name='alias'>
<tmpl_var name='alias'>
</tmpl_if>
ServerAdmin webmaster@<tmpl_var name='domain'>

ErrorLog /var/log/ispconfig/httpd/<tmpl_var name='domain'>/error.log

<tmpl_if name='errordocs'>
ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

</tmpl_if>
SSLEngine on
SSLCertificateFile <tmpl_var name='document_root'>/ssl/<tmpl_var name='ssl_domain'>.crt
SSLCertificateKeyFile <tmpl_var name='document_root'>/ssl/<tmpl_var name='ssl_domain'>.key
<tmpl_if name='has_bundle_cert'>
SSLCACertificateFile <tmpl_var name='document_root'>/ssl/<tmpl_var name='ssl_domain'>.bundle
</tmpl_if>

<Directory {tmpl_var name='web_document_root_www'}>
Options FollowSymLinks
AllowOverride <tmpl_var name='allow_override'>
Order allow,deny
Allow from all
<tmpl_if name='ssi' op='==' value='y'>

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</tmpl_if>
<tmpl_if name='php' op='==' value='no'>
<Files ~ '.php[s3-6]{0,1}$'>
Order allow,deny
Deny from all
Allow from none
</Files>
</tmpl_if>
</Directory>
<Directory {tmpl_var name='web_document_root'}>
Options FollowSymLinks
AllowOverride <tmpl_var name='allow_override'>
Order allow,deny
Allow from all
<tmpl_if name='ssi' op='==' value='y'>

# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Options +Includes
</tmpl_if>
<tmpl_if name='php' op='==' value='no'>
<Files ~ '.php[s3-6]{0,1}$'>
Order allow,deny
Deny from all
Allow from none
</Files>
</tmpl_if>
</Directory>

<tmpl_if name='cgi' op='==' value='y'>
# cgi enabled
<Directory {tmpl_var name='document_root'}/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ <tmpl_var name='document_root'>/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
</tmpl_if>
<tmpl_if name='ssi'op='==' value='y'>
# ssi enabled
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
</tmpl_if>
<tmpl_if name='suexec'op='==' value='y'>
# suexec enabled
SuexecUserGroup <tmpl_var name='system_user'> <tmpl_var name='system_group'>
</tmpl_if>
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
<tmpl_if name='php' op='==' value='mod'>
# mod_php enabled
AddType application/x-httpd-php .php .php3 .php4 .php5
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@<tmpl_var name='domain'>"
php_admin_value upload_tmp_dir <tmpl_var name='document_root'>/tmp
php_admin_value session.save_path <tmpl_var name='document_root'>/tmp
# PHPIniDir <tmpl_var name='custom_php_ini_dir'>
<tmpl_if name='security_level' op='==' value='20'>
php_admin_value open_basedir <tmpl_var name='php_open_basedir'>
</tmpl_if>
-------
Reply With Quote
  #18  
Old 9th September 2011, 17:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by hitri View Post
vi /usr/local/ispconfig/server/conf/vhost.conf.master
This is the template file. Can you post a real vhost (from your /etc/apache2/sites-enabled or /etc/httpd/sites-enabled directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 10th September 2011, 22:54
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

vi /etc/apache2/sites-enabled mydomain.si.vhost:

---
<IfModule mod_ssl.c>
################################################## #########
# SSL Vhost
################################################## #########

<VirtualHost xxx.xxx.xxx.xxx:443>
DocumentRoot /var/www/mydomain.si/web

ServerName www.mydomain.si
ServerAlias www.mydomain.si
ServerAdmin webmaster@mydomain.si

ErrorLog /var/log/ispconfig/httpd/mydomain.si/error.log

ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

SSLEngine on
SSLCertificateFile /var/www/clients/client1/web1/ssl/www.mydomain.si.crt
SSLCertificateKeyFile /var/www/clients/client1/web1/ssl/www.mydomain.si.key

<Directory /var/www/mydomain/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web1/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>

# suexec enabled
SuexecUserGroup web1 client1
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# php as fast-cgi enabled
<IfModule mod_fcgid.c>
# SocketPath /tmp/fcgid_sock/
# IdleTimeout n (3600 seconds)
# An idle fastcgi application will be terminated after IdleTimeout seconds.
IdleTimeout 3600

# ProcessLifeTime n (7200 seconds)
# A fastcgi application will be terminated if lifetime expired, even no error is detected.
ProcessLifeTime 7200

----

Last edited by hitri; 16th September 2011 at 01:40.
Reply With Quote
  #20  
Old 11th September 2011, 10:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Can you post the output of
Code:
ifconfig
?

Also, I'm getting an "Error code: ssl_error_rx_record_too_long" error when I try to visit your SSL site.

What values did you type into ISPConfig when you created the certificate?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3, ssl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can install drupal core site (for multisites) under websites basedir, e.g. /var/www? qiubosu Installation/Configuration 0 12th December 2010 23:06
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
SSL site fails to load crypted Installation/Configuration 4 9th March 2009 08:57
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
Install Error on Debian 3.1 planet_fox Installation/Configuration 4 25th June 2006 17:03


All times are GMT +2. The time now is 18:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.