Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th August 2011, 14:49
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Question When install SSL no more site access

Hi,

I installed "The Perfect Server" on Ubuntu 11.04 with Ispconfig 3. Everythig have worked fine, then I activated SSL cert for the site and now I have no access to my site. Not even http. Only SSH still works. It looks, that apache stop working.

Last edited by hitri; 28th August 2011 at 16:00.
Reply With Quote
Sponsored Links
  #2  
Old 29th August 2011, 11:49
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

Please restart apache on the shell. If it shows an error, post that error.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th August 2011, 12:29
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

I get this:

httpd not running, trying to start
Action 'restart' failed.
The Apache error log may have more information.

And here is apache error log:

[Sun Aug 28 06:26:47 2011] [error] [client 95.176.180.106] PHP Notice: Undefined index: return_to_ur l in /usr/local/ispconfig/interface/lib/classes/tform_actions.inc.php on line 142, referer: http://www.xxxxxxxxxx.si:8080/index.php
[Sun Aug 28 06:26:55 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc /apache2/htdocs
[Sun Aug 28 06:26:56 2011] [error] [client 66.249.66.234] client denied by server configuration: /etc /apache2/htdocs
[Sun Aug 28 06:27:02 2011] [notice] caught SIGTERM, shutting down
[Sun Aug 28 06:27:03 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sun Aug 28 06:27:03 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Aug 28 06:27:03 2011] [notice] Digest: done
[Sun Aug 28 06:27:03 2011] [notice] Apache/2.2.17 (Ubuntu) DAV/2 mod_fcgid/2.3.6 PHP/5.3.5-1ubuntu7.2 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.17 OpenSSL/0.9.8o configured -- resuming normal operations
[Sun Aug 28 06:27:04 2011] [error] [client 95.176.180.106] client denied by server configuration: /et c/apache2/htdocs
[Sun Aug 28 06:27:06 2011] [notice] caught SIGTERM, shutting down
Reply With Quote
The Following User Says Thank You to hitri For This Useful Post:
AbannyvabVask (20th December 2013)
  #4  
Old 29th August 2011, 12:45
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

Please disable the site where you enabled ssl temporarily with the command:

a2dissite yourdomain.tld

replace yourdomain.tld with the domain of that site and restart apache. Then login into ispconfig and check the website settings, especially that there is a unique IP address is assigned to that site and not * and that this IP is not used for another ssl website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th August 2011, 12:54
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

I got:

ERROR: Site mydomain.si does not exist!

I tried with

a2dissite default

got this:

Site default disabled.

Reload apache, still nothing

Last edited by hitri; 29th August 2011 at 18:06.
Reply With Quote
  #6  
Old 29th August 2011, 19:00
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

I have to add vhost:

a2dissite mydomaine.si.vhost

now Ispconfig works, but I can not create certificate
Reply With Quote
The Following User Says Thank You to hitri For This Useful Post:
AbannyvabVask (10th December 2013)
  #7  
Old 29th August 2011, 20:27
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

I explained the next steps that you should do to solve the problem above.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 30th August 2011, 08:51
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
Default

I did like you explain. When I press Save button with SSL Action 'Create certificate', window closes. When I open site again, there is no certificate.
Reply With Quote
  #9  
Old 30th August 2011, 09:37
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

Please check the details that you entered in the ssl certificate fields and ensure that they dont cntain any special characters or umlauts as this might cause openssl to fail to create the ssl cert.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
AbannyvabVask (10th December 2013)
  #10  
Old 31st August 2011, 13:36
hitri hitri is offline
Member
 
Join Date: Jun 2010
Posts: 33
Thanks: 2
Thanked 4 Times in 4 Posts
 
Default

Now manage to make certificate, but browser get me:

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)
Reply With Quote
The Following User Says Thank You to hitri For This Useful Post:
AbannyvabVask (10th December 2013)
Reply

Bookmarks

Tags
ispconfig 3, ssl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can install drupal core site (for multisites) under websites basedir, e.g. /var/www? qiubosu Installation/Configuration 0 12th December 2010 23:06
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
SSL site fails to load crypted Installation/Configuration 4 9th March 2009 08:57
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
Install Error on Debian 3.1 planet_fox Installation/Configuration 4 25th June 2006 17:03


All times are GMT +2. The time now is 13:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.