Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th August 2011, 16:54
matej matej is offline
Member
 
Join Date: May 2006
Posts: 60
Thanks: 6
Thanked 0 Times in 0 Posts
Default mail module doesnt work

I've installed fresh ISP config 3 on Centos 6.0 (folowed perfect manual). Everything went fine, but when I login into ISPConfig panel and click into "Email" module (big icon in header) nothing hapens (ispconfing doesnt show list of email domains...). Sites, dns... everthing works well, just email doesn't work (same if I click domain/alisa, email-mailbox... doesn't show list).

Please help.
Reply With Quote
Sponsored Links
  #2  
Old 28th August 2011, 17:07
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
Default

Is postfix running?
Is mysql running?

Check the outputs of:
netstat -tap
Reply With Quote
  #3  
Old 28th August 2011, 17:52
matej matej is offline
Member
 
Join Date: May 2006
Posts: 60
Thanks: 6
Thanked 0 Times in 0 Posts
Default

yes both of them are running.
As I said, all other "modules" are working fine (so mysql works..), just when I click something inside "email" - it does show any list.
In apache log I cannot find any error. Is there any other (ispconfig specific) log to look at?
Reply With Quote
  #4  
Old 28th August 2011, 18:07
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
Default

In Server -> services is your mail server showing as online?

Have you tried logging into ISPConfig with a different browser?

Yes you can try this:

sh /usr/local/ispconfig/server/cron_daily.sh

If all is well it will say "finished."

Also to get a verbose output do this:

sh -x /usr/local/ispconfig/server/cron_daily.sh

And post the outputs.

Last edited by CSsab; 28th August 2011 at 18:11.
Reply With Quote
  #5  
Old 28th August 2011, 18:20
matej matej is offline
Member
 
Join Date: May 2006
Posts: 60
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Output of cronjob is:

Code:
+ PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin
+ /usr/bin/php -q /usr/local/ispconfig/server/cron_daily.php
PHP Warning:  strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 120
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 120
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 219
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 235
PHP Warning:  date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /usr/local/ispconfig/server/cron_daily.php on line 352
finished.
Probably thease warnings shouldn't be problem?

I'm not sure if I described my problem correctly.
When I click on "Email" in header of ispconfig, I get on left side correct navigator "Email Accounts", and below "Domain, Domain Alias...", but the "main part" of windows remains (it doesn't show "Email Domain list".). I'm attaching screenshot - after login i have clicked Email...

Thanks for help.
Attached Images
 
Reply With Quote
  #6  
Old 28th August 2011, 18:42
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
Default

Yes you described your problem correctly although I have never had this problem which is why I am asking you possibly silly questions .

Okay the timezone problem can be fixed by following the steps here:
http://www.howtoforge.com/forums/showthread.php?t=53610
Reply With Quote
  #7  
Old 28th August 2011, 18:47
matej matej is offline
Member
 
Join Date: May 2006
Posts: 60
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Ok, I hope that someone will have any idea what can I do to fix this problem.
Reply With Quote
  #8  
Old 28th August 2011, 18:52
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
Default

Did you fix your timezone?
Reply With Quote
  #9  
Old 28th August 2011, 19:06
matej matej is offline
Member
 
Join Date: May 2006
Posts: 60
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Yes I did. cron_daily.php gives no error. But "mail module" in ISP config still doesn't work.
Reply With Quote
  #10  
Old 28th August 2011, 19:11
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
 
Default

Can you please restart your services:
/etc/init.d/postfix restart
/etc/init.d/mysql restart
/etc/init.d/apache2 restart

There are other things you can look at if this doesn't work.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig 3.0.3.2 postfix not relaying outgoing attachments mychoice2009 Installation/Configuration 3 13th April 2011 17:42
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Why did Squirrelmail, Dovecot/IMAP & Outbound mail break? websissy Technical 4 29th October 2009 22:39


All times are GMT +2. The time now is 09:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.