#1  
Old 6th July 2006, 21:44
dlikar dlikar is offline
Junior Member
 
Join Date: Jun 2006
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Default Slave DNS problem

DNS records from master to slave server are not transfered. Here are lines from mine /var/log/messages file:

Jul 6 21:31:39 luke named[3827]: zone example.com/IN: Transfer started.
Jul 6 21:31:39 luke named[3827]: transfer of 'example.com/IN' from 111.222.333.444#53: connected using 192.168.0.105#34214
Jul 6 21:31:39 luke named[3827]: dumping master file: slaves/tmp-QmJSyN6yDU: open: file not found
Jul 6 21:31:39 luke named[3827]: transfer of 'example.com/IN' from 111.222.333.444#53: failed while receiving responses: file not found
Jul 6 21:31:39 luke named[3827]: transfer of 'example.com/IN' from 111.222.333.444#53: end of transfer

Anyone has a solution?

Thanks, Dejan
Reply With Quote
The Following User Says Thank You to dlikar For This Useful Post:
bedrock101 (11th June 2007)
Sponsored Links
  #2  
Old 6th July 2006, 22:39
dlikar dlikar is offline
Junior Member
 
Join Date: Jun 2006
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Default

Here is another line from my messages file:

Jul 6 22:35:21 luke named[5964]: example.com/IN: zone transfer deferred due to quota

Dejan
Reply With Quote
  #3  
Old 7th July 2006, 10:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please check that you have enough diskspace in /etc and /var and that you dont have quota restrictions on your named user and group.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 11th June 2007, 18:35
bedrock101 bedrock101 is offline
Junior Member
 
Join Date: Jun 2007
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dlikar
DNS records from master to slave server are not transfered. Here are lines from mine /var/log/messages file:

Jul 6 21:31:39 luke named[3827]: zone example.com/IN: Transfer started.
Jul 6 21:31:39 luke named[3827]: transfer of 'example.com/IN' from 111.222.333.444#53: connected using 192.168.0.105#34214
Jul 6 21:31:39 luke named[3827]: dumping master file: slaves/tmp-QmJSyN6yDU: open: file not found
Jul 6 21:31:39 luke named[3827]: transfer of 'example.com/IN' from 111.222.333.444#53: failed while receiving responses: file not found
Jul 6 21:31:39 luke named[3827]: transfer of 'example.com/IN' from 111.222.333.444#53: end of transfer

Anyone has a solution?

Thanks, Dejan
Well, looking at this posting it appears that its a year old, I am having the same problem and cannot find any other exact references besides this one. Unfortunately no one posted a reply with a fix. Was the problem ever resolved? and if so, how???
Reply With Quote
  #5  
Old 12th June 2007, 13:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Do you use ISPConfig? Is port 53 (TCP and UDP) open on the master?
What are the exact error messages from the master and slave?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 13th June 2007, 17:33
bedrock101 bedrock101 is offline
Junior Member
 
Join Date: Jun 2007
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

The master in this case is a Windows 2003 Standard Server, I can only assume that its listening on port 53. I am not using ISP-Config but I am using Helm, another control panel. Could this be the problem? If so how can it be overcome?

This is what the Fedora box says:

Jun 13 16:24:50 pythagoras named[22157]: dumping master file: slaves/tmp-7gb7AU3I8Z: open: file not found
Jun 13 16:24:50 pythagoras named[22157]: transfer of 'steasp.com/IN' from 82.102.77.66#53: failed while receiving responses: file not found
Jun 13 16:24:50 pythagoras named[22157]: transfer of 'steasp.com/IN' from 82.102.77.66#53: end of transfer
Jun 13 16:37:32 pythagoras named[22157]: zone advonlserv.com/IN: Transfer started.
Jun 13 16:37:32 pythagoras named[22157]: transfer of 'advonlserv.com/IN' from 82.102.77.66#53: connected using 82.102.77.68#51118
Jun 13 16:37:32 pythagoras named[22157]: dumping master file: /var/named/chroot/var/named/slaves/tmp-ydFjZGhILC: open: file not found
Jun 13 16:37:32 pythagoras named[22157]: transfer of 'advonlserv.com/IN' from 82.102.77.66#53: failed while receiving responses: file not found
Jun 13 16:37:32 pythagoras named[22157]: transfer of 'advonlserv.com/IN' from 82.102.77.66#53: end of transfer
Jun 13 16:49:57 pythagoras named[22157]: zone 77.102.82.in-addr.arpa/IN: Transfer started.
Jun 13 16:49:57 pythagoras named[22157]: transfer of '77.102.82.in-addr.arpa/IN' from 82.102.77.66#53: connected using 82.102.77.68#50595
Jun 13 16:49:57 pythagoras named[22157]: dumping master file: slaves/tmp-w5dALpQV5P: open: file not found
Jun 13 16:49:57 pythagoras named[22157]: transfer of '77.102.82.in-addr.arpa/IN' from 82.102.77.66#53: failed while receiving responses: file not found
Jun 13 16:49:57 pythagoras named[22157]: transfer of '77.102.82.in-addr.arpa/IN' from 82.102.77.66#53: end of transfer


Good Luck :-)


Greg
Reply With Quote
  #7  
Old 14th June 2007, 21:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Does the directory /var/named/chroot/var/named/slaves exist? If so, what's the output of
Code:
ls -la /var/named/chroot/var/named/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06
Pri & Slave DNS HOWTO (FC4) ppettigrew Suggest HOWTO 0 1st April 2006 15:35
Problem with slave DNS DarkBen Installation/Configuration 15 5th January 2006 12:42


All times are GMT +2. The time now is 16:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.