Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th August 2011, 17:00
dabbi dabbi is offline
Junior Member
 
Join Date: Jun 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question I am having difficulty enabling SSL

I setup my server following this guide
Then i am trying to enable SSL on my site but am having problems.
The config for the site i want to enable SSL is here verzlun

Config for the default site witch works fine is here default
I want to redirect users to use https://

Config for default-ssl

I want to add in httpd.conf
Redirect Permanent / https://URL

So that users go automatically to the https://URL

How do i go about enabling SSL for verzlun?

Please help.
Reply With Quote
Sponsored Links
  #2  
Old 25th August 2011, 11:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Are there any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th August 2011, 13:30
dabbi dabbi is offline
Junior Member
 
Join Date: Jun 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No i cant see any related error in the log.
It is working now, the SSL atleast.

But when i put the Redirect Permanent in the httpd.conf
It says This webpage has a redirection loop.

Is there another way to make the default allways access https insted of http?

Thx
Reply With Quote
  #4  
Old 26th August 2011, 12:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

You can try this: http://www.besthostratings.com/artic...-htaccess.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 26th August 2011, 13:49
dabbi dabbi is offline
Junior Member
 
Join Date: Jun 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thx i will try that.
Reply With Quote
Reply

Bookmarks

Tags
ssl apache2

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding SSL certificate to Site snowfly Installation/Configuration 2 31st May 2011 12:54
Creating a SSL certificate - Quick guide SamTzu Tips/Tricks/Mods 22 4th January 2011 13:38
https not working after enabling ssl jdg General 3 14th March 2010 21:49
SSL and IPs problem. debian-lover General 7 21st April 2008 11:59
SSL for virtual hosts on one certificate rbartz Tips/Tricks/Mods 8 20th November 2007 17:59


All times are GMT +2. The time now is 13:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.