Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > MyDNSConfig > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th June 2011, 14:08
greystar greystar is offline
Junior Member
 
Join Date: Jun 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mydns Make error - cannot find -lmysqlclient

hi,
i'm running centos 5.6 64bit. when i try to install mydns, "configure" works fine but "make" fails with this:
Code:
/usr/bin/ld: skipping incompatible /usr/lib/mysql/libmysqlclient.so when searching for -lmysqlclient
/usr/bin/ld: skipping incompatible /usr/lib/mysql/libmysqlclient.a when searching for -lmysqlclient
/usr/bin/ld: cannot find -lmysqlclient
collect2: ld returned 1 exit status
make[3]: *** [mydns] Error 1
make[3]: Leaving directory `/root/mydns-1.1.0/src/mydns'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/mydns-1.1.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/mydns-1.1.0'
make: *** [all] Error 2
any ideas how i can fix, i'm stumped

thanks

grey
Reply With Quote
Sponsored Links
  #2  
Old 13th September 2011, 19:15
markhawke7 markhawke7 is offline
Junior Member
 
Join Date: Nov 2008
Posts: 10
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Yes I ran into the same thing last night. In the end, I switched over to Debian Squeeze and followed these directions:
http://www.howtoforge.com/installing...debian-squeeze

That went very well. However, my suspicion that it might have been related to attempting the configure/compile on a 64 bit os and a confusion over the 64bit vs 32bit mydnsclient shared libraries. I have downloaded the 32 bit version of CentOS 5.6 and will give that a try in the next few days. I have a feeling that it may go better with the 32 bit version of CentOS. But that is just a guess.

-Mark
Reply With Quote
The Following User Says Thank You to markhawke7 For This Useful Post:
dahoacuong (15th April 2014)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Security issue bernholdt General 3 5th November 2008 13:04
clamav spamassassin with simscan @ debian Shamael Anwar Installation/Configuration 2 15th December 2006 20:06
Sudden Problem Started using cp: command "omitting directory" bpmee Server Operation 11 22nd November 2006 16:39
Can't find 'make' on new Ubuntu install Arachne Kernel Questions 10 10th August 2006 21:32
view webalizer stats kuyaedz General 22 12th March 2006 14:45


All times are GMT +2. The time now is 05:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.