Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th August 2011, 05:17
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
Default Local Website Url - 403 Forbidden

Hi Guys,

I'm a newbie about knowledge of Ispconfig and how to configure it and I'm tryng to understand about DNS, Redirect, Cname MX Record and all about a webserver configuration. I'm searching on the forum but don't find an answer to my question for this reason I hope you can help me to figure out my troubles

But my question is maybe simple for a Member Senior of this community or for everybody else that know much more than about Ispconfig

MY QUESTION

When I go on the local URL of the the website that I create but It doesn't work

http://192.168.1.106/clients/client1/web1/web

I tryed also

http://192.168.1.106/mywebsite.com/web

and it doesn't work too

I installed the Ispconfig 3 on the last Perfect Server Debian Squeez (3.0.3) on my home webserver when I digit the local URL of the Ispconfig http://192.168.1.106:8080 everything go ok and I can access like Admin

1. I Create a User

On the CLient Tab create the Client: ciao

2. I Create a Website

I create a website I wish run a Ruby or a Ruby On Rails Website but now nevermind if now it doesn't work I want view in the website a simple .html file to understand that it works

Server: server1.mywebsite.com
Client: ciao
IP-Address: *
Domain: mywebsite.com
Harddisk Quota MB: 100 MB
Traffic Quota MB: -1
CGI: NO CHECKED
SSI: NO CHECKED
Ruby: CHECKED
SuEXEC: NO CHECKED
Own Error-Documents: CHECKED
Auto-Subdomain: www.
SSL: NO CHECKED
PHP: Disabled
Active: CHECKED


OTHER INFORMATIONS

in the /etc/apache2/sites-enabled directory I have 5 files

000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
000-default -> ../sites-available/default
000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
000-ispconfig.vhost -> /etc/apache2/sites-available/ispconfig.vhost
mywebsite.com.vhost -> /etc/apache2/sites-available/mywebsite.com.vhost

the last file inside mywebsite.com.vhost have the follow quote maybe is important to know

Quote:

<Directory /var/www/mywebsite.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/mywebsite.com/web

ServerName mywebsite.com
ServerAlias www.mywebsite.com
ServerAdmin webmaster@mywebsite.com

ErrorLog /var/log/ispconfig/httpd/mywebsite.com/error.log


ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/mywebsite.com/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
<Files ~ '.php[s3-6]{0,1}$'>
Order allow,deny
Deny from all
Allow from none
</Files>
</Directory>
<Directory /var/www/clients/client1/web1/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
<Files ~ '.php[s3-6]{0,1}$'>
Order allow,deny
Deny from all
Allow from none
</Files>
</Directory>

<IfModule mod_ruby.c>
<Directory /var/www/clients/client1/web1/web>
Options +ExecCGI
</Directory>
RubyRequire apache/ruby-run
#RubySafeLevel 0
<Files *.rb>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
<Files *.rbx>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
</IfModule>

# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>

# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web1 client1
</IfModule>

<IfModule mod_dav_fs.c>
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>

<Directory /var/www/mywebsite.com/web>
AllowOverride All
</Directory>
</VirtualHost>
TIP:on the MONITOR Tab on the Admin Ispconfig Panel I read

Status of Services (Server : server1.mywebsite.com)

Data from: 2011-08-04 17:40

Web-Server: Offline
FTP-Server: Offline
SMTP-Server: Offline
POP3-Server: Offline
IMAP-Server: Offline
DNS-Server: Offline
mySQL-Server: Offline

maybe this could be useful to understand why it doesn't work

bye & thanks

S
Reply With Quote
Sponsored Links
  #2  
Old 5th August 2011, 09:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Thats all fine and the error shows that your system is working correctly. You canm not access a website folder trogh the IP address, if that would be possible, everyone would be able to hack your server easily.

To access a website, enter the webite domain in the browser. In your case, open a browser and enter:

http://mywebsite.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th August 2011, 04:32
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Thanks Till for the answer

Then I have to set up my home webserver for an internet access?

I recorded mywebsite.com on Godaddy.com I have to look the follow page:

http://www.howtoforge.com/ispconfig_dns_godaddy

to set up my home webserver to access mywebsite.com opening a browser?

thanks

S
Reply With Quote
  #4  
Old 6th August 2011, 12:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

For testing purposes you can modify the hosts file on your client: http://www.howtoforge.com/forums/sho...s+file+windows
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th August 2011, 19:58
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Falko,

I have a linux box with Debian Squeeze (last stable version)

If I want an internet access to my home webserver I have to read this?

http://www.howtoforge.com/ispconfig_dns_godaddy

sorry If I repeat the question but I don't understand your answer

saludos,

S
Reply With Quote
  #6  
Old 7th August 2011, 12:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

You must create DNS records on the authoritative name servers for your domain. These can be your registrar's name servers or your ISPConfig servers or any other server. You can find these out by running
Code:
dig ns yourdomain.com
If your ISPConfig name servers are authoritative, you should take a look at this guide: http://www.howtoforge.com/how-to-run...debian-squeeze

For testing purposes (if you don't want to change DNS records), you can modify your client PC's hosts file.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th August 2011, 21:26
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi all,

I have now two questions and I try to answer to second one If this is no correct I apologize in advance

1. If I want to use Ispconfig and I registered the websites on Godaddy to redirect on my private home websever I need two ip-address?

2. I don't have two ip-address and I register the website on Godaddy I can't use Ispconfig?

If the answer at point 2 is yes then I can use Ispconfig to use a website registered on Godaddy with only an ip-address I have to simply follow these following steps:

a. Create a DNS RECORD from the back end of Ispconfig (I don't want to change DNS records)

Template: Default
Server: server1.mywebsite.com
Client: client1
Domain: mywebsite.com
IP Address: <IP-ADDRESS of the website. ping www.mywebsite.com>
NS 1: ns1.mywebsite.com
NS 2: ns2.mywebsite.com
Email: info@mywebsite.com

b. I modify my client PC's hosts file.

In my home webserver I have 3 host files

/etc/hosts
/etc/resolv.conf
/etc/bind/named.conf

I decided to change /etc/resolv.conf (why? 'cause I red nameserver in it)

# Generated by NetworkManager
nameserver 192.168.1.254, ns1.mywebsite.com, ns2.mywebsite.com

After I restart my home webserver when I write on the browser www.mywebsite.com I have to see the website that I have on my webserver in the following directory:

/var/www/mywebsite.com/web

I made the a. and b. changes but I can't see my folder website. I don't have any idea why this solution doen't work

I'm looking for another solution & bye,

S
pd. mybe when here talk about vhost file is this? /etc/apache2/sites-enabled/mywebsite.com.vhost

Last edited by Salital; 8th August 2011 at 21:40.
Reply With Quote
  #8  
Old 9th August 2011, 11:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

If you want to run your own nameservers with ISPConfig, then you need two IP addresses. However, it is not required that you use the ISPConfig DNS module - for most people it is easier to use the nameservers provided by their registrar.

For example, if you use GoDaddy to register your domains, you can create and manage your DNS records from GoDaddy's control panel, and then you don't need ISPConfig's DNS module. Of course, you can still use ISPconfig to create web sites, email accounts, etc.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 10th August 2011, 03:16
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Hi Falko,

first of all thanks for your answer now if I put on my browser the URL of the website:

mywebsite.com

point to follow directory

/var/www/

but I want to point at following directory:

/var/www/clients/client1/mywebsite.com/web

I don't know if I have to edit a file example: mywebsite.conf at the following file

/etc/apache2/sites-available/mywebsite.com.vhost

bye,

S
Reply With Quote
  #10  
Old 10th August 2011, 09:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
 
Default

You dont have to edit any config files. If apache points the domain to /var/www, then the dns record and apache settings dont match or you missed to enable the auto subdomain www setting. Please check thet you selected the same IP address in the website settings that you used for the dns A-Record of the domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
403 - Forbidden on client website GHz Installation/Configuration 1 15th September 2009 22:31
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
I Fail at installing ispconfig where did I go wrong? stocker741 Installation/Configuration 14 30th October 2008 14:12
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
IMAP doesn't work..as i followed the Perfect Setup for Fedora 4 asokaajay Server Operation 11 10th June 2007 14:57


All times are GMT +2. The time now is 01:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.