Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th July 2006, 20:13
eldaria eldaria is offline
Junior Member
 
Join Date: Apr 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Question ISPConfig and outgoing port 25 blocked

Hi.

I run the Ubuntu 6.06 setup, and ISPConfig.

My ISP is blocking outgoing port 25, I found that out after i moved ISP, and I'm now stuck with them until March.

So during the setup I configured procmail to use my ISP's mail server as a smarthost.

This has worked before with Exchange server.
It was also working fine, until I migrated to new server hardware.

I thought I had configured everything the same, but now I have 2 problems.

First one and so far most important, mail does not get delivered to my mail box, but rather gets bounced back after a while.
With an error message about too many hops.

(domains, IP and usernames replaced)
My config as following.
server hostname: lnx1.mydomain.net
my mail domain configured in ISPConfig: mail.mydomain.net
settings during setup of postfix: mail.mydomain.net
smarthost: smtp.myisp.net

Mail sent to user@mydomain.net get's rejected with follwoing;

Code:
This is the Postfix program at host smtp5.myisp.net.

I'm sorry to have to inform you that the message returned
below could not be delivered to one or more destinations.

For further assistance, please send mail to

If you do so, please include this problem report. You can
delete your own text from the message returned below.

The Postfix program

<web1_user@mail.mydomain.net>: host mail.mydomain.net[my.ip.add.ress] said: 554
Error: too many hops (in reply to end of DATA command)
My second problem is less important since I can use the relay host directly, but would be nice to avoid.
I'm unable to use my server to send mail.
Kontakt(Kmail) gives an error:

Code:
Sending Failed:

Your SMTP server does not support PLAIN.

Chose a different authentication method.

The server responded: "Error: authentication failed"

The message ........
However when detecting what server supports, it configured everything fine.
So I started looking in the logs, and this is what I see:
Code:
Jul  5 18:04:06 lnx1 postfix/smtpd[13414]: connect from unknown[192.168.1.5]
Jul  5 18:04:08 lnx1 postfix/smtpd[13414]: setting up TLS connection from unknown[192.168.1.5]
Jul  5 18:04:08 lnx1 postfix/smtpd[13414]: TLS connection established from unknown[192.168.1.5]: TLSv1 with cipher EXP1024-RC4-SHA (56/128 bits)
Jul  5 18:04:10 lnx1 postfix/smtpd[13414]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jul  5 18:04:10 lnx1 postfix/smtpd[13414]: warning: SASL authentication failure: Password verification failed
Jul  5 18:04:10 lnx1 postfix/smtpd[13414]: warning: unknown[192.168.1.5]: SASL PLAIN authentication failed
Jul  5 18:04:10 lnx1 postfix/smtpd[13414]: lost connection after AUTH from unknown[192.168.1.5]
Jul  5 18:04:10 lnx1 postfix/smtpd[13414]: disconnect from unknown[192.168.1.5]
I should mention that the password is correct. :-)

Huff, long question, hope someone can solve it for me...

Regards.
Brian Levinsen
Reply With Quote
Sponsored Links
  #2  
Old 6th July 2006, 12:25
eldaria eldaria is offline
Junior Member
 
Join Date: Apr 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Cool

Ok, with a bit of experimenting, or actually by misstaske I found out what caused the first error, or actually more of how to solve it.

By changing the domain configured in postfix to be the same as the server is configured as, mail started to come in.
According to the logs, they still seem to get looped through my ISP smtp server, but at least they get delivered eventually.
Is there a reason for Postfix to forward incoming mail to my ISP's server?

Oh and it did not solve my second problem, I still can not send directly through my mail server.

Regards.
Brian Levinsen
Reply With Quote
  #3  
Old 6th July 2006, 13:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by eldaria
Oh and it did not solve my second problem, I still can not send directly through my mail server.

Regards.
Brian Levinsen
Quote:
Jul 5 18:04:10 lnx1 postfix/smtpd[13414]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Please start saslauthd:
Code:
/etc/init.d/saslauthd start
Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 7th July 2006, 00:54
eldaria eldaria is offline
Junior Member
 
Join Date: Apr 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Question

It is started, but just in case I tried to restart it, and then connect.
This is from auth.log and syslog.

Code:
Jul  6 22:45:11 lnx1 sudo: username : TTY=pts/1 ; PWD=/home/username ; USER=root ; COMMAND=/etc/init.d/saslauthd restart
Jul  6 22:46:49 lnx1 postfix/smtpd[2138]: connect from unknown[192.168.1.5]
Jul  6 22:46:51 lnx1 postfix/smtpd[2138]: setting up TLS connection from unknown[192.168.1.5]
Jul  6 22:46:51 lnx1 postfix/smtpd[2138]: TLS connection established from unknown[192.168.1.5]: TLSv1 with cipher EXP1024-RC4-SHA (56/128 bits)
Jul  6 22:46:52 lnx1 postfix/smtpd[2138]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
Jul  6 22:46:52 lnx1 postfix/smtpd[2138]: warning: SASL authentication failure: Password verification failed
Jul  6 22:46:52 lnx1 postfix/smtpd[2138]: warning: unknown[192.168.1.5]: SASL PLAIN authentication failed
Jul  6 22:46:52 lnx1 postfix/smtpd[2138]: lost connection after AUTH from unknown[192.168.1.5]
Jul  6 22:46:52 lnx1 postfix/smtpd[2138]: disconnect from unknown[192.168.
On server I'm running Ubuntu 6.06 and on Desktop I'm running Kubuntu 6.06
Reply With Quote
  #5  
Old 7th July 2006, 12:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Then it seems as if saslauthd is not configured correctly as Postfix is running chrooted. Please configure Postfix and saslauthd as described here: http://www.howtoforge.com/perfect_setup_ubuntu_6.06_p5
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 20:30


All times are GMT +2. The time now is 06:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.