Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th August 2011, 21:06
jasona jasona is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Default stuck on default welcome page

Hi everyone,

I have installed ISP Config 3 following the perfect install to debian squeeze with no apparent problems. After install, I added a website through the admin console logged in as admin.

I get the Welcome to your website! page. When I upload a website via ftp I cannot seem to get past this page. If I so to www.domain/sometingelse.html I get a 404. If I rename the index.html and put a different one I get a page that says something along the lines of "your webmaster has not added content"

I've been searching these boards and google, and pouring over the manual I purchased for several hours and am coming up blank. Can someone point me in the right direction.

thanks,

Jason
Reply With Quote
Sponsored Links
  #2  
Old 6th August 2011, 21:12
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 38
Thanked 89 Times in 68 Posts
Default

Files must have the right owner and permissions. Can you post a ls -la from your web/ directory??
Reply With Quote
  #3  
Old 6th August 2011, 21:34
jasona jasona is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Default

here it is. This issue happens for any website I create.

Code:
root@Websrv1:/var/www/clients/client1/thealvarados.com/web# ls -la
total 28
drwx--x--- 5 web1 client1 4096 Aug  6 18:30 .
drwxr-x--x 6 web1 client1 4096 Aug  6 18:17 ..
-rw-r--r-- 1 web1 client1  429 Aug  6 18:26 Home.html
drwxr-xr-x 2 web1 client1 4096 Aug  6 18:17 error
drwxr-xr-x 5 web1 client1 4096 Aug  6 18:26 htdocs
-rwxr-xr-- 1 web1 client1 1861 Aug  6 18:17 index.html
drwxr-xr-x 2 root root    4096 Aug  6 18:17 stats
root@Websrv1:/var/www/clients/client1/thealvarados.com/web#
Reply With Quote
  #4  
Old 7th August 2011, 12:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

/var/www/clients/client1/thealvarados.com/web has the wrong permissions. Please try
Code:
chmod 755 /var/www/clients/client1/thealvarados.com/web
chmod 755 /var/www/clients/client1/thealvarados.com/
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th August 2011, 12:45
jasona jasona is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I tried this and it didnt seem to get any different results. Here's what I ran and what ther permissions look like now
Code:
root@websrv1:/var/www/clients/client1/thealvarados.com/web# chmod 755 /var/www/clients/client1/thealvarados.com/
root@websrv1:/var/www/clients/client1/thealvarados.com/web# chmod 755 /var/www/clients/client1/thealvarados.com/web
root@websrv1:/var/www/clients/client1/thealvarados.com/web# ls -la
total 28
drwxr-xr-x 5 web1 client1 4096 Aug  8 10:38 .
drwxr-xr-x 6 web1 client1 4096 Aug  6 18:17 ..
-rw-r--r-- 1 web1 client1  429 Aug  6 18:26 Home.html
drwxr-xr-x 2 web1 client1 4096 Aug  6 18:17 error
drwxr-xr-x 5 web1 client1 4096 Aug  6 18:26 htdocs
-rwxr-xr-- 1 web1 client1 1861 Aug  6 18:17 index.html
drwxr-xr-x 2 root root    4096 Aug  7 00:30 stats
root@websrv1:/var/www/clients/client1/thealvarados.com/web#
Reply With Quote
  #6  
Old 8th August 2011, 13:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,438
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

The previous permissions were correct, so there was no need to change them. You get the default index pahe bevcause the new index page you uploaded has a wrong name.

Please deleete the file index.html that is currently in the web directory and rename you "Home.htm" page to "index.html". On Linux servers, the homepage is named index.htm or index.html and not Home.htm like on windows servers. Additionally, it matters on Linux if you bame a file in upper or Loewercaee as these are different filenames. So it is recommended that you name you files alwas lowercase.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 8th August 2011, 13:05
jasona jasona is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanks for the responese. That was one of the steps I tried. What I was doing ws renaming index.html to _index.html. In this instance did what you recommended and now the page says:

Code:
This site is under development
 This is a default template, indicating that the webmaster has not yet uploaded a Web site to the server.
 
For information on how to build or upload a site, please visit your web hosting company's site.

Any ideas?

-Jason
Reply With Quote
  #8  
Old 8th August 2011, 13:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,438
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Ok, so the text that you see in the browser has changed? Then you did the right thing and renamed the correct page.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 8th August 2011, 13:15
jasona jasona is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 2
Thanked 0 Times in 0 Posts
Default

The text did change. But it is now some sort of default webpage from apache or ispconfig? It's definately not the page that was created.

It has the text above, plus like a relate items search page.
Reply With Quote
  #10  
Old 8th August 2011, 13:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,438
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
 
Default

Please post a screenshot of that page. No default page from ispconfig has a search function inside.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 14:51
User creating shoevring Developers' Forum 7 25th July 2010 10:17
amavis: (!!)WARN: all primary virus scanners failed, considering ba jariasca Installation/Configuration 13 20th April 2010 17:34
Admin Program for Virtual Users and Domains Postfix courier etc...(Ubuntu 8.04)? the1rob HOWTO-Related Questions 11 4th August 2009 04:54
Exim MTA dazblade Server Operation 4 16th July 2007 18:42


All times are GMT +2. The time now is 14:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.