#1  
Old 11th January 2012, 18:02
aristotlejones aristotlejones is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default ISPConfig3 and user databases

I have a user working in the ISPConfig3 system, based on the setup found here. He has created a database according to the manual. However I, when logged into phpmyadmin cannot see the database, and none of the credentials of the user, either the ipconfig3 login, nor the database user he created, will log into phpmyadmin.

To follow up, it doesn't appear that ispconfig3 is creating any database users, or databases when logged in as this client account, and on further inspection databases created in ispconfig3 as root are no longer being created.

One more note, at the bottom of phpmyadmin, when logged in as root, it says "The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated"

I did change the root password to mysql the other day, could this have messed things up?

Anyone have any ideas?

Last edited by aristotlejones; 11th January 2012 at 18:14.
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2012, 18:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Most likely the mysql root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf is not set correctly so that ISPConfig can not create databases and users.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th January 2012, 23:08
aristotlejones aristotlejones is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Snapshots are awesome, I rolled it back to right before the password change, then took a look at that password in the config file. Turns out I was mistyping it and there was no need to change it in the first place.

thanks for the quick reply!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPCONFIG3 + No Email Service!!! AntennaMike Installation/Configuration 4 13th February 2013 11:24
httpd fails on start with bad user name ispapps error after Perfect Server ISPconfig3 ssscud HOWTO-Related Questions 11 6th October 2010 14:23
ISPconfig3 user manuals availability prisfeo General 1 27th January 2010 12:37
does anyone have the ISPConfig3 user guide/manual? qiubosu Developers' Forum 1 5th January 2010 17:40
Need Help setting up ISPconfig3 admin user Heeter Installation/Configuration 1 29th May 2009 08:08


All times are GMT +2. The time now is 03:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.