Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd August 2011, 15:20
counterpoint counterpoint is offline
Junior Member
 
Join Date: Jan 2010
Posts: 21
Thanks: 1
Thanked 5 Times in 5 Posts
Default Mail users not found by Postfix when SSL used

I'm building a mail server loosely based on the Debian Squeeze perfect server "how to". The primary mail components are Postfix and Courier, and Postfix is using Courier for user/password authorizations. For more detail please see http://www.howtoforge.com/forums/showthread.php?t=53595

The problem I have now is that the following things happen:

* I can relay mail using SSL/TLS from a mail client, supplying my email address and password

* I can send mail to user who are in the mailbox database provided the mail is relayed through a server that will not attempt an SSL connection to my mail server

* Sending mail to one user through a relay that does try to use SSL results in the mail being rejected as no such user. The same mail can be sent successfully via a non-SSL relay.

* Sending mail to another user through a relay that tries to use SSL results in the mail being accepted but not delivered. The same mail can be sent successfully via a non-SSL relay.

What can I do to diagnose the problems?
Reply With Quote
Sponsored Links
  #2  
Old 4th August 2011, 11:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Are there any errors in your mail log (in the /var/log/ directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th August 2011, 22:50
counterpoint counterpoint is offline
Junior Member
 
Join Date: Jan 2010
Posts: 21
Thanks: 1
Thanked 5 Times in 5 Posts
 
Default

Sorry, the question was posed wrongly - it was what I thought was the situation - but it wasn't correct. Which is why I was having such a struggle!

In fact the relaying server was configured to send the mail somewhere else, so there was no problem at all in my new mail server.

Sorry.
Reply With Quote
The Following User Says Thank You to counterpoint For This Useful Post:
falko (5th August 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mail authentication failure - unknown user or password evok Installation/Configuration 9 16th October 2010 06:37
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 16:27
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 22:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.