Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd August 2011, 19:51
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default All mails in queue

I have all mails in queue, the server doesn't send neither receive, but I can't see any error.

Queue list is like this:

Code:
F260F54801B! 1668 Wed Aug 3 14:19:29 user@gmail.com
pruebas@domain.com
F0A1754801A! 1777 Tue Aug 2 23:10:02 www-data@im.domain.net
www-data@im.domain.net
netstat -tap

Code:
tcp        0      0 localhost:10024         *:*                     LISTEN      17601/amavisd (mast
tcp        0      0 localhost:10025         *:*                     LISTEN      17496/master
tcp        0      0 *:smtp                  *:*                     LISTEN      17496/master
ISPConfig 3.0.3.3
Debian 6.0.2
postfix 2.7.1-1+squeeze1
amavisd-new 1:2.6.4-3
Reply With Quote
Sponsored Links
  #2  
Old 3rd August 2011, 21:13
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

You must have missed a step in the how-to of this site. These how-to's are practically water-tight.

Supply us with some more info f.e.:
- more lines from /var/log/mail.log
- processlist (ps fax)
Reply With Quote
  #3  
Old 3rd August 2011, 21:33
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

I am sure I have did something wrong, but I can't find what

Code:
root@im:~# ps fax
  PID TTY      STAT   TIME COMMAND
    2 ?        S      0:00 [kthreadd]
    3 ?        S      0:00  \_ [migration/0]
    4 ?        S      0:00  \_ [ksoftirqd/0]
    5 ?        S      0:00  \_ [watchdog/0]
    6 ?        S      0:00  \_ [migration/1]
    7 ?        S      0:00  \_ [ksoftirqd/1]
    8 ?        S      0:00  \_ [watchdog/1]
    9 ?        S      0:00  \_ [migration/2]
   10 ?        S      0:00  \_ [ksoftirqd/2]
   11 ?        S      0:00  \_ [watchdog/2]
   12 ?        S      0:00  \_ [migration/3]
   13 ?        S      0:00  \_ [ksoftirqd/3]
   14 ?        S      0:00  \_ [watchdog/3]
   15 ?        S      0:00  \_ [migration/4]
   16 ?        S      0:00  \_ [ksoftirqd/4]
   17 ?        S      0:00  \_ [watchdog/4]
   18 ?        S      0:02  \_ [migration/5]
   19 ?        S      0:00  \_ [ksoftirqd/5]
   20 ?        S      0:00  \_ [watchdog/5]
   21 ?        S      0:00  \_ [migration/6]
   22 ?        S      0:00  \_ [ksoftirqd/6]
   23 ?        S      0:00  \_ [watchdog/6]
   24 ?        S      0:00  \_ [migration/7]
   25 ?        S      0:00  \_ [ksoftirqd/7]
   26 ?        S      0:00  \_ [watchdog/7]
   27 ?        S      0:00  \_ [events/0]
   28 ?        S      0:00  \_ [events/1]
   29 ?        S      0:00  \_ [events/2]
   30 ?        S      0:00  \_ [events/3]
   31 ?        S      0:00  \_ [events/4]
   32 ?        S      0:00  \_ [events/5]
   33 ?        S      0:00  \_ [events/6]
   34 ?        S      0:00  \_ [events/7]
   35 ?        S      0:00  \_ [cpuset]
   36 ?        S      0:00  \_ [khelper]
   37 ?        S      0:00  \_ [netns]
   38 ?        S      0:00  \_ [async/mgr]
   39 ?        S      0:00  \_ [pm]
   40 ?        S      0:00  \_ [sync_supers]
   41 ?        S      0:00  \_ [bdi-default]
   42 ?        S      0:00  \_ [kintegrityd/0]
   43 ?        S      0:00  \_ [kintegrityd/1]
   44 ?        S      0:00  \_ [kintegrityd/2]
   45 ?        S      0:00  \_ [kintegrityd/3]
   46 ?        S      0:00  \_ [kintegrityd/4]
   47 ?        S      0:00  \_ [kintegrityd/5]
   48 ?        S      0:00  \_ [kintegrityd/6]
   49 ?        S      0:00  \_ [kintegrityd/7]
   50 ?        S      0:00  \_ [kblockd/0]
   51 ?        S      0:00  \_ [kblockd/1]
   52 ?        S      0:00  \_ [kblockd/2]
   53 ?        S      0:00  \_ [kblockd/3]
   54 ?        S      0:00  \_ [kblockd/4]
   55 ?        S      0:00  \_ [kblockd/5]
   56 ?        S      0:00  \_ [kblockd/6]
   57 ?        S      0:00  \_ [kblockd/7]
   58 ?        S      0:00  \_ [kacpid]
   59 ?        S      0:00  \_ [kacpi_notify]
   60 ?        S      0:00  \_ [kacpi_hotplug]
   61 ?        S      0:00  \_ [kseriod]
   70 ?        S      0:00  \_ [kondemand/0]
   71 ?        S      0:00  \_ [kondemand/1]
   72 ?        S      0:00  \_ [kondemand/2]
   73 ?        S      0:00  \_ [kondemand/3]
   74 ?        S      0:00  \_ [kondemand/4]
   75 ?        S      0:00  \_ [kondemand/5]
   76 ?        S      0:00  \_ [kondemand/6]
   77 ?        S      0:00  \_ [kondemand/7]
   78 ?        S      0:00  \_ [khungtaskd]
   79 ?        S      0:00  \_ [kswapd0]
   80 ?        SN     0:00  \_ [ksmd]
   81 ?        S      0:00  \_ [aio/0]
   82 ?        S      0:00  \_ [aio/1]
   83 ?        S      0:00  \_ [aio/2]
   84 ?        S      0:00  \_ [aio/3]
   85 ?        S      0:00  \_ [aio/4]
   86 ?        S      0:00  \_ [aio/5]
   87 ?        S      0:00  \_ [aio/6]
   88 ?        S      0:00  \_ [aio/7]
   89 ?        S      0:00  \_ [crypto/0]
   90 ?        S      0:00  \_ [crypto/1]
   91 ?        S      0:00  \_ [crypto/2]
   92 ?        S      0:00  \_ [crypto/3]
   93 ?        S      0:00  \_ [crypto/4]
   94 ?        S      0:00  \_ [crypto/5]
   95 ?        S      0:00  \_ [crypto/6]
   96 ?        S      0:00  \_ [crypto/7]
  253 ?        S      0:00  \_ [ksuspend_usbd]
  254 ?        S      0:00  \_ [khubd]
  268 ?        S      0:00  \_ [ata/0]
  269 ?        S      0:00  \_ [ata/1]
  270 ?        S      0:00  \_ [ata/2]
  271 ?        S      0:00  \_ [ata/3]
  272 ?        S      0:00  \_ [ata/4]
  273 ?        S      0:00  \_ [ata/5]
  274 ?        S      0:00  \_ [ata/6]
  275 ?        S      0:00  \_ [ata/7]
  276 ?        S      0:00  \_ [ata_aux]
  278 ?        S      0:00  \_ [scsi_eh_0]
  279 ?        S      0:00  \_ [scsi_eh_1]
  280 ?        S      0:00  \_ [scsi_eh_2]
  281 ?        S      0:00  \_ [scsi_eh_3]
  282 ?        S      0:00  \_ [scsi_eh_4]
  283 ?        S      0:00  \_ [scsi_eh_5]
  334 ?        S      0:00  \_ [usbhid_resumer]
  339 ?        S      0:00  \_ [kjournald]
  606 ?        S      0:00  \_ [scsi_eh_6]
  607 ?        S      0:00  \_ [usb-storage]
  609 ?        S      0:00  \_ [scsi_eh_7]
  610 ?        S      0:00  \_ [usb-storage]
  796 ?        S      0:00  \_ [flush-8:0]
  962 ?        S      0:03  \_ [kjournald]
    1 ?        Ss     0:01 init [2]  
  386 ?        S<s    0:00 udevd --daemon
  529 ?        S<     0:00  \_ udevd --daemon
  531 ?        S<     0:00  \_ udevd --daemon
 1211 ?        Sl     1:05 /usr/sbin/rsyslogd -c4
 1558 ?        Ss     0:00 /usr/sbin/acpid
 1570 ?        Ss     0:00 /usr/bin/dbus-daemon --system
 1790 ?        Ss     0:10 /usr/sbin/spamd --create-prefs --max-children 5 --hel
 2058 ?        S      0:00  \_ spamd child
 2059 ?        S      0:00  \_ spamd child
 2069 ?        Ss     0:02 /usr/sbin/ntpd -p /var/run/ntpd.pid -g -u 107:111
 2268 ?        Ss     0:00 /usr/sbin/cron
 2336 tty1     Ss+    0:00 /sbin/getty 38400 tty1
 2337 tty2     Ss+    0:00 /sbin/getty 38400 tty2
 2338 tty3     Ss+    0:00 /sbin/getty 38400 tty3
 2339 tty4     Ss+    0:00 /sbin/getty 38400 tty4
 2340 tty5     Ss+    0:00 /sbin/getty 38400 tty5
 2341 tty6     Ss+    0:00 /sbin/getty 38400 tty6
 3264 ?        Ss     0:00 /usr/sbin/sshd
18041 ?        Ss     0:00  \_ sshd: root@pts/0 
18086 pts/0    Ss     0:00      \_ -bash
18135 pts/0    R+     0:00          \_ ps fax
  300 ?        S      0:00 /bin/sh /usr/bin/mysqld_safe
  411 ?        Sl     0:09  \_ /usr/sbin/mysqld --basedir=/usr --datadir=/var/li
  412 ?        S      0:00  \_ logger -t mysqld -p daemon.error
 1679 ?        Ss     0:00 pure-ftpd (SERVER)                                  
 1700 ?        Ssl    0:38 /usr/sbin/named -u bind
19365 ?        Ss     0:00 /usr/sbin/apache2 -k start
29483 ?        S      0:00  \_ /bin/sh -c /usr/local/ispconfig/server/scripts/vl
29484 ?        S      0:00  |   \_ vlogger (access log)
29485 ?        S      0:00  \_ /usr/sbin/apache2 -k start
29578 ?        S      0:02  \_ /usr/sbin/apache2 -k start
 4162 ?        S      0:00  \_ /usr/sbin/apache2 -k start
32077 ?        S      0:02  \_ /usr/sbin/apache2 -k start
31036 ?        S      0:01  \_ /usr/sbin/apache2 -k start
32573 ?        S      0:00  \_ /usr/sbin/apache2 -k start
19609 ?        S      0:00  \_ /usr/sbin/apache2 -k start
 2791 ?        S      0:00  \_ /usr/sbin/apache2 -k start
 3837 ?        S      0:00  \_ /usr/sbin/apache2 -k start
 4513 ?        S      0:00  \_ /usr/sbin/apache2 -k start
20276 ?        S      0:00  \_ /usr/sbin/apache2 -k start
 2992 ?        Sl     0:02 /usr/bin/python /usr/bin/fail2ban-server -b -s /var/r
21272 ?        Ss     0:00 /usr/sbin/dovecot -c /etc/dovecot/dovecot.conf
21274 ?        S      0:00  \_ dovecot-auth
21275 ?        S      0:00  \_ dovecot-auth -w
12015 ?        S      0:00  \_ pop3-login
 5655 ?        S      0:00  \_ imap-login
 8338 ?        S      0:00  \_ imap-login
15437 ?        S      0:00  \_ pop3-login
16417 ?        S      0:00  \_ pop3-login
17602 ?        S      0:00  \_ imap-login
20632 ?        SNs    0:02 MailScanner: starting child
18043 ?        ZN     0:01  \_ [MailScanner] <defunct>
18092 ?        ZN     0:01  \_ [MailScanner] <defunct>
15349 ?        Ss     0:03 /usr/bin/freshclam -d --quiet
15565 ?        Ss     0:00 /usr/lib/postfix/master
15567 ?        S      0:00  \_ pickup -l -t fifo -u -c
15568 ?        S      0:00  \_ qmgr -l -t fifo -u
16866 ?        S      0:00  \_ tlsmgr -l -t unix -u -c
17861 ?        S      0:00  \_ flush -z -t unix -u -c
20005 ?        Ss     0:01 amavisd (master)
20048 ?        S      0:00  \_ amavisd (virgin child)
20049 ?        S      0:00  \_ amavisd (virgin child)
25770 ?        Ssl    0:00 /usr/sbin/clamd
Code:
Aug  3 21:24:41 server MailScanner[18875]: MailScanner E-Mail Virus Scanner version 4.79.11 starting...
Aug  3 21:24:41 server MailScanner[18875]: Reading configuration file /etc/MailScanner/MailScanner.conf
Aug  3 21:24:41 server MailScanner[18875]: Reading configuration file /etc/MailScanner/conf.d/README
Aug  3 21:24:41 server MailScanner[18875]: Read 858 hostnames from the phishing whitelist
Aug  3 21:24:41 server MailScanner[18875]: Read 5497 hostnames from the phishing blacklists
Aug  3 21:24:41 server MailScanner[18875]: Using SpamAssassin results cache
Aug  3 21:24:41 server MailScanner[18875]: Connected to SpamAssassin cache database
Aug  3 21:24:41 server MailScanner[18875]: Enabling SpamAssassin auto-whitelist functionality...
Aug  3 21:24:43 server MailScanner[18875]: I have found clamd scanners installed, and will use them all by default.
Aug  3 21:24:43 server MailScanner[18875]: Connected to Processing Attempts Database
Aug  3 21:24:43 server MailScanner[18875]: Found 0 messages in the Processing Attempts Database
Aug  3 21:24:43 server MailScanner[18875]: Using locktype = flock
Reply With Quote
  #4  
Old 3rd August 2011, 21:42
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Your MailScanner is running as a Zombie

Code:
20632 ?        SNs    0:02 MailScanner: starting child
18043 ?        ZN     0:01  \_ [MailScanner] <defunct>
18092 ?        ZN     0:01  \_ [MailScanner] <defunct>
You could try to stop mailscanner see if the zombies are gone and start it again
then keep track of the child procs if they aren't defuncing again. if so, then you have a configuration error in Mailscanner and you should recheck your settings, check the log files for any errors etc ..

If the zombies won't go, reboot the server, it's the only way to get rid of them.

All your mails are on hold atm, you can requeue them again with
Code:
postsuper -H ALL
after that, keep an eye on your mail.log file and watch for errors.
Reply With Quote
  #5  
Old 3rd August 2011, 22:10
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

Well, I don't know what is a "zombie process", but I imagine is not good a thing.

I stop mailscanner, and I start it then and I get the same.

Then I restart the server, and I still having zombies I think.

Code:
1734 ?        SNs    0:00 MailScanner: starting children
 1735 ?        ZN     0:01  \_ [MailScanner] <defunct>
 1871 ?        ZN     0:01  \_ [MailScanner] <defunct>
I had not touched /etc/MailScanner/MailScanner.conf before. What can I check there?
Reply With Quote
  #6  
Old 3rd August 2011, 22:57
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Quote:
Originally Posted by mentes View Post
Well, I don't know what is a "zombie process", but I imagine is not good a thing.

I had not touched /etc/MailScanner/MailScanner.conf before. What can I check there?
Zombies are dead processes that can't be released. (man ps)

You should double check your log files, there must be something in it that could give you a lead on what's going on ..

Else remove Mailscanner from your mail setup and see if it works.

did you try postsuper -H ALL ?

Why are you using mailscanner btw?

If your new to all this, you might want to use one of the "Perfect How-to's from this site to get your ispconfig system up and running.
Reply With Quote
  #7  
Old 3rd August 2011, 23:23
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

Suddenly works!

Code:
 5774 ?        SNs    0:00 MailScanner: starting child
25136 ?        SN     0:01  \_ MailScanner: waiting for messages
25180 ?        SN     0:01  \_ MailScanner: waiting for messages

I need execute "postsuper -H ALL" and wait 5 minutes until I receive mails from or to gmail.com but works.

And now I have this:

Code:
0D102B020C1 1770 Wed Aug 3 22:54:17 www-data@im.server.net
(Host or domain name not found. Name service error for name=im.server.net type=MX: Host not found, try again)
www-data@im.server.net
Reply With Quote
  #8  
Old 3rd August 2011, 23:31
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

Quote:
Originally Posted by mentes View Post
Suddenly works!
nice, good to hear!

Quote:
Originally Posted by mentes View Post
I need execute "postsuper -H ALL" and wait 5 minutes until I receive mails from or to gmail.com but works.
That's because there where mostlikely more mails in the queue that needed to be processed, depending on the size of the queue it can take from 2 seconds up to hours.

Quote:
Originally Posted by mentes View Post
And now I have this:

Code:
0D102B020C1 1770 Wed Aug 3 22:54:17 www-data@im.server.net
(Host or domain name not found. Name service error for name=im.server.net type=MX: Host not found, try again)
www-data@im.server.net
im.server.net has no MX records, you should create one that points to your server.
Reply With Quote
  #9  
Old 3rd August 2011, 23:35
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
Default

I post my reply without read yours.

Why I am using mailscanner? That is a good question. I don't know

I follow this how to http://www.howtoforge.com/perfect-se...ot-ispconfig-3 but I have Debian 6.0.2

Without installing Squirrelmail, and a piece of this http://www.howtoforge.com/extending-...ze-ispconfig-3 for install Roundcube
Reply With Quote
  #10  
Old 3rd August 2011, 23:39
mentes mentes is offline
Senior Member
 
Join Date: Aug 2011
Location: Spain
Posts: 132
Thanks: 4
Thanked 15 Times in 13 Posts
 
Default

Quote:
Originally Posted by Mentes
I need execute "postsuper -H ALL" and wait 5 minutes until I receive mails from or to gmail.com but works.
Quote:
Originally Posted by Mark_NL View Post
That's because there where mostlikely more mails in the queue that needed to be processed, depending on the size of the queue it can take from 2 seconds up to hours.
I have only 2 mails in queue. And I need execute "postsuper -H ALL" manualy or I can't send or receive mails.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
delay in sending email Hellbound General 4 9th November 2012 10:53
Unable to Receve Email walner8080 Installation/Configuration 8 30th September 2010 05:58
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
mail stop on one account provell General 10 26th November 2009 21:29
ISPConfig with postfix problem Chrisssssss General 30 20th January 2007 23:34


All times are GMT +2. The time now is 18:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.