Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th July 2011, 18:53
GioMBG GioMBG is offline
Junior Member
 
Join Date: Dec 2009
Location: Rimini
Posts: 28
Thanks: 2
Thanked 1 Time in 1 Post
Default how to config sendmail.mc to receive email in debian squeeze

Hi Staff,
is three day that I try to configure sendmail.mc with my debian squeeze to receive email from external, I can only send mail but I don't receive mail from local too.
note that the sent email to debian don't return to the original sent server.

I just try work around the famous DAEMON_OPTIONS:
Code:
FEATURE(`no_default_msa')dnl
dnl DAEMON_OPTIONS(`Family=inet6, Name=MTA-v6, Port=smtp, Addr=::1')dnl
DAEMON_OPTIONS(`Family=inet,  Name=MTA-v4, Port=smtp, Addr=127.0.0.1')dnl
dnl DAEMON_OPTIONS(`Family=inet6, Name=MSP-v6, Port=submission, M=Ea, Addr=::1')dnl
DAEMON_OPTIONS(`Family=inet,  Name=MSP-v4, Port=submission, M=Ea, Addr=127.0.0.1')dnl
commenting and de- commenting dnl etc.
what I can only cause don't send like don't receive.
Let me know what I have to do,
what log I have to post
what form have to see
--
I'm waiting for You.
thx
GioMBG
Reply With Quote
Sponsored Links
  #2  
Old 31st July 2011, 13:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Sendmail is very difficult to configure. Have you thought about using Postfix instead?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st July 2011, 15:31
GioMBG GioMBG is offline
Junior Member
 
Join Date: Dec 2009
Location: Rimini
Posts: 28
Thanks: 2
Thanked 1 Time in 1 Post
Default postfix exim4 and sendmail make me carzy in debian

Hi Falko,
I'm totally with You regarding sendmail on debian squizee
but I go crazy with exim4 and postfix to...
any time I don't have received an email sent to this machine and in the logs I see that all was rejected, now (is to verify) I'm just worried about some wrong parameter that would be like the hostname so I have a suspect: that in my rescue hetzner installimage tool when is asked what kind of hostname give to the server the tool do not edit in all the places that have to edit (is a suspect) now I have totally changed distro I choose a centos minimal 6 64bit and everythink appears MORE simple... but is early, in few hours I will install a mail transport and I will return here.
if You can tell me if there is a procedure to verify that all the places that have to be named like the hostname I will check asap before reset the first centos test set up
thx 4 now
GioMBG
Reply With Quote
  #4  
Old 1st August 2011, 10:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Does the hostname you use exist in DNS? If not, either create an A record or use the hostname Hetzner gives to your server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th August 2011, 19:42
GioMBG GioMBG is offline
Junior Member
 
Join Date: Dec 2009
Location: Rimini
Posts: 28
Thanks: 2
Thanked 1 Time in 1 Post
 
Default the hostname I use was in my DNS

Hi Falko,
sorry for the late reply
the hostname I use was in my DNS...

after 3 days of slap and big face, crying I try centos 6.0 and...
I've understand that for me the life is easy with this distro!
I make all the machine from 0 in one night.
so respecting debian is not really my favourite.
Thx
GioMBG
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
email sebd receive problems patfee Installation/Configuration 1 5th December 2007 15:44
Can't receive email merlincc General 4 6th December 2006 00:50
Can Send email but not receive it using sendmail on debian ZeroDni Installation/Configuration 7 25th June 2006 07:04
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 11:48
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 15:42


All times are GMT +2. The time now is 14:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.