Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd July 2011, 00:57
fordwrench fordwrench is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 4 Times in 2 Posts
Default roundcube problem www.mysite.com/webmail

I installed ispconfig on debian 6 with this guide.

http://www.howtoforge.com/perfect-se...er-ispconfig-3

Then followed with this guide.

http://www.howtoforge.com/extending-...ze-ispconfig-3

when I enter www.mysite.com/webmail

it gives this error

Iceweasel can't establish a connection to the server at www.mysite.com:8080

I can get to roundcube with:
https://www.mysite.com:50443/webmail

How to I fix it so that when I put in www.mysite.com/webmail it redirects to

https://www.mysite.com:50443/webmail


Fordwrench
Reply With Quote
Sponsored Links
  #2  
Old 24th July 2011, 02:07
fordwrench fordwrench is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 4 Times in 2 Posts
Default

Anyone?... 72 views and not a hint....

Have have read every post having to do with webmail and roundcube and have not found the answer.
Reply With Quote
  #3  
Old 24th July 2011, 02:39
fordwrench fordwrench is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 4 Times in 2 Posts
Default

Nevermind

I got fixed... one guide had me create file roundcube in
/etc/apache2/conf.d/

and there was also roundcube.conf file in the same dir with conflicting config information.


Thanks for looking ...hope this helps someone else.
Reply With Quote
The Following User Says Thank You to fordwrench For This Useful Post:
falko (24th July 2011)
  #4  
Old 25th July 2011, 18:49
fordwrench fordwrench is offline
Member
 
Join Date: Apr 2007
Posts: 58
Thanks: 6
Thanked 4 Times in 2 Posts
Default

Well I thought I had it fixed completely, but no....

Some sites work with www.mysite.com/webmail

some download = download.php


<?php

/**
* index.php
*
* Redirects to the login page.
*
* @copyright 1999-2010 The SquirrelMail Project Team
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
* @version $Id: index.php 13893 2010-01-25 02:47:41Z pdontthink $
* @package squirrelmail
*/

// Are we configured yet?
if( ! file_exists ( 'config/config.php' ) ) {
echo '<html><body><p><strong>ERROR:</strong> Config file ' .
'&quot;<tt>config/config.php</tt>&quot; not found. You need to ' .
'configure SquirrelMail before you can use it.</p></body></html>';
exit;
}

// If we are, go ahead to the login page.
header('Location: src/login.php');

?>


Originally I had squirrelmail
Now I have roundcube mail
Reply With Quote
  #5  
Old 26th July 2011, 17:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do all your sites have PHP enabled? Do they all use the same PHP mode?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 26th July 2011, 18:16
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

sed -i '1 i AddHandler application\/x-httpd-php .php .php3 .php4 .php5' /usr/share/roundcube/.htaccess

This should fix your problem with any php mode selected in every site. It is working for me, but use it at your own risk :P

(basically, every time a client access roundcube, this line will change the handler used by roundcube)
Reply With Quote
  #7  
Old 31st July 2011, 16:21
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
Default

Quote:
Originally Posted by fordwrench View Post
Nevermind

I got fixed... one guide had me create file roundcube in
/etc/apache2/conf.d/

and there was also roundcube.conf file in the same dir with conflicting config information.


Thanks for looking ...hope this helps someone else.
As I mention in http://www.howtoforge.com/extending-...ispconfig-3-p2 you have to paste some line in the end of the file, so as the redirection to port 50443 is made.

Did you do this?
Reply With Quote
  #8  
Old 31st July 2011, 16:30
8omas 8omas is offline
Senior Member
 
Join Date: Jan 2011
Posts: 148
Thanks: 16
Thanked 35 Times in 26 Posts
 
Default

Have in mind that the tutorial assumes the redirection of all ssl traffic to ISPCONFIG to port 50443. So if you want ssl for roundcube you have to paste the two directives.
If you don't want to change ports then you must skip the parts of redirecting to port 50443.
It all or nothing thing..
Either you change the port 8080 to 50443 for all ssl traffic or not.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix/cleanup: warning: virtual_alias_maps map lookup problem penkku Server Operation 1 11th February 2011 13:48
Roundcube HTML format problem Captain General 4 6th December 2010 18:29
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
Roundcube user@WWW.domain.com Problem unitetech Installation/Configuration 0 31st January 2007 23:26
Roundcube - big attachament problem it0007 Installation/Configuration 6 2nd January 2007 22:10


All times are GMT +2. The time now is 10:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.