Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 12th September 2011, 12:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

I guess with the code:

$awmonth = date("m"+1-1);

you like to have the month without leading 0, so that it is 1 instead of 01? In that case it might be better to use this:

$awmonth = date("n");
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
erosbk (12th September 2011)
Sponsored Links
  #12  
Old 14th September 2011, 20:51
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

When change from Webalizer to AWStats (or AWStats to Webalizer), index.php and index.html must be deleted, if not deleted, one file has priority over the other...

I will make the changes and post changes here tomorrow
Reply With Quote
  #13  
Old 16th September 2011, 01:25
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 25 Times in 14 Posts
Default

hi,

What will happen, if user has no php active?
Maybe extra vhost entry?

regards
xaver
Reply With Quote
  #14  
Old 16th September 2011, 17:49
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Good point, maybe with a htaccess it could be fixed, or be host must have settings to use mod_php for this in this directory...

I will work on this...

Regards!
Reply With Quote
  #15  
Old 16th September 2011, 20:51
xaver xaver is offline
Member
 
Join Date: May 2009
Posts: 77
Thanks: 10
Thanked 25 Times in 14 Posts
Default

Hi,

no it cant -> Override setting.
Best & easiest you add in master template a directory.

EDIT:
Maybe you can do this too, if you add a vhost part:
http://bugtracker.ispconfig.org/inde...s&task_id=1749
directory index and AllowOverride auth

regards

Last edited by xaver; 18th September 2011 at 02:47.
Reply With Quote
  #16  
Old 23rd September 2011, 06:01
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

** Update: Bug Fix **

1) When awstats/webalizer are selected, older index.html of webalizer or index.php of awstats must be deleted in order to avoid conflict between them.

So, when you select awstats, index.html is deleted (apache2_plugin.inc.php). If webalizer, index.php is deleted every time cron_daily.php is executed (cron_daily.php).

2) index.php.awstats was modified to fix january month bug...

Main post has been updated. Till, do you need modified the task in roadmap too?

Regards
Reply With Quote
  #17  
Old 23rd September 2011, 09:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

Thanks for the update. I will add it to svn directly, no need to reopen the task in the bugtracker.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 30th September 2011, 09:00
zbuzanic zbuzanic is offline
Member
 
Join Date: Sep 2011
Location: Zagreb
Posts: 79
Thanks: 43
Thanked 20 Times in 13 Posts
Default

I have problems with AWstats. On some domains it's working fine, on some gives 404, althought there is awstats *.html files in stats directory for all domains.
How to check what went wrong?

ps. using SVN
__________________
ISPConfig -> the best open source control panel
Reply With Quote
  #19  
Old 30th September 2011, 16:39
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

AWStats index.php (as posted) search for fixedindex.html to show stats. If the file is named differently, it will not find the file and will return 404.

I don't have the svn version to test how the code was implemented...

In the mean while, could you post error log here of one of your domains with the problem?

Regards
Reply With Quote
  #20  
Old 1st October 2011, 22:01
zbuzanic zbuzanic is offline
Member
 
Join Date: Sep 2011
Location: Zagreb
Posts: 79
Thanks: 43
Thanked 20 Times in 13 Posts
 
Default

My bad, it seems there was not enough data to generate stats after 3 days
__________________
ISPConfig -> the best open source control panel
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig 3 - awstats Mouton Tips/Tricks/Mods 99 27th January 2011 10:31


All times are GMT +2. The time now is 18:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.