Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th April 2012, 14:17
vinod.linux vinod.linux is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default Api method mail_user_add is not crating the mailbox

I am using ispconfig remoting api in order to create new mailbox user.
I have tried mail_user_add api method. Its returning a sucess method and details are saved in mail_user table. But there is no folder created under /var/vmail/email.biz folder.

I know that it creates the folder when it receives the mail. I tried to send mail to newly created user "hmmnoe@email.biz".

Log file says

temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to create a dot-lock at /var/vmail/email.biz/hmmnoe/21182.0.gsmtp.email.biz. )

Now i am unable figure out wass the exact problem is.Any help will be highly appreciated
__________________
VINOD THAKUR
Reply With Quote
Sponsored Links
  #2  
Old 30th April 2012, 16:49
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,460
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Most likely a parameter that you passed to the function was wrong e.g. you passed a wrong maildir path. See here for instructions to debug ispconfig:

http://www.faqforge.com/linux/debugg...-of-a-failure/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
vinod.linux (30th April 2012)
  #3  
Old 30th April 2012, 17:15
vinod.linux vinod.linux is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Most likely a parameter that you passed to the function was wrong e.g. you passed a wrong maildir path. See here for instructions to debug ispconfig:

http://www.faqforge.com/linux/debugg...-of-a-failure/
Yes i was passing wrong path for maildir. I modified it with correct one. Now directories are created even i can access the welcome mail but when i tried to send email to newly created mailbox i got following error

Apr 30 20:39:07 dianin postfix/smtpd[12659]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 554 5.1.1 <kev@email.biz>: Recipient address rejected: User unknown in virtual mailbox table; from=<info@email.biz> to=<kev@email.biz> proto=ESMTP helo=<www.email.biz>
Apr 30 20:39:07 dianin postfix/smtpd[12659]: disconnect from localhost[127.0.0.1]
__________________
VINOD THAKUR
Reply With Quote
  #4  
Old 30th April 2012, 17:38
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,460
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Are the email and login field of the mail_user table filled in corrcty of the user that you created? Compare it with a user that you created in the ispconfig interface.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st May 2012, 09:12
vinod.linux vinod.linux is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
 
Thumbs up Its working now

Quote:
Originally Posted by till View Post
Are the email and login field of the mail_user table filled in corrcty of the user that you created? Compare it with a user that you created in the ispconfig interface.
Yes the problem was in one field, postfix field in user_data table was set to 'n' , i changed it into 'y' its working fine now.
Thanks Till
__________________
VINOD THAKUR
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 Autoresponder, adding subdomain problem BlackHat Installation/Configuration 4 18th October 2011 14:24
ISPConfig3 + API + BoxBilling class450dude Installation/Configuration 3 22nd August 2011 22:32
Unable to receive mail - Can't open Mailbox he14607 Installation/Configuration 2 8th June 2010 10:28


All times are GMT +2. The time now is 12:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.