Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th July 2011, 00:11
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default Webdav doesn't work

Cannot display location "dav://mydomain.com/webdav/webdoc"

HTTP Error: Internal Server Error

I have checked everything including the latest manual, but couldn't get it to work.
Reply With Quote
Sponsored Links
  #2  
Old 15th July 2011, 11:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Are there any errors in Apache's error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th July 2011, 23:01
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default apache logs

Sorry for the delay.

apache logs look like this,

domain.tld::80 192.168.0.1 - - [21/Jul/2011:01:23:24 +0530] "OPTIONS /webdav/doc HTTP/1.1" 500 2149 "-" "gvfs/1.6.1"

I couldn't make out anything out of it.
Reply With Quote
  #4  
Old 21st July 2011, 16:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Is that in the access log or the error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 21st July 2011, 17:33
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default Webdav doesn't work

it is in the access log.
There is nothing generated in the error-log relating to webdav
Reply With Quote
  #6  
Old 22nd July 2011, 15:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Are you sure? An internal server error should be logged...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd July 2011, 22:52
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default

Yes, I have checked the file var/log/apache2/error.log but nothing is being logged in respect to webdav.

Here is an extract of the error log file after I tried to access the webdav.

[Fri Jul 22 23:12:58 2011] [notice] mod_fcgid: process /var/www/example.com/web/index.php(11976) exit(lifetime expired), terminated by calling exit(), return code: 0
[Fri Jul 22 23:29:17 2011] [notice] mod_fcgid: process /var/www/example1.com/web/index.php(14071) exit(idle timeout), terminated by calling exit(), return code: 0
[Fri Jul 22 23:33:01 2011] [notice] mod_fcgid: call /var/www/example2.co.in/web/index.php with wrapper /var/www/php-fcgi-scripts/web13/.php-fcgi-starter
[Fri Jul 22 23:33:22 2011] [notice] mod_fcgid: process /var/www/example3.com/web/index.php(14176) exit(idle timeout), terminated by calling exit(), return code: 0
[Fri Jul 22 23:35:26 2011] [notice] mod_fcgid: process /var/www/example4.in/web/index.php(14171) exit(idle timeout), terminated by calling exit(), return code: 0
[Fri Jul 22 23:41:57 2011] [notice] mod_fcgid: call /var/www/example5.com/web/index.php with wrapper /var/www/php-fcgi-scripts/web22/.php-fcgi-starter

what should I do next? I would like to sort it out.
Reply With Quote
  #8  
Old 23rd July 2011, 14:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Hm... Maybe you can stop these errors with the help of this article: http://wherethebitsroam.com/blogs/je...d-and-timeouts

Not sure if that has anything to do with WebDAV though.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
pawan (26th July 2011)
  #9  
Old 26th July 2011, 01:04
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default

Thank you for your suggestion.

can you suggest anything else, I can look for for webdav to work.

I am also getting this error,(instead of internal error) if I try to connect little differently that is if i try only /webdav instead of /webdav/doc

Cannot display location "dav://example.tld/webdav"
HTTP Error: Component not found
Reply With Quote
  #10  
Old 26th July 2011, 18:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Did you enable the DAV modules in Apache?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.2 & Webdav & 403 Forbidden Rescue9 Installation/Configuration 6 4th December 2011 17:05
Cron issue in Debian 6 Nolan Installation/Configuration 6 18th April 2011 17:36
How does ISPConfig 3.0.3 enable WebDav? ferrao Installation/Configuration 13 26th October 2010 16:13
Fedora 13 Webdav Nymus Server Operation 1 23rd July 2010 18:16
Newb: Is this WebDav setup going to work? smartin Installation/Configuration 34 4th March 2010 19:15


All times are GMT +2. The time now is 04:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.