Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th July 2011, 08:10
rex_ray rex_ray is offline
Junior Member
 
Join Date: Apr 2008
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Default Installing Maia Mailguard On Debian Lenny (configtest.pl dependency)

Hi,
Am following this howto "Installing Maia Mailguard On Debian Lenny" on a Ubuntu Server 10.04.3. While running the "perl configtest.pl" I encounter the following dependency requirement. Can anyone please tell me what perl module should I install to satisfy this requirement. Thanks in advance for the help.


root@smtp:/opt/mail/maia-1.0.2c/scripts# perl configtest.pl

MAIA MAILGUARD CONFIGURATION TEST

This script checks for the presence of applications and Perl modules
required by amavisd-maia, SpamAssassin, and Maia Mailguard's maintenance
scripts. Version numbers are also checked, and if a newer version of
a component is recommended, you should consider upgrading to at least
the minimum recommended version.

If you have already configured your Maia Mailguard database, the script
will also test the connection to that database.

Remember also to run the configtest.php script on your web server to
perform similar tests of your web, PHP, and PEAR environment.

Application/Module Version Status
================================================== ======================
Perl : 5.10.1 : OK
file(1) : N/A : NOT INSTALLED (required by Maia Mailguard)
Archive::Tar : 1.76 : OK
Archive::Zip : 1.30 : OK
BerkeleyDB : 0.39 : OK
Reply With Quote
Sponsored Links
  #2  
Old 29th July 2011, 08:54
rex_ray rex_ray is offline
Junior Member
 
Join Date: Apr 2008
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by rex_ray View Post
Hi,
Am following this howto "Installing Maia Mailguard On Debian Lenny" on a Ubuntu Server 10.04.3. While running the "perl configtest.pl" I encounter the following dependency requirement. Can anyone please tell me what perl module should I install to satisfy this requirement. Thanks in advance for the help.


root@smtp:/opt/mail/maia-1.0.2c/scripts# perl configtest.pl

MAIA MAILGUARD CONFIGURATION TEST

This script checks for the presence of applications and Perl modules
required by amavisd-maia, SpamAssassin, and Maia Mailguard's maintenance
scripts. Version numbers are also checked, and if a newer version of
a component is recommended, you should consider upgrading to at least
the minimum recommended version.

If you have already configured your Maia Mailguard database, the script
will also test the connection to that database.

Remember also to run the configtest.php script on your web server to
perform similar tests of your web, PHP, and PEAR environment.

Application/Module Version Status
================================================== ======================
Perl : 5.10.1 : OK
file(1) : N/A : NOT INSTALLED (required by Maia Mailguard)
Archive::Tar : 1.76 : OK
Archive::Zip : 1.30 : OK
BerkeleyDB : 0.39 : OK
Solved it, actually file(1) is not a perl module requirement but the command file in your nix machine(my bad I understood it wrongly).

# file -v
file-5.03
magic file from /etc/magic:/usr/share/misc/magic

Edit the 'configtest.pl' file and comment the text in line number 99

# {component => "file(1)", type => "file -v 2>/dev/null", regexp => "\-([0-9\.]+)", minver => "4.12",
#Replace it with the following line.
{component => "file(1)", type => "file -v 2>&1", regexp => "\-([0-9\.]+)", minver => "4.12",

Now run the script and it will run fine.
Reply With Quote
The Following User Says Thank You to rex_ray For This Useful Post:
falko (30th July 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
yum issues el-sid Installation/Configuration 4 10th August 2011 11:01
Installation just stops, and dies. cosmicsafari Installation/Configuration 3 19th July 2011 10:24
setting up a media server centos 5.2 asphix20 HOWTO-Related Questions 2 9th December 2009 16:37
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
Help....package missing sbovisjb1 Installation/Configuration 3 31st March 2006 11:14


All times are GMT +2. The time now is 15:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.