Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th July 2011, 11:32
helly88 helly88 is offline
Member
 
Join Date: May 2011
Posts: 35
Thanks: 1
Thanked 0 Times in 0 Posts
Default Squirrelmail after upgrade to PHP53

Ok, So I upgraded to PHP53 (because I need that version) and I saw that squirrelmail got removed.

So I downloaded the newest version of Squirrelmail using wget. Then i extracted it and placed it at /usr/share/squirrelmail. I ran the config and told it that I use dovecot.

I created an alias that poits mydomain.com/webmail/ to that dir and I get the login screen when I acces the site.
However, I can't login, I get this error:

ERROR
Error opening ../data/default_pref
Could not create initial preference file!
/var/local/squirrelmail/data/ should be writable by user httpd
Please contact your system administrator and report this error.

So I guess it wasn't as simple as downloading and unpacking it...
Can anybody tell me what I need to do? There is not a folder called /var/local/squirrelmail

Should I just chown the /usr/share/squirrelmail folder to client1:web1?
Reply With Quote
Sponsored Links
  #2  
Old 27th July 2011, 13:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You could try this:
Code:
mkdir -p /var/local/squirrelmail/data/
chown -R httpd /var/local/squirrelmail/
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th July 2011, 13:47
helly88 helly88 is offline
Member
 
Join Date: May 2011
Posts: 35
Thanks: 1
Thanked 0 Times in 0 Posts
Default

chown: 'httpd': invalid user.

I've followed your guide (Perfect server centos 5.6 and ISPconfig 3).
Reply With Quote
  #4  
Old 27th July 2011, 14:44
helly88 helly88 is offline
Member
 
Join Date: May 2011
Posts: 35
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ofc, this is Centos.. I changed the owner of the folder to apache and it worked.

One other thing though, When I send a mail from my webmail, It dosen't use the correct format.. (Norwegian letters) don't work. I'll guess I'll just google that problem.

Thanks
Reply With Quote
  #5  
Old 18th September 2011, 02:08
hueseo hueseo is offline
Junior Member
 
Join Date: Jun 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by helly88 View Post
ofc, this is Centos.. I changed the owner of the folder to apache and it worked.

One other thing though, When I send a mail from my webmail, It dosen't use the correct format.. (Norwegian letters) don't work. I'll guess I'll just google that problem.

Thanks
he he confrguaration
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Using Squirrelmail with ISPConfig 3 dpicella Installation/Configuration 15 7th January 2011 04:30
Why did Squirrelmail, Dovecot/IMAP & Outbound mail break? websissy Technical 4 29th October 2009 22:39
squirrelmail cannot access after 3.0.1.6 upgrade. acumen Installation/Configuration 2 18th October 2009 01:20
How to upgrade SquirrelMail satimis Server Operation 5 13th April 2008 20:00


All times are GMT +2. The time now is 16:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.