Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th July 2011, 00:00
james@thereidsonline.com james@thereidsonline.com is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default How to turn on SMTP Auth?

Hi,

Could someone please provide some info on how to turn on SMTP Auth for ISPConfig?

I have:
- Built Debian Lenny server in accordance with http://howtoforge.com/perfect-server...nny-ispconfig3
- Searched the forum
- Read the manual (where I would have thought something might be mentioned - there is discussion about monitoring SASL with fail2ban, but nothing on how to enable it!)

I note that there is perhaps a hint when installing ISPConfig:
To enable saslauthd, edit /etc/default/saslauthd and set START=yes (warning).

I've done the above... is there anything else?

If I do a telnet:
myserver:~# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 myserver.net ESMTP Postfix (Debian/GNU)
ehlo localhost
250-hosting01.reidware.net
250-PIPELINING
250-SIZE
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

Maybe it is a simple case of I'm not connecting using the right config - I'm using Thunderbird to test.

Thanks!
James.
Reply With Quote
Sponsored Links
  #2  
Old 26th July 2011, 08:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

SMTP-Auth is always on, when you followed the guide and installed ispconfig 3. This shows also your telnet output "250-AUTH PLAIN LOGIN".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th July 2011, 10:22
james@thereidsonline.com james@thereidsonline.com is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks Till... so does the comment in the ISPConfig 3 installation "To enable saslauthd, edit /etc/default/saslauthd and set START=yes (warning)." have any significance?
Reply With Quote
  #4  
Old 26th July 2011, 10:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

No. Thats not relevant.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th July 2011, 12:07
james@thereidsonline.com james@thereidsonline.com is offline
Junior Member
 
Join Date: Nov 2006
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ok... having had a look at main.cf again I think I'm understanding what is going on... am I correct in thinking that smtp auth uses dovecot auth for authentication?

I have noticed that it does not seem to matter whether I configure Thunderbird to use any form of encryption for logging in - is there a way to force smtp auth only accept encrypted sessions?

I've tried doing a few searches - found a couple of things like smtpd_tls_auth_only but this does not seem to make any difference.

Thanks!
James.
Reply With Quote
  #6  
Old 26th July 2011, 12:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Quote:
Ok... having had a look at main.cf again I think I'm understanding what is going on... am I correct in thinking that smtp auth uses dovecot auth for authentication?
That depends on your setup. If you use dovecot for imap and pop3, then dovecot is used. If you hace courier installed, then salauthd is used.


SMTP-auth and smtp encryption are two different things, so dont mix that up! If you want to have encrypted smtp sessions, then enable smtp encryption in your email client. The email client will then use ssl encrypted session to communicate with postfix on port 25 automatically. SMTP-auth works with encrypted sessions as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd August 2011, 21:32
gawry gawry is offline
Junior Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 3
Thanked 1 Time in 1 Post
Default

How do I disable email sending for unauthenticated users?

I'm running a mail server with postfix / courier.
Reply With Quote
  #8  
Old 22nd August 2011, 22:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
Default

Quote:
How do I disable email sending for unauthenticated users?
Thats already the case if you have ispconfig installed as its the default.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 23rd August 2011, 18:47
gawry gawry is offline
Junior Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 3
Thanked 1 Time in 1 Post
Default

but i cant use to send email to external addresses but i can send to the internal ones.
Reply With Quote
  #10  
Old 23rd August 2011, 19:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,501 Times in 4,330 Posts
 
Default

Please post the exact error messages that you get in the mail.log file when you try to authenticate and check your mail client settings again that the correct username is used for smtp, the username is the full email address. E.g. Thunderbird has a bug so that not the full email address is used until you correct the username in the smtp settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
postfix smtp sasl auth problem hammer Installation/Configuration 1 13th July 2006 18:19


All times are GMT +2. The time now is 00:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.