#1  
Old 19th July 2011, 18:26
qb7 qb7 is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 12
Thanked 4 Times in 4 Posts
Smile SSL in domain

I made one ssl certificate in a domain, and not run. When point https://www.mydomain.com in broser, the result is apache http server test Page powered. After this i did erase the certificate and don't run when point http://www.mydomain.com. The result is other domain park in the server. Why? Please hep my to this big problem for my.

ispconfig 3.0.3.2 CentOS. 5.5

Thank
Reply With Quote
Sponsored Links
  #2  
Old 19th July 2011, 20:13
qb7 qb7 is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 12
Thanked 4 Times in 4 Posts
Default SSL problem wich domain

Is posible wich cron job solution for this issue
Reply With Quote
  #3  
Old 20th July 2011, 13:33
qb7 qb7 is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 12
Thanked 4 Times in 4 Posts
Default No isn't cron job solution.

Quote:
Originally Posted by qb7 View Post
Is posible wich cron job solution for this issue
How I most go back the process to ssl domain in ispconfig, for normal fuction: http://www.mydomain.com?
Please help me the domain is in production.
Reply With Quote
  #4  
Old 20th July 2011, 17:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you download the ISPConfig 3 Manual? If so, please check out chapter 5.4.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th July 2011, 20:26
qb7 qb7 is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 12
Thanked 4 Times in 4 Posts
Default I read 5.4 capitulo

Hi Falko I don't have the solution. This domain now when I going point the broser http://www.mydomain.com, the broser show me other web, the next alphabetical order. When I pointing the broser https://www.mydomain.com, the broser show me the page Apache 2 Test Page powered by CentOS.

The sistem is IspConfig 3.0.2 and run in Centos 5.5

Only change the mode SSL in domain and not work.

I see this post http://www.howtoforge.com/forums/showthread.php?t=41597 how to made this for one posible solution? post of Till.
Reply With Quote
  #6  
Old 21st July 2011, 12:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Can you post the vhost configurations for the mydomain.com http and https vhosts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 25th July 2011, 12:13
qb7 qb7 is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 12
Thanked 4 Times in 4 Posts
Default I find the error and possible issue

I have to put in the web site of domain the wildcard (*) in ip field and them run ok: www.mydomain.com
If I put the ip 111.111.111.111 them not run. This ip is the same wich the server IP (the internet static IP wich i have of my internet provider).

If the SSL is active them https:// show me the page of server other time.

How I can put SSL in only one domain?


The issue wich I find is:

When I disable one web site in the server and after I point the broser in the domain disable, the broser show me the page of the next alphabetical order domain active.

This is from my point of view one issue (hole).

Sistem: Centos 5.5 IspConfig 3.0.3.2
Can I report this issue?

Last edited by qb7; 25th July 2011 at 12:15.
Reply With Quote
  #8  
Old 25th July 2011, 14:49
qb7 qb7 is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 12
Thanked 4 Times in 4 Posts
Default When point https://www.mydomain.com

this is the cert to show in the broser:

Name:  pantalla1.jpg
Views: 83
Size:  35.3 KB
Reply With Quote
  #9  
Old 26th July 2011, 16:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

What about my question in post #6?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
qb7 (28th July 2011)
  #10  
Old 28th July 2011, 13:05
qb7 qb7 is offline
Member
 
Join Date: Jul 2010
Posts: 50
Thanks: 12
Thanked 4 Times in 4 Posts
 
Wink I have solved this problem

Hello to all, I have solved this problem in my system:

Centos 5.5

IspConfig 3.0.3.3 (I upgrade it)

In the ssl.conf (etc/httpd/conf.d/ssl.conf) I have applied this policy

<IfDefine 0>
##
## SSL Virtual Host Context
##

<VirtualHost _default_:443>
...
</VirtualHost>
</IfDefine>

This fixed the default vhost and run OK the cert of mydomain.

Thank Falko
Reply With Quote
The Following User Says Thank You to qb7 For This Useful Post:
falko (29th July 2011)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not forwarding for some domains flappy Installation/Configuration 3 21st November 2010 17:57
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
Should I go for dedicated SSL or free shared SSL? What's the deal? calvinrobinson Smalltalk 3 3rd November 2010 17:57
SSL for virtual hosts on one certificate rbartz Tips/Tricks/Mods 8 20th November 2007 17:59
rebuild ssl certificates for domain change whitty Installation/Configuration 1 6th June 2006 12:12


All times are GMT +2. The time now is 02:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.