Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #41  
Old 24th November 2011, 13:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

I will check that and will include it in the bugfix release which is sent to all customers today.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #42  
Old 24th November 2011, 13:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

@pitits: I've just checked the database dumps and "company_name_short" is in the database dump for the 1.0 final that we released, so it is not a bug that it was not added in the 1.1 update. Maybe you installed a prerelease version of the billing module where the field did not exist.

You can add the column manually with this sql command:

Code:
ALTER TABLE  `invoice_company` ADD  `company_name_short` varchar(255) DEFAULT NULL;
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
pititis (24th November 2011)
  #43  
Old 28th December 2011, 22:02
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 78
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default Some bugs maibe ?

REV-1

I testing my billing module installation and have some bugs to consult.

1. Recurring invoice item form,
date format at "Next payment","start date", "end date" need to be validated so i put firstime 1.1.2012 and no error and no save was made other textbox saved. Date mask or something simmiliar is needed cos date at right side as example wont be saved correct date format as i tested was 2012-01-01. Maibe is my settings i have chrome in english currently.

2. When selecting PDF invoice template "no VAT", table with items at generated pdf is broken in result. Maibe mistake in template.
Reply With Quote
  #44  
Old 28th December 2011, 22:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please contact us by email to get support for the billing module. Your problem is related to the date format settings in your installation that happen when the billing module date fomat do not match eith the date format of the language you had selected.

The rev 1 version has no no vat template, it has been introduced in rev2. So most likely your system datsbase is not correctly updated.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 28th December 2011 at 22:50.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
madmucho (29th December 2011)
  #45  
Old 7th January 2012, 14:52
edwintenhaaf edwintenhaaf is offline
Junior Member
 
Join Date: Jul 2007
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default dutch translation off billing module

Hello,

I have one short question:

Is the billing module allready translated in dutch?

thanks,

Edwin
Reply With Quote
  #46  
Old 8th January 2012, 20:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The billing module has language files for english and german at the moment. But it can be translated with the language editor that is built into ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #47  
Old 9th January 2012, 14:55
xxs xxs is offline
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Bug or Feature?

If you log in as reseller, you are only able to see the invoices you build, but if you bulid new invoices you can chose all companies, wouldn't it be a better solution, only to use own companies? Especially, as you can only see the invoices, you build, and not the whole of a company?
Reply With Quote
  #48  
Old 9th January 2012, 15:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The Billing module is for the administrator only so that the administrator can invoice clients and resellers. The invoice module is not made to be activated for a reseller or client user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #49  
Old 9th January 2012, 15:15
xxs xxs is offline
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, that was not clear because of seeing only your own invoices as logged in as reseller.
Any plans for a reseller able solution?
Reply With Quote
  #50  
Old 9th January 2012, 15:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
 
Default

We might integrate that in future, but its not that easy to handle as just separating the companies is only a very small part of it. E.g. every reseller needs its own payment gateways then and the same item might have to double invoiced at different prices at different times automatically for some resellers while others do it manually and each resller might have its different payment schemes e.g. flatrates vs. dedicated invoicing of each item.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
ISPconfig 3: can't send or receive messages zogthegreat Installation/Configuration 6 22nd May 2010 14:45
Amavisd not identfying spam properly Cracklefish Installation/Configuration 11 22nd December 2009 11:05
ISPConfig 3: Monitor Module & Logfiles - All setup correctly? Master One Installation/Configuration 2 10th July 2009 18:51
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12


All times are GMT +2. The time now is 23:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.