#1  
Old 14th March 2014, 09:33
icemaker icemaker is offline
Junior Member
 
Join Date: Oct 2009
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation Joomla 403 Error

Hello,

i have download and extracted joomla files in :

/var/www/clients/client1/web2/web

i have fixed the permissions as follow:

chown -hR -v -f we21:client1 web/*
cd web
find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;

and when i try to access the website i get the following error:

Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.16 (Debian) Server at assafina.net Port 80
Reply With Quote
Sponsored Links
  #2  
Old 14th March 2014, 09:39
neutrino neutrino is offline
Member
 
Join Date: Oct 2008
Posts: 56
Thanks: 10
Thanked 5 Times in 5 Posts
Default

Well if you really did :

chown -hR -v -f we21:client1 web/*

Then you have a problem for sure... with an extra b it may be better
Reply With Quote
  #3  
Old 14th March 2014, 09:47
icemaker icemaker is offline
Junior Member
 
Join Date: Oct 2009
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by neutrino View Post
Well if you really did :

chown -hR -v -f we21:client1 web/*

Then you have a problem for sure... with an extra b it may be better
Sorry for that! was a typing error while typing on the forums!


here is the actual permissions:

chown -hR -v -f web2:client1 web/*
cd web
find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
Reply With Quote
  #4  
Old 14th March 2014, 09:53
neutrino neutrino is offline
Member
 
Join Date: Oct 2008
Posts: 56
Thanks: 10
Thanked 5 Times in 5 Posts
Default

Did you already checked if everything looks good with an ls -l in the web folder ?
Reply With Quote
  #5  
Old 14th March 2014, 09:56
icemaker icemaker is offline
Junior Member
 
Join Date: Oct 2009
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by neutrino View Post
Did you already checked if everything looks good with an ls -l in the web folder ?
here is the ls -l output:

drwxr-xr-x 10 web2 client1 4096 Mar 3 17:06 administrator
drwxr-xr-x 2 web2 client1 4096 Mar 3 17:06 bin
drwxr-xr-x 5 web2 client1 4096 Mar 10 18:57 cache
-rw-r--r-- 1 web2 client1 51984370 Mar 10 14:07 charity-website.rar
drwxr-xr-x 2 web2 client1 4096 Mar 3 17:06 cli
drwxr-xr-x 20 web2 client1 4096 Mar 10 10:05 components
-rw-r--r-- 1 web2 client1 1805 Mar 3 17:10 configuration.php
drwxr-xr-x 2 web2 client1 4096 Mar 13 21:25 error
-rw-r--r-- 1 web2 client1 3123 Mar 5 21:06 htaccess.txt
drwxr-xr-x 9 web2 client1 4096 Mar 9 10:03 images
drwxr-xr-x 2 web2 client1 4096 Mar 6 21:27 includes
-rw-r--r-- 1 web2 client1 45 Mar 14 08:20 index.html
-rw-r--r-- 1 web2 client1 1011 Mar 5 21:06 index.php
-rw-r--r-- 1 web2 client1 616 Sep 16 10:54 install.script.php
drwxr-xr-x 4 web2 client1 4096 Mar 3 17:06 language
drwxr-xr-x 4 web2 client1 4096 Mar 3 17:06 layouts
drwxr-xr-x 15 web2 client1 4096 Mar 10 10:05 libraries
-rw-r--r-- 1 web2 client1 17816 Mar 5 21:06 LICENSE.txt
drwxr-xr-x 2 web2 client1 4096 Mar 6 21:27 logs
drwxr-xr-x 20 web2 client1 4096 Mar 10 17:39 media
drwxr-xr-x 39 web2 client1 4096 Mar 10 10:50 modules
drwxr-xr-x 16 web2 client1 4096 Mar 9 09:55 plugins
-rw-r--r-- 1 web2 client1 4300 Mar 5 21:06 README.txt
-rw-r--r-- 1 web2 client1 865 Sep 16 10:54 robots.txt
-rw-r--r-- 1 web2 client1 901 Mar 5 21:06 robots.txt.dist
drwxr-xr-x 2 web2 client1 4096 Mar 14 00:30 stats
drwxr-xr-x 7 web2 client1 4096 Mar 8 14:05 templates
drwxr-xr-x 2 web2 client1 4096 Mar 10 17:39 tmp
-rw-r--r-- 1 web2 client1 1715 Mar 5 21:06 web.config.txt
Reply With Quote
  #6  
Old 14th March 2014, 10:11
neutrino neutrino is offline
Member
 
Join Date: Oct 2008
Posts: 56
Thanks: 10
Thanked 5 Times in 5 Posts
Default

Looks good, do you have a .htaccess in the web folder who may screw up things ?
Reply With Quote
The Following User Says Thank You to neutrino For This Useful Post:
icemaker (14th March 2014)
  #7  
Old 14th March 2014, 11:12
florian030 florian030 is offline
Senior Member
 
Join Date: Oct 2012
Posts: 187
Thanks: 7
Thanked 47 Times in 41 Posts
Default

And web is owned by web2.client1?
Did you use fastcgi with suexec for this website?
__________________
regards
Florian

blog.schaal-24.de
Reply With Quote
  #8  
Old 14th March 2014, 11:20
icemaker icemaker is offline
Junior Member
 
Join Date: Oct 2009
Posts: 8
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by neutrino View Post
Looks good, do you have a .htaccess in the web folder who may screw up things ?
Seems .htaccess was the problem it was set to deny all
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed during pvmove, howto: set up software raid 1 on running LVM system sbh77 HOWTO-Related Questions 2 8th October 2010 00:11
mod_layout and php gd branov Installation/Configuration 8 2nd September 2009 15:51
LB1 Not Taking Over Shared IP Using Heartbeat 2.1.3 On FC10 64Bit asyadiqin Installation/Configuration 5 11th February 2009 20:11
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14


All times are GMT +2. The time now is 23:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.