#1  
Old 18th September 2005, 01:18
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default ssl.conf error

I installed apache2 per the instructions in the perfect setup for debian sarge...when I attempt to restart the apache server, I get an error message of:
Forcing reload of web server: Apache2grep: /etc/apache2/mods=enabled/ssl.conf: No such file or directory.....
apache2: could not open document config file /etc/apache2/mods-enabled/ssl.con
There are processes named 'apache2' which do not match your pid file.

Should I just remove apache2 and reinstall?
Reply With Quote
Sponsored Links
  #2  
Old 18th September 2005, 02:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Can you post the output of
Code:
ls -l /etc/apache2/mods-enabled
and
Code:
ls -l /etc/apache2/mods-available
here?

Quote:
There are processes named 'apache2' which do not match your pid file.
Restart Apache, and if that doesn't help, reboot your system.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th September 2005, 02:56
dianer dianer is offline
Member
 
Join Date: Sep 2005
Location: Dover, PA, USA
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache

Quote:
Originally Posted by falko
Can you post the output of
Code:
ls -l /etc/apache2/mods-enabled
and
Code:
ls -l /etc/apache2/mods-available
here?

Restart Apache, and if that doesn't help, reboot your system.

I did that. I believe I figured out where the problem lies...when I added this line:
ln -s /etc/apache2/mods-available/ssl.conf ssl.conf
I typed mods-abailable instead....can I rename the file? If so, how do I do that?

Thanks so much for your help.
Reply With Quote
  #4  
Old 18th September 2005, 11:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Do this:
Code:
cd /etc/apache2/mods-enabled
rm -f ssl.conf
ln -s /etc/apache2/mods-available/ssl.conf ssl.conf
Then restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not make OpenSSL yontengyatso Installation/Configuration 3 3rd November 2005 10:50
ISPConfig on Centos Error so_ Installation/Configuration 2 31st August 2005 22:55
ERROR While upgrading to 2.0.8 adamluz Installation/Configuration 2 29th August 2005 21:30
Installation error - Makefile is older than makefile.org sybella1 Installation/Configuration 0 25th August 2005 20:49
Error in Instalation (mysql header) juampi Installation/Configuration 2 5th August 2005 22:37


All times are GMT +2. The time now is 22:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.