Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th June 2006, 02:03
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default Paypal Bonus...Mail not reaching my local Server! Queued in system....

Setup:
Ubuntu 6.06 (using perfect installation guide)
Network: Single server single IP single site for the moment (IP Dedicated)
ISPConfig 2.23
-------------------------------
Ok I can:

> Send mail through both webmail (Roundcube/UM) and client (Mozilla Thunderbird using TLS).

I CANT:

> Retrieve mail using client (Thunderbird)
> Recieve mail to my inbox (but it goes into the queue...see below)

When I run the "postqueue -p" command I get the following printout...
Code:
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
BFF2D1AD87BD     2957 Fri Jun 16 17:33:19  MAILER-DAEMON
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

593B81AD87C0     1593 Fri Jun 16 17:57:39  qualitysiding@gmail.com
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

040511AD87C9     2351 Mon Jun 19 15:11:34  dimitriy.iyerusalimets@gmail.com
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

-- 7 Kbytes in 3 Requests.
My local server is called "antec.qualitysiding.net" and my public domain is qualitysiding.net. My DNS is managed through www.poweryourname.com (A service similar to Godaddy) and it looks picture attached.

So what am I doing wrong here? I can send mail through Thunderbird and webmail using my public name (itsupport@qualitysiding.net) and it works completely fine.

ALSO, I use Gmail to test and whenever I respond to a message it doesnt give me an error. I assume this is because the mail is recieved at my end (qualitysiding.net -->> antec.qualitysiding.net) and stores it in a temporary location since it cant resolve the name?

Anybody got a hint on how to make say people who got mail.qualitysiding.net will take them to my webmail form (mail.qualitysiding.net -->> https://qualitysiding.net:81/roundcube)?

Thanks,
Dimitriy

DNS config if you cant get it:

Last edited by Dimitriy; 22nd June 2006 at 01:27.
Reply With Quote
Sponsored Links
  #2  
Old 20th June 2006, 02:14
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Also results of hostname and "hostname -f" gives me the following:

antec -- just simple hostname

localhost.localdomain -- thats for "hostname -f"
Reply With Quote
  #3  
Old 21st June 2006, 00:49
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Should be simple enough.... No takers?
Reply With Quote
  #4  
Old 21st June 2006, 01:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Code:
dig antec.qualitysiding.net

; <<>> DiG 9.2.1 <<>> antec.qualitysiding.net
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63817
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;antec.qualitysiding.net.       IN      A

;; AUTHORITY SECTION:
qualitysiding.net.      3600    IN      SOA     dns01.gpn.register.com. partnersupport.register.com. 2002050701 10001 1801 604801 181

;; Query time: 138 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Wed Jun 21 00:48:14 2006
;; MSG SIZE  rcvd: 114
antec.qualitysiding.net doesn't exist. Please create an A record for it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 21st June 2006, 02:11
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I created an A record for "antec.qualitysiding.net" to my IP: 71.231.xxx.xxx. But I have only one computer on this end. Do I have to set something in ISP config??

PS: I want email to come xuser@qualitysiding.net not xuser@antec.qualitysiding.net
Reply With Quote
  #6  
Old 21st June 2006, 02:34
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok got something here I think. The only place that postfix references the host name is in /etc/postfix/main.cf.

/etc/postfix/main.cf
Code:
...
myhostname = antec.qualitysiding.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = antec.qualitysiding.net, localhost.qualitysiding.net, , localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
So what should change?

Last edited by Dimitriy; 21st June 2006 at 02:58.
Reply With Quote
  #7  
Old 21st June 2006, 18:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Just create an A record for antec.qualitysiding.net, that should work. I didn't see it in the dig output yet, but it might take some time until it appears.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 22nd June 2006, 00:57
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This was done 24 hours ago. Should be working....
Attached Images
 
Reply With Quote
  #9  
Old 22nd June 2006, 01:00
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Results of "postqueue -p"

Does this make this a internal error then??


Code:
root@antec:~# postqueue -p                                                     -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
BFF2D1AD87BD     2957 Fri Jun 16 17:33:19  MAILER-DAEMON
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

593B81AD87C0     1593 Fri Jun 16 17:57:39  qualitysiding@gmail.com
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

040511AD87C9     2351 Mon Jun 19 15:11:34  dimitriy.iyerusalimets@gmail.com
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

3B00B1AD87CD     1634 Tue Jun 20 16:24:34  dimitriy.iyerusalimets@gmail.com
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

8F0181AD87CE     2204 Tue Jun 20 16:39:46  dimitriy.iyerusalimets@gmail.com
(Host or domain name not found. Name service error for name=antec.qualitysiding.net type=MX: Host not found, try again)
                                         itsupport@antec.qualitysiding.net

-- 12 Kbytes in 5 Requests.
Reply With Quote
  #10  
Old 22nd June 2006, 01:25
Dimitriy Dimitriy is offline
Junior Member
 
Join Date: Jun 2006
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Get me a right answer and it works and you get 15 bucks in your paypal.

The ?/Problem: Make mail system work normally (eg. recieve and send mail.). Must be able to login as through POP and use a simple client aka Mozilla Thunderbird.

Its pretty simple but I am not a networking pro or even a novice.....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47
Mail server jas_esp Server Operation 1 7th December 2005 19:17
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 13:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.