#1  
Old 29th June 2011, 10:49
shekiman shekiman is offline
Junior Member
 
Join Date: Jan 2011
Location: Murska Sobota
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to shekiman Send a message via Skype™ to shekiman
Cool Want to run perl inside php

For testing Perl in php I run this script:
PHP Code:
<?php

print "Hello from PHP! ";
$perl = new Perl();
$perl->eval('print "Hello from perl! "');
print 
"Bye! ";

?>
For this site I enabled everything:
SSI,Ruby,SuEXEC and PHP=CGI

And than I get
mod_fcgid: stderr: PHP Fatal error: Class 'Perl' not found in /var/www/clients/client0/web9/web/index.php on line 4

Could me someone give me a hint how to handle Perl with ispc3?

Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 29th June 2011, 11:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,475
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
 
Default

That issue is not ISPConfig specific as you use a PHP class that is not defined or installed on your server. As far as I know, there is no class "Perl" in any sztandard PHP, so what you try to use there must be eiter a PHP addon module or any other custom class which needs to be installed on your server and included in your php script before you can use it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3, perl, php

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error when install ISPConfig 2 with components built from source X-admin Installation/Configuration 5 30th April 2010 13:22
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
How to add a subdomain? malinens Installation/Configuration 2 10th March 2008 23:16
Sites are up, but none show in ispconfig Check Installation/Configuration 10 5th February 2008 11:33
VirtualHosts marra87 General 9 12th September 2006 04:09


All times are GMT +2. The time now is 18:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.