Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th May 2006, 14:25
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default Postfix - Debian Sarge

Introduction:

I had installed ISPConfig more than 5 times on FedoraCore3. There were problems, but finally I (with great help of falco and till) managed it to work seamlessly. I had installed ISPConfig more than 5 times on FedoraCore4 box. There were problems, but finally I managed it to work perfectly. I even re-installed few times, just to meke it routine. And every time it worked perfectly. Really. Then I decided to move on Debian Sarge 3.1

And now there are BIG problems with postfix. And UebiMiau.
----------------------------------------------------------
1. There were NO typo's errors.
2. HOW-TO was followed to the letter.
3. No, I didn't forgot to change "server1.example.com"
4. I know how to set it up becuse I set it up on FedoraCore so many times.
---------------------------------------------------------
1. UebiMiau DO NOT accept logins. Period.
Not with web1_nenad@web-hosting-solutions.biz, not with web1_nenad, not with anything.
2. POP3 (when accesed with e-mail client such as OutlookExpress or thinderbird) do not accept connection.
3. SMTP works fine.
--------------------------------------------------------------
Any difference compared to "HOW-TO" is that I am using mysql4.1 set up with default UTF8.
-------------------------------------------------------------
This is error displayed by OE when accesing POP3:
Quote:
There was a problem logging onto your mail server. Your User Name was rejected. Account: 'Nenad Bulatovic (WebHosting)', Server: 'mail.web-hosting-solutions.biz', Protocol: POP3, Server Response: '-ERR Unknown AUTHORIZATION state command', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC91
Here is /etc/postifx/main.cf
Quote:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = server201.web-hosting-solutions.biz
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = server201.web-hosting-solutions.biz, localhost.web-hosting-solutions.biz, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
--------------------------------------------------
/etc/init.d/saslauthd start

returns: failed
------------------------------------------------
server201:/etc/postfix/ssl# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
220 server201.web-hosting-solutions.biz ESMTP Postfix (Debian/GNU)
ehlo localhost
250-server201.web-hosting-solutions.biz
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
----------------------------------------------
I DO NOT use Courier-IMAP/Courier-POP3
----------------------------------------------
It is obvious that this line:
#mydestination = server201.web-hosting-solutions.biz, localhost.web-hosting-solutions.biz, localhost

Is commented. The questions is WHY?

Even if I uncomment that line, nothing happens.
------------------------------------------------
What I do not understand is why in /etc/postifx/main.cf there is no:
mail.web-hosting-solutions.biz ?
----------------------------------------------
maildir is NOT checked in ISPConfig
-----------------------------------------------
This is /etc/postfix/local-host-names

Quote:
###################################
#
# ISPConfig local-host-names Configuration File
# Version 1.0
#
###################################
localhost
server201.web-hosting-solutions.biz
localhost.server201.web-hosting-solutions.biz
localhost.web-hosting-solutions.biz
www.web-hosting-solutions.biz
www.cvecara-neven.com
web-hosting-solutions.biz
cvecara-neven.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
-------------------------------------------------------
This is /etc/postfix/virtusertable
Quote:
###################################
#
# ISPConfig virtusertable Configuration File
# Version 1.0
#
###################################
nenad@www.web-hosting-solutions.biz web1_nenad
web1_nenad@www.web-hosting-solutions.biz web1_nenad
nenad@web-hosting-solutions.biz web1_nenad
web1_nenad@web-hosting-solutions.biz web1_nenad
nevena@www.cvecara-neven.com web2_nevena
web2_nevena@www.cvecara-neven.com web2_nevena
nevena@cvecara-neven.com web2_nevena
web2_nevena@cvecara-neven.com web2_nevena
nenad@www.cvecara-neven.com web2_nenad
web2_nenad@www.cvecara-neven.com web2_nenad
nenad@cvecara-neven.com web2_nenad
web2_nenad@cvecara-neven.com web2_nenad
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
-----------------------------------------------------
Quote:
server201:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 1023/inetd
tcp 0 0 *: pop3s *:* LISTEN 1023/inetd
tcp 0 0 localhost.localdo:mysql *:* LISTEN 1077/mysqld
tcp 0 0 *: pop3 *:* LISTEN 1023/inetd
tcp 0 0 *:imap2 *:* LISTEN 1023/inetd
tcp 0 0 *:www *:* LISTEN 1419/apache2
tcp 0 0 *:81 *:* LISTEN 1270/ispconfig_http
tcp 0 0 server201.web-ho:domain *:* LISTEN 2553/named
tcp 0 0 localhost.locald:domain *:* LISTEN 2553/named
tcp 0 0 *:ftp *:* LISTEN 1565/proftpd: (acce
tcp 0 0 *:ssh *:* LISTEN 1233/sshd
tcp 0 0 localhost.localdoma:953 *:* LISTEN 2553/named
tcp 0 0 *:smtp *:* LISTEN 1523/master
tcp 0 0 *:https *:* LISTEN 1419/apache2
tcp 0 0 server201.web-hosti:ssh 192.168.123.100:2330 ESTABLISHED2639/0
tcp 0 0 server201.web-hos:32769 ftp.uoc.gr:www ESTABLISHED1570/freshclam
---------------------------------------------------------
My ISP is not blocking any port. I have static IP as well. I use my own DNS servers as well as foreign DNS servers.
-------------------------------------------------------
server201:~# tail -f /var/log/mail.info
May 7 15:08:13 server201 ipop3d[2777]: Command stream end of file while reading line user=??? host=web-hosting-solutions.biz [87.116.136.92]
May 7 15:08:13 server201 ipop3d[2778]: Command stream end of file while reading line user=??? host=web-hosting-solutions.biz [87.116.136.92]
--------------------------------------------------------
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3

Last edited by nenad; 7th May 2006 at 15:13.
Reply With Quote
Sponsored Links
  #2  
Old 7th May 2006, 15:13
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

server201:~# iptables -L
Chain INPUT (policy DROP)
target prot opt source destination
DROP tcp -- anywhere 127.0.0.0/8
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT all -- anywhere anywhere
DROP all -- BASE-ADDRESS.MCAST.NET/4 anywhere
PUB_IN all -- anywhere anywhere
PUB_IN all -- anywhere anywhere
PUB_IN all -- anywhere anywhere
PUB_IN all -- anywhere anywhere
DROP all -- anywhere anywhere

Chain FORWARD (policy DROP)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
DROP all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
PUB_OUT all -- anywhere anywhere
PUB_OUT all -- anywhere anywhere
PUB_OUT all -- anywhere anywhere
PUB_OUT all -- anywhere anywhere

Chain INT_IN (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
DROP all -- anywhere anywhere

Chain INT_OUT (0 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere
ACCEPT all -- anywhere anywhere

Chain PAROLE (9 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere

Chain PUB_IN (4 references)
target prot opt source destination
ACCEPT icmp -- anywhere anywhere icmp destination-unreachable
ACCEPT icmp -- anywhere anywhere icmp echo-reply
ACCEPT icmp -- anywhere anywhere icmp time-exceeded
ACCEPT icmp -- anywhere anywhere icmp echo-request
PAROLE tcp -- anywhere anywhere tcp dpt:ftp
PAROLE tcp -- anywhere anywhere tcp dpt:ssh
PAROLE tcp -- anywhere anywhere tcp dpt:smtp
PAROLE tcp -- anywhere anywhere tcp dpt:domain
PAROLE tcp -- anywhere anywhere tcp dpt:www
PAROLE tcp -- anywhere anywhere tcp dpt:81
PAROLE tcp -- anywhere anywhere tcp dpt: pop3
PAROLE tcp -- anywhere anywhere tcp dpt:https
PAROLE tcp -- anywhere anywhere tcp dpt:10000
ACCEPT udp -- anywhere anywhere udp dpt:domain
DROP icmp -- anywhere anywhere
DROP all -- anywhere anywhere

Chain PUB_OUT (4 references)
target prot opt source destination
ACCEPT all -- anywhere anywhere
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3
Reply With Quote
  #3  
Old 7th May 2006, 16:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by nenad
/etc/init.d/saslauthd start

returns: failed
Do you see anything in the logs why it fails?

Quote:
Originally Posted by nenad
It is obvious that this line:
#mydestination = server201.web-hosting-solutions.biz, localhost.web-hosting-solutions.biz, localhost

Is commented. The questions is WHY?
Because you have
Code:
mydestination = /etc/postfix/local-host-names
in /etc/postfix/main.cf instead.


Quote:
Originally Posted by nenad
Even if I uncomment that line, nothing happens.
Do not uncomment it.
Quote:
Originally Posted by nenad
server201:~# tail -f /var/log/mail.info
May 7 15:08:13 server201 ipop3d[2777]: Command stream end of file while reading line user=??? host=web-hosting-solutions.biz [87.116.136.92]
May 7 15:08:13 server201 ipop3d[2778]: Command stream end of file while reading line user=??? host=web-hosting-solutions.biz [87.116.136.92]
--------------------------------------------------------
What's in /etc/c-client.cf? Did you restart inetd?

The Debian tutorial works out of the box, I have followed it so many times now and never had any problems. There must be something you're doing wrong.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 7th May 2006, 17:11
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

#mydestination = server201.web-hosting-solutions.biz, localhost.web-hosting-solutions.biz, localhost

In in /etc/postfix/main.cf is commented again, as you advised.

Why in HOW-TO that line is uncommented
(http://www.howtoforge.com/perfect_setup_debian_sarge_p4)
Quote:
The file /etc/postfix/main.cf should now look like this:
And why there is no:
mydestination = /etc/postfix/local-host-names

In that sample file ?

Quote:
Did you restart inetd?
actually I even restarted server, just to be sure that all services are restarted.

Quote:
What's in /etc/c-client.cf? Did you restart inetd?
Quote:
I accept the risk
set disable-plaintext 0

Quote:
Originally Posted by nenad
/etc/init.d/saslauthd start

returns: failed
Do you see anything in the logs why it fails?
In which log should I look?
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3

Last edited by nenad; 7th May 2006 at 20:22.
Reply With Quote
  #5  
Old 7th May 2006, 17:26
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

P.S. I copy and paste "perfect setup" so there's no typo from my side.

How comes that everything works OK, apache, bind, mysql, ftp except postfix ?
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3

Last edited by nenad; 7th May 2006 at 18:50.
Reply With Quote
  #6  
Old 7th May 2006, 19:00
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

What to do if I do not want to install:
POP3 server that also does POP3s (port 995) and an IMAP server that is also capable of IMAPs (port 993) ?

Any user will always recive warning from OE becuse of self-signed certificate.
Very annoying.
---------------------------
In Debian Perfect Setup, page 3
there is nothing to be answered with Yes after executing
update-inetd --remove discard
----------------------------
This line gives error, even with default mysql 4.xxx
server200:~# mysqladmin -h server200.web-hosting.co.yu -u root password xxxxxxxxxx (removed for security reasons)
mysqladmin: connect to server at 'server200.web-hosting.co.yu' failed
error: 'Lost connection to MySQL server during query'

--------------------------------------------
What does this mean:
server200.web-hosting.co.yu, localhost.web-hosting.co.yu, , localhost

Why there is , , ?
In "graphical screen" during postfix configuration?
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3

Last edited by nenad; 7th May 2006 at 19:59.
Reply With Quote
  #7  
Old 7th May 2006, 20:14
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

I DO REALLY think that it is database issue, actually some of the depencies with it.

I just reinstalled OS (following "perfect debian setup").
This time I didn't installed mysql 4.1 but I installed mysq 4.xx as declared in "perfect setup".

This time there was no problem with starting saslauthd:

/etc/init.d/saslauthd start
--------------------------------

I will finish this install, and right after it, I will re-install everything installing mysql 4.1 and later mysql 5
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3
Reply With Quote
  #8  
Old 7th May 2006, 20:47
nenad nenad is offline
Senior Member
 
Join Date: Nov 2005
Location: Novi Sad, Serbia
Posts: 415
Thanks: 13
Thanked 5 Times in 5 Posts
Default

Is it allowed to use:

install Bundle::CPAN
reload cpan
__________________
Nenad Bulatovic
---------------
Debian Lenny & ISPConfig 3

Last edited by nenad; 8th May 2006 at 03:05.
Reply With Quote
  #9  
Old 7th May 2006, 22:36
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default login in Uebimiau

To login in Uebimiau enable maildir is ISPConfig.

Hans
Reply With Quote
  #10  
Old 8th May 2006, 00:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by nenad
And why there is no:
mydestination = /etc/postfix/local-host-names

In that sample file ?
That line is added by the ISPConfig installer.


Quote:
What to do if I do not want to install:
POP3 server that also does POP3s (port 995) and an IMAP server that is also capable of IMAPs (port 993) ?
Simply do not install the POP3s and IMAPs packages...

Quote:
This line gives error, even with default mysql 4.xxx
server200:~# mysqladmin -h server200.web-hosting.co.yu -u root password xxxxxxxxxx (removed for security reasons)
mysqladmin: connect to server at 'server200.web-hosting.co.yu' failed
error: 'Lost connection to MySQL server during query'
http://www.howtoforge.com/forums/sho...r1.example.com

Quote:
What does this mean:
server200.web-hosting.co.yu, localhost.web-hosting.co.yu, , localhost

Why there is , , ?
In "graphical screen" during postfix configuration?
It's a small bug in the Debian installer, nothing serious...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
After Debian postfix / currior install, can not get external mail skdb Installation/Configuration 7 24th April 2006 10:06
Debian Sarge power down by itself jfer Technical 1 24th March 2006 20:08
Postfix on Debian Sarge Perfect Setup daniel_rodriguez HOWTO-Related Questions 1 12th January 2006 22:07
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42
Debian Sarge RAID5 killfrog Installation/Configuration 2 23rd October 2005 21:43


All times are GMT +2. The time now is 08:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.