Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd July 2006, 12:18
uwfrog uwfrog is offline
Junior Member
 
Join Date: Jun 2006
Location: Annex
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default "Host "xxx.xxx" not allowed to connect to this MySQL server"

I am trying to set up a MySQL server on ubuntu behind a router, following this great setup tutorial. The server has been set up running on my machine on port 3306. I also let the router forward (TCP and UDP requests) from port 3306 to my machine.

But when I tried to connect MySQL server, by

mysqladmin -h 70.24.xx.xx -u root passowrd myrootsqlpassword

it returns "mysqladmin: connect to server at '70.24.xx.xx' failed
error: 'Host 'randomcharacterstrings.yyy.net.cable.zzzzz.com' is not allowed to connect to this MySQL server'
"

Here, 70.24.xx.xx is the external IP of my router. And I am guessing the Host 'randomcharacterstrings.yyy.net.cable.zzzzz.com' is the name that My ISP uses (the name of my router?).

Any ideas of what the problem is?

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 3rd July 2006, 23:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

You must use the hostname that is listed in the mysql.user table in the MySQL database. You can also change the hostname there or put % instead of a hostname there (% allows connections with all hostnames). Restart MySQL afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Email seemingly not working... Duplex Installation/Configuration 11 19th April 2006 14:48
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30
Ispconfig and Virtuemart shajazzi Installation/Configuration 7 21st February 2006 20:25
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 22:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.