Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd September 2011, 04:21
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default Pure-FTPd configuration

Hi there

I'd like to enable file transfer resume on Pure-FTPd server, on my ISPConfig3 installation.

The reason is that I have large (2GB +) files to transfer by SFTP or FTPS.

Is this something I should do through ISPConfig interface, config files, or through Pure-FTPd config files?

If so, please can someone tell me where to look?

Thanks,

Mat
Reply With Quote
Sponsored Links
  #2  
Old 23rd September 2011, 09:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,415
Thanks: 812
Thanked 5,204 Times in 4,080 Posts
Default

This has to be configured in the pure-ftpd config files. Which Linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd September 2011, 13:06
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Hi,

I'm using Debian Squeeze.

There are a bunch of files in /etc/pure-ftpd/conf

Each file is a setting. Do I need to create a new file?

- I read somewhere that by setting an option called "KeepAllFiles", this prevents users from deleting files as well as allowing resume upload. Is that right? I don't want to prevent users from deleting files. I just want to be able to resume upload.

- I also read somewhere that there is a 2GB file size limit for resuming uploads. (i.e. if the file is over 2GB, upload will not resume). My question is: why?! And can I stop that?

Do I need to configure a new FTP daemon if I need file upload resume AND ability to delete files?

Sorry for all the questions. The pure-ftpd docs are ... shall we say, not clear on the matter!
Reply With Quote
  #4  
Old 26th September 2011, 04:54
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quick bump -

Does anyone know how to configure file upload resume *but* also not prevent file deletions with pure-ftpd? (On Debian Squeeze)

Thanks!

Mat
Reply With Quote
  #5  
Old 26th September 2011, 09:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

I've just taken a look at pure-ftpd's man page, but could not find anything about upload resume...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 27th September 2011, 22:44
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 386
Thanks: 28
Thanked 58 Times in 50 Posts
Default

Quote:
Originally Posted by msp View Post
I'd like to enable file transfer resume on Pure-FTPd server, on my ISPConfig3 installation.
Have you confirmed that resuming file transfers does not already function as expected (by default)?

If so, is there a particular error message that the client or server produces when resuming is unsuccessful?

Finally, is your system architecture 64-bit and is large file support enabled in pureFTPd?

See this thread, too: http://www.howtoforge.com/forums/arc...p/t-46972.html

Last edited by cbj4074; 27th September 2011 at 22:56.
Reply With Quote
  #7  
Old 28th September 2011, 01:55
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
 
Default

Quote:
Originally Posted by cbj4074 View Post
Have you confirmed that resuming file transfers does not already function as expected (by default)?

If so, is there a particular error message that the client or server produces when resuming is unsuccessful?
Yes - file resume to other FTP servers (i.e. other hosting providers with their own FTP servers) always works but it doesn't work on my own private server.

There is no error. My client (Filezilla for Windows - very common open source client) prompts for the action if a file exists: restart transfer, resume, skip, etc. When you click "resume transfer", it doesn't error, the log of the ftp session is completely as it should be (simply issues a PUT command), but it just restarts the file from 0 bytes.



Quote:
Originally Posted by cbj4074 View Post
Finally, is your system architecture 64-bit and is large file support enabled in pureFTPd?

See this thread, too: http://www.howtoforge.com/forums/arc...p/t-46972.html
I haven't been able to check whether I installed a 64 or 32 OS, I'll check.

I haven't made any changes to the daemon since installing the recommended setup for Debian Squeeze.
Reply With Quote
Reply

Bookmarks

Tags
ftp, resume, upload

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freeradius and Mysql uvstudios HOWTO-Related Questions 4 19th February 2014 12:11
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
FreeRadius + MySQL working, but I don't know how to customise SQL queries awe Installation/Configuration 4 4th April 2010 23:28
squirrelmail and postfix witoszek General 12 1st December 2009 18:07
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15


All times are GMT +2. The time now is 14:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.