#1  
Old 4th June 2011, 18:02
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
Default ERROR 403 - Forbidden!

Hi all!

I got problem with SMF packages when I try to upload Tinyportal. I get error message: "You cannot download or install new packages because the Packages directory or one of the files in it are not writable!" and I search after solution and found problem that owner permissions is a need but i don't know which owner I need to change so I try with www-data:www-data and I get error page and all files and directives in /web is empty but SMF is still there on website. What can I doing to get work again? I have try change owner to root, administrator and such, not success

I did create folder "temp" in Packages and change permission to 777 but it don't works too.
Reply With Quote
Sponsored Links
  #2  
Old 4th June 2011, 21:10
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
Default

Okay, I got ftp works now but website does still problem.

I did just change owner permission: web3:www-data

Any have idea why do it problem?
Reply With Quote
  #3  
Old 5th June 2011, 14:11
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
Default

Now website is working! But still problem with package upload and cannot find solution. Any know how to solve this problem with owner permission?
Reply With Quote
  #4  
Old 6th June 2011, 10:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,082
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

you use the wrong website settings and permossions. Please reconfigure the website:

suexec: on
php mode: php-fcgi

owner of all files and folders have to be web user and client group of this website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 6th June 2011, 21:09
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post
you use the wrong website settings and permossions. Please reconfigure the website:

suexec: on
php mode: php-fcgi

owner of all files and folders have to be web user and client group of this website.
Thank you for reply. Suexec is enable and owner permission is changed and it show the forbidden page

Only web3:www-data is working.
Reply With Quote
  #6  
Old 7th June 2011, 09:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,082
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

You use the wrong ownerships. As I explained above, the file owner ahs tpo be the web user and client group and not web user and www-data group. Make sure that you changed all folders and files incl. the web folder and that you have set the permissions to e.g. 755 and not 777!
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 7th June 2011, 10:02
Kozley Kozley is offline
Member
 
Join Date: Mar 2011
Location: Örebro, Sweden
Posts: 41
Thanks: 4
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by till View Post
You use the wrong ownerships. As I explained above, the file owner ahs tpo be the web user and client group and not web user and www-data group. Make sure that you changed all folders and files incl. the web folder and that you have set the permissions to e.g. 755 and not 777!
Thanks you so much! I trough it was 777 but changed to 755 and change back to rigth owner permission with web3:client0 and the error page is gone. Now it works
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sites aren't showing up jopa123 Server Operation 9 9th May 2011 17:41
My Ispconfig UI is not totally loading when i log in wachira General 23 2nd February 2011 20:11
Can't access to my website - after install problem pallermo Installation/Configuration 18 4th June 2010 13:29
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
IMAP doesn't work..as i followed the Perfect Setup for Fedora 4 asokaajay Server Operation 11 10th June 2007 14:57


All times are GMT +2. The time now is 17:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.