#1  
Old 26th May 2011, 23:22
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 38
Thanked 86 Times in 68 Posts
Default Billing module and Paypal IPN

Hello,

I'm using the ipnproxy.php suggested because my server use https and port 8080. In global settings is set to http://www.domain.de/ipnproxy.php but when a customer try to pay a invoice always get a redirection to http://domain.de:8080/billing/paymen...?id=xxxxxxxxxx (without https) error 404. I have re-checked permissions and owner from the script. php5-curl is installed. I have changed urls to test but I get the redirection and 404, no matter I do I get the same redirection.

Any idea?

Cheers!
Reply With Quote
Sponsored Links
  #2  
Old 27th May 2011, 09:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please check that the URL to the ispconfig ipn page in the ipnproxy.php script is correct. You can do this by opening the the URL in the browser, you should get then a message like this "Direct access not allowed!".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th May 2011, 17:09
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 38
Thanked 86 Times in 68 Posts
Default

It work without problem Till.
Reply With Quote
  #4  
Old 27th May 2011, 20:20
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 38
Thanked 86 Times in 68 Posts
Default

...Nothing to do.

When I click in "pay now" I always get redirection to:

http://xxx.com:8080/billing/payments...xxxxxxxxxxxxxx

Code:
Bad Request

Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Hint: https://server.xxx.com:8080/
Changing manually the http for https works. My ispconfig is on port 8080 and I use ssl certificate (self-signed).

Is the get_ispconfig_url function working correctly??

Cheers!
Reply With Quote
  #5  
Old 31st May 2011, 21:45
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 38
Thanked 86 Times in 68 Posts
 
Default

Till I need you!

No matter you set in the paypal ipn field doesn't works but the value is in the "invoice_settings" table.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 Server Module for WHMCS Germanius Tips/Tricks/Mods 154 26th March 2014 20:58
Billing Module / Faktura maarz General 11 11th February 2010 09:40


All times are GMT +2. The time now is 20:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.